aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-10-19 14:35:48 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-10-20 20:15:19 +0300
commit348491d105df0f8dfc19b40f4cabd5120d453139 (patch)
treef6437971fdc3677eb98f7ea64d6546d5809ab36a
parent0b51cdda2778ca9fef1c3fe08bde9271179f2cdb (diff)
downloadaports-348491d105df0f8dfc19b40f4cabd5120d453139.tar.bz2
aports-348491d105df0f8dfc19b40f4cabd5120d453139.tar.xz
testing/monero: upgrade to 0.13.0.2
-rw-r--r--testing/monero/APKBUILD14
-rw-r--r--testing/monero/disable-aes-on-s390x.patch27
-rw-r--r--testing/monero/easylogging.patch10
-rw-r--r--testing/monero/system-miniupnpc.patch90
4 files changed, 57 insertions, 84 deletions
diff --git a/testing/monero/APKBUILD b/testing/monero/APKBUILD
index 9902789831..663e1662b6 100644
--- a/testing/monero/APKBUILD
+++ b/testing/monero/APKBUILD
@@ -1,17 +1,16 @@
# Contributor: André Klitzing <aklitzing@gmail.com>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=monero
-pkgver=0.12.3.0
-pkgrel=1
+pkgver=0.13.0.2
+pkgrel=0
pkgdesc="Secure, private, untraceable cryptocurrency"
url="https://getmonero.org/"
arch="all"
license="BSD"
-makedepends="unbound-dev libressl-dev boost-dev miniupnpc-dev cmake cppzmq zeromq-dev rapidjson-dev"
+makedepends="unbound-dev libressl-dev boost-dev miniupnpc-dev cmake cppzmq zeromq-dev rapidjson-dev readline-dev libsodium-dev"
options="!check"
source="$pkgname-$pkgver.tar.gz::https://github.com/monero-project/$pkgname/archive/v$pkgver.tar.gz
easylogging.patch
- disable-aes-on-s390x.patch
system-miniupnpc.patch
"
builddir="$srcdir/"$pkgname-$pkgver
@@ -32,7 +31,6 @@ package() {
install -m755 -t "${pkgdir}"/usr/bin build/bin/*
}
-sha512sums="9e78a66c2f76ebcefd355442f659a9a02298ec34ffca5ee514763b688d999da25cd1b96dd98255bacda7448e783b1c52e8d9effbbf3a75d1f0be1b5788d4b1ca monero-0.12.3.0.tar.gz
-71bb3dd1943dd0850221445e93e07597019691a94bf776950ee2bdb334a670d9ec64fb036f42c5df2846493a0aa4f803c7cb46560fcdb5264cf3d8909d66cef0 easylogging.patch
-b6f2a60822d0ad59b15766d84ec69f99aedac01697097244683f52e9bc24e98f2ba3ddf58d7d26055ff075dcc6894f173099b1213b04f281435ee051ad967e90 disable-aes-on-s390x.patch
-5abfc9248cf11bc86441622bc7cfd74c52746907fb0fce38a94d6be48d266e779d61135b7911076f11c967d6b8cb065d10aaab38d299a67698b5c8ff41d22d55 system-miniupnpc.patch"
+sha512sums="6e139774188752d4f632bc8161d695c2a13b44c62b52d55a7ce55725d0f5885c2634670a4206d57e76ce56c9b4e3755aa43199df709ad91f1a639511f8ee9b29 monero-0.13.0.2.tar.gz
+1cc51b85fdf15414421f76de04cf6736db1cbed99d1a08709ff99f2fc2597ccb1cb9940692c2d55fcbb3ed6a85d3704540ddbf86111943fdd09bc8e33aa245e2 easylogging.patch
+70c8e981d87442e0c8eccb6804af8ba78c312cfeb547957b20c8e4e83e533f161ce1b094891a99df4113e901f43954a0f1473e39781e8dae77faa0726132563b system-miniupnpc.patch"
diff --git a/testing/monero/disable-aes-on-s390x.patch b/testing/monero/disable-aes-on-s390x.patch
deleted file mode 100644
index 8581bb7544..0000000000
--- a/testing/monero/disable-aes-on-s390x.patch
+++ /dev/null
@@ -1,27 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -139,6 +139,10 @@
- set(PPC64LE 1)
- endif()
-
-+if(ARCH_ID STREQUAL "s390x")
-+ set(S390X 1)
-+endif()
-+
- if(WIN32 OR ARM)
- set(OPT_FLAGS_RELEASE "-O2")
- else()
-@@ -592,10 +596,12 @@
- message(STATUS "AES support explicitly disabled")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -DNO_AES")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DNO_AES")
-- elseif(NOT ARM AND NOT PPC64LE)
-+ elseif(NOT ARM AND NOT PPC64LE AND NOT S390X)
- message(STATUS "AES support enabled")
- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -maes")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -maes")
-+ elseif(S390X)
-+ message(STATUS "AES support not available on s390x")
- elseif(PPC64LE)
- message(STATUS "AES support not available on ppc64le")
- elseif(ARM6)
diff --git a/testing/monero/easylogging.patch b/testing/monero/easylogging.patch
index 27082046be..3228501a47 100644
--- a/testing/monero/easylogging.patch
+++ b/testing/monero/easylogging.patch
@@ -1,11 +1,11 @@
---- a/external/easylogging++/easylogging++.h
-+++ b/external/easylogging++/easylogging++.h
-@@ -200,7 +200,7 @@
+--- a/external/easylogging++/easylogging++.h 2018-10-10 13:06:21.126417347 +0200
++++ b/external/easylogging++/easylogging++.h 2018-10-10 13:07:35.488416829 +0200
+@@ -205,7 +205,7 @@
# define ELPP_INTERNAL_INFO(lvl, msg)
#endif // (defined(ELPP_DEBUG_INFO))
#if (defined(ELPP_FEATURE_ALL)) || (defined(ELPP_FEATURE_CRASH_LOG))
--# if (ELPP_COMPILER_GCC && !ELPP_MINGW && !ELPP_OS_OPENBSD)
-+# if (__has_include(<execinfo.h>) && ELPP_COMPILER_GCC && !ELPP_MINGW && !ELPP_OS_OPENBSD)
+-# if (ELPP_COMPILER_GCC && !ELPP_MINGW && !ELPP_OS_OPENBSD && !ELPP_OS_NETBSD)
++# if ( __has_include(<execinfo.h>) && ELPP_COMPILER_GCC && !ELPP_MINGW && !ELPP_OS_OPENBSD && !ELPP_OS_NETBSD)
# define ELPP_STACKTRACE 1
# else
# define ELPP_STACKTRACE 0
diff --git a/testing/monero/system-miniupnpc.patch b/testing/monero/system-miniupnpc.patch
index 5cc25a570e..3742ce525c 100644
--- a/testing/monero/system-miniupnpc.patch
+++ b/testing/monero/system-miniupnpc.patch
@@ -15,11 +15,36 @@
# Final setup for libunbound
include_directories(${UNBOUND_INCLUDE})
link_directories(${UNBOUND_LIBRARY_DIRS})
-diff --git a/external/CMakeLists.txt b/external/CMakeLists.txt
-index 1fc4d64c..b4f712ee 100644
---- a/external/CMakeLists.txt
-+++ b/external/CMakeLists.txt
-@@ -34,21 +34,42 @@
+diff --git a/src/p2p/net_node.inl b/src/p2p/net_node.inl
+index 9b21705e..76340a22 100644
+--- a/src/p2p/net_node.inl
++++ b/src/p2p/net_node.inl
+@@ -49,9 +49,16 @@
+ #include "storages/levin_abstract_invoke2.h"
+ #include "cryptonote_core/cryptonote_core.h"
+
+-#include <miniupnp/miniupnpc/miniupnpc.h>
+-#include <miniupnp/miniupnpc/upnpcommands.h>
+-#include <miniupnp/miniupnpc/upnperrors.h>
++// We have to look for miniupnpc headers in different places, dependent on if its compiled or external
++#ifdef UPNP_STATIC
++ #include <miniupnp/miniupnpc/miniupnpc.h>
++ #include <miniupnp/miniupnpc/upnpcommands.h>
++ #include <miniupnp/miniupnpc/upnperrors.h>
++#else
++ #include "miniupnpc.h"
++ #include "upnpcommands.h"
++ #include "upnperrors.h"
++#endif
+
+ #undef MONERO_DEFAULT_LOG_CATEGORY
+ #define MONERO_DEFAULT_LOG_CATEGORY "net.p2p"
+--
+2.17.0
+
+--- a/external/CMakeLists.txt 2018-10-10 13:13:55.759414180 +0200
++++ b/external/CMakeLists.txt 2018-10-10 13:19:33.363411827 +0200
+@@ -34,22 +34,46 @@
# We always compile if we are building statically to reduce static dependency issues...
# ...except for FreeBSD, because FreeBSD is a special case that doesn't play well with
# others.
@@ -28,18 +53,25 @@ index 1fc4d64c..b4f712ee 100644
+endif()
-find_package(Miniupnpc REQUIRED)
+-
+-message(STATUS "Using in-tree miniupnpc")
+-add_subdirectory(miniupnp/miniupnpc)
+-set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
+-if(MSVC)
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
+-elseif(NOT MSVC)
+- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -Wno-undef -Wno-unused-result -Wno-unused-value")
+# If we have the correct shared version and we're not building static, use it
+if(STATIC OR IOS)
+ set(USE_SHARED_MINIUPNPC false)
+elseif(MINIUPNP_FOUND AND MINIUPNPC_VERSION_1_7_OR_HIGHER)
+ set(USE_SHARED_MINIUPNPC true)
-+endif()
-
--message(STATUS "Using in-tree miniupnpc")
+ endif()
++
++
+if(USE_SHARED_MINIUPNPC)
+ message(STATUS "Using shared miniupnpc found at ${MINIUPNP_INCLUDE_DIR}")
-
--add_subdirectory(miniupnp/miniupnpc)
++
+ set(UPNP_STATIC false PARENT_SCOPE)
+ set(UPNP_INCLUDE ${MINIUPNP_INCLUDE_DIR} PARENT_SCOPE)
+ set(UPNP_LIBRARIES ${MINIUPNP_LIBRARY} PARENT_SCOPE)
@@ -49,13 +81,6 @@ index 1fc4d64c..b4f712ee 100644
+ else()
+ message(STATUS "Using miniupnpc from local source tree (/external/miniupnp/miniupnpc)")
+ endif()
-
--set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
--if(MSVC)
-- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -wd4244 -wd4267")
--elseif(NOT MSVC)
-- set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -Wno-undef -Wno-unused-result -Wno-unused-value")
--endif()
+ add_subdirectory(miniupnp/miniupnpc)
+
+ set_property(TARGET libminiupnpc-static PROPERTY FOLDER "external")
@@ -64,6 +89,10 @@ index 1fc4d64c..b4f712ee 100644
+ elseif(NOT MSVC)
+ set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -Wno-undef -Wno-unused-result -Wno-unused-value")
+ endif()
++
+ if(CMAKE_SYSTEM_NAME MATCHES "NetBSD")
+ set_property(TARGET libminiupnpc-static APPEND_STRING PROPERTY COMPILE_FLAGS " -D_NETBSD_SOURCE")
+ endif()
-set(UPNP_LIBRARIES "libminiupnpc-static" PARENT_SCOPE)
+ set(UPNP_STATIC true PARENT_SCOPE)
@@ -72,30 +101,3 @@ index 1fc4d64c..b4f712ee 100644
find_package(Unbound)
-diff --git a/src/p2p/net_node.inl b/src/p2p/net_node.inl
-index 9b21705e..76340a22 100644
---- a/src/p2p/net_node.inl
-+++ b/src/p2p/net_node.inl
-@@ -49,9 +49,16 @@
- #include "storages/levin_abstract_invoke2.h"
- #include "cryptonote_core/cryptonote_core.h"
-
--#include <miniupnp/miniupnpc/miniupnpc.h>
--#include <miniupnp/miniupnpc/upnpcommands.h>
--#include <miniupnp/miniupnpc/upnperrors.h>
-+// We have to look for miniupnpc headers in different places, dependent on if its compiled or external
-+#ifdef UPNP_STATIC
-+ #include <miniupnp/miniupnpc/miniupnpc.h>
-+ #include <miniupnp/miniupnpc/upnpcommands.h>
-+ #include <miniupnp/miniupnpc/upnperrors.h>
-+#else
-+ #include "miniupnpc.h"
-+ #include "upnpcommands.h"
-+ #include "upnperrors.h"
-+#endif
-
- #undef MONERO_DEFAULT_LOG_CATEGORY
- #define MONERO_DEFAULT_LOG_CATEGORY "net.p2p"
---
-2.17.0
-