aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-07 10:38:31 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-07 15:46:30 +0000
commit461d26a03341a7ed50480dc0676972f6b798f260 (patch)
tree54899929a601c8f690d8fd598a52787db68b67ed
parent0501504a35c990a21a588c88a04b0c050cad6f83 (diff)
downloadaports-461d26a03341a7ed50480dc0676972f6b798f260.tar.bz2
aports-461d26a03341a7ed50480dc0676972f6b798f260.tar.xz
main/dbus: upgrade to 1.12.12
-rw-r--r--main/dbus/APKBUILD19
-rw-r--r--main/dbus/fix-int64-print.patch203
2 files changed, 6 insertions, 216 deletions
diff --git a/main/dbus/APKBUILD b/main/dbus/APKBUILD
index 8d365f5b6e..cdffac116d 100644
--- a/main/dbus/APKBUILD
+++ b/main/dbus/APKBUILD
@@ -1,30 +1,23 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=dbus
-pkgver=1.10.24
-pkgrel=1
+pkgver=1.12.12
+pkgrel=0
pkgdesc="Freedesktop.org message bus system"
url="http://www.freedesktop.org/Software/dbus"
pkggroups="messagebus"
arch="all"
options="!check" # Requires running X11 server.
-license="AFL-2.1 OR GPL-2.0+"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-x11"
+license="AFL-2.1 OR GPL-2.0-or-later"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-libs $pkgname-x11 $pkgname-openrc"
triggers="$pkgname.trigger=/etc/dbus-1/system.d"
-depends=
depends_dev="util-linux-dev"
makedepends="$depends_dev expat-dev libx11-dev autoconf automake libtool xmlto
libsm-dev"
install="$pkgname.pre-install $pkgname.post-install"
source="https://dbus.freedesktop.org/releases/dbus/dbus-$pkgver.tar.gz
- fix-int64-print.patch
$pkgname.initd
"
-prepare() {
- default_prepare
- autoreconf -vif
-}
-
build() {
cd "$srcdir"/$pkgname-$pkgver
./configure \
@@ -53,6 +46,7 @@ package() {
cd "$srcdir"/$pkgname-$pkgver
make -j1 DESTDIR="$pkgdir" install
install -Dm755 "$srcdir"/dbus.initd "$pkgdir"/etc/init.d/dbus
+ rm -rf "$pkgdir"/usr/lib/systemd
}
libs() {
@@ -69,6 +63,5 @@ x11() {
mv "$pkgdir"/usr/bin/dbus-launch "$subpkgdir"/usr/bin/
}
-sha512sums="fc0b88b756affdb4fc7a62e84a6f7757121293afeadc38acf8aac48b6c2b82531e136a575be2ab503a39d7669cb7b609a021e20c1064e28c965c091e94c4f68c dbus-1.10.24.tar.gz
-5f07d8cb377ab80c927a77236c3f3437f08351161e594c62a1ad43f0324c2dba3cc98d50257ae27b9a4f5148571c5f26f35db8b40f13c72e92f267d5356c87f0 fix-int64-print.patch
+sha512sums="51af4e86ab7d36e1c9a861164e7cd7aa1605fdd82f90aed8728b34c45a87864a00671de9db00d88ea6f96be97459c7eb53d2517ea9d9687ae9ebf81c58c3a80f dbus-1.12.12.tar.gz
df74e7d6a4f76f777d356e94bd23422b17656aa51a5b2d3c655fcabb32c84f2f06b9f5cd8827920d51842f89e8c0d968a6e723315e4bf216e55711fcda9b0ee9 dbus.initd"
diff --git a/main/dbus/fix-int64-print.patch b/main/dbus/fix-int64-print.patch
deleted file mode 100644
index 2efaa8a006..0000000000
--- a/main/dbus/fix-int64-print.patch
+++ /dev/null
@@ -1,203 +0,0 @@
-From 855409c57d160e03ccd9e6a663884362a777b076 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Fri, 18 Sep 2015 15:27:50 +0200
-Subject: [PATCH] Use C99 standard PRI*64 for printing 64 bit integers
-
-Use the standard C99 PRI*64 macros instead of checking for specific GNU
-libc version. We also specifically check for windows which does not have
-proper C99 support.
-
-This fixes printing of int64 on non-GNU 32 bit systems (like musl libc).
-
-Bug: https://bugs.freedesktop.org/show_bug.cgi?id=92043
----
- configure.ac | 39 --------------------------------------
- dbus/dbus-marshal-basic.c | 8 +++++---
- dbus/dbus-marshal-recursive-util.c | 8 +++++---
- tools/dbus-print-message.c | 21 ++++++++++----------
- 4 files changed, 21 insertions(+), 55 deletions(-)
-
-diff --git a/configure.ac b/configure.ac
-index 529e960..4c1fe5b 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -337,31 +337,6 @@ if test x$enable_compiler_coverage = xyes; then
- AC_DEFINE_UNQUOTED(DBUS_GCOV_ENABLED, 1, [Defined if gcov is enabled to force a rebuild due to config.h changing])
- fi
-
--# glibc21.m4 serial 3
--dnl Copyright (C) 2000-2002, 2004 Free Software Foundation, Inc.
--dnl This file is free software; the Free Software Foundation
--dnl gives unlimited permission to copy and/or distribute it,
--dnl with or without modifications, as long as this notice is preserved.
--
--# Test for the GNU C Library, version 2.1 or newer.
--# From Bruno Haible.
--
--AC_CACHE_CHECK(whether we are using the GNU C Library 2.1 or newer,
-- ac_cv_gnu_library_2_1,
-- [AC_EGREP_CPP([Lucky GNU user],
-- [
--#include <features.h>
--#ifdef __GNU_LIBRARY__
-- #if (__GLIBC__ == 2 && __GLIBC_MINOR__ >= 1) || (__GLIBC__ > 2)
-- Lucky GNU user
-- #endif
--#endif
-- ],
-- ac_cv_gnu_library_2_1=yes,
-- ac_cv_gnu_library_2_1=no)
-- ]
--)
--
- #### Integer sizes
-
- AC_CHECK_SIZEOF(char)
-@@ -380,32 +355,21 @@ $ac_cv_sizeof_int)
- dbusint64=int
- dbusint64_constant='(val)'
- dbusuint64_constant='(val)'
-- dbusint64_printf_modifier='""'
- ;;
- $ac_cv_sizeof_long)
- dbusint64=long
- dbusint64_constant='(val##L)'
- dbusuint64_constant='(val##UL)'
-- dbusint64_printf_modifier='"l"'
- ;;
- $ac_cv_sizeof_long_long)
- dbusint64='long long'
- dbusint64_constant='(val##LL)'
- dbusuint64_constant='(val##ULL)'
-- # Ideally we discover what the format is, but this is
-- # only used in verbose mode, so eh...
-- if test x"$ac_cv_gnu_library_2_1" = xyes; then
-- dbusint64_printf_modifier='"ll"'
-- fi
- ;;
- $ac_cv_sizeof___int64)
- dbusint64=__int64
- dbusint64_constant='(val##i64)'
- dbusuint64_constant='(val##ui64)'
-- # See above case
-- if test x"$ac_cv_gnu_library_2_1" = xyes; then
-- dbusint64_printf_modifier='"ll"'
-- fi
- ;;
- esac
-
-@@ -423,9 +387,6 @@ Please report a bug here with details of your platform and compiler:
- DBUS_INT64_TYPE="$dbusint64"
- DBUS_INT64_CONSTANT="$dbusint64_constant"
- DBUS_UINT64_CONSTANT="$dbusuint64_constant"
-- if test x"$dbusint64_printf_modifier" != x; then
-- AC_DEFINE_UNQUOTED(DBUS_INT64_PRINTF_MODIFIER, [$dbusint64_printf_modifier], [Define to printf modifier for 64 bit integer type])
-- fi
- AC_MSG_RESULT($DBUS_INT64_TYPE)
- ])
-
-diff --git a/dbus/dbus-marshal-basic.c b/dbus/dbus-marshal-basic.c
-index 74fe3f9..9315b6e 100644
---- a/dbus/dbus-marshal-basic.c
-+++ b/dbus/dbus-marshal-basic.c
-@@ -29,6 +29,10 @@
-
- #include <string.h>
-
-+#if !defined(PRIx64) && defined(DBUS_WIN)
-+#define PRIx64 "%I64x"
-+#endif
-+
- #if defined(__GNUC__) && (__GNUC__ >= 4)
- # define _DBUS_ASSERT_ALIGNMENT(type, op, val) \
- _DBUS_STATIC_ASSERT (__extension__ __alignof__ (type) op val)
-@@ -1334,10 +1338,8 @@ _dbus_verbose_bytes (const unsigned char *data,
- if (i > 7 &&
- _DBUS_ALIGN_ADDRESS (&data[i], 8) == &data[i])
- {
--#ifdef DBUS_INT64_PRINTF_MODIFIER
-- _dbus_verbose (" u64: 0x%" DBUS_INT64_PRINTF_MODIFIER "x",
-+ _dbus_verbose (" u64: 0x%" PRIx64,
- *(dbus_uint64_t*)&data[i-8]);
--#endif
- _dbus_verbose (" dbl: %g",
- *(double*)&data[i-8]);
- }
-diff --git a/dbus/dbus-marshal-recursive-util.c b/dbus/dbus-marshal-recursive-util.c
-index 3bc26a8..4d57f49 100644
---- a/dbus/dbus-marshal-recursive-util.c
-+++ b/dbus/dbus-marshal-recursive-util.c
-@@ -31,6 +31,10 @@
- #include "dbus-internals.h"
- #include <string.h>
-
-+#if !defined(PRIx64) && defined(DBUS_WIN)
-+#define PRIx64 "%I64x"
-+#endif
-+
- static void
- basic_value_zero (DBusBasicValue *value)
- {
-@@ -2644,12 +2648,10 @@ double_read_value (TestTypeNode *node,
-
- if (!_DBUS_DOUBLES_BITWISE_EQUAL (v, expected))
- {
--#ifdef DBUS_INT64_PRINTF_MODIFIER
-- _dbus_warn ("Expected double %g got %g\n bits = 0x%" DBUS_INT64_PRINTF_MODIFIER "x vs.\n bits = 0x%" DBUS_INT64_PRINTF_MODIFIER "x)\n",
-+ _dbus_warn ("Expected double %g got %g\n bits = 0x%" PRIx64 " vs.\n bits = 0x%" PRIx64 ")\n",
- expected, v,
- *(dbus_uint64_t*)(char*)&expected,
- *(dbus_uint64_t*)(char*)&v);
--#endif
- _dbus_assert_not_reached ("test failed");
- }
-
-diff --git a/tools/dbus-print-message.c b/tools/dbus-print-message.c
-index 80c9698..04b817e 100644
---- a/tools/dbus-print-message.c
-+++ b/tools/dbus-print-message.c
-@@ -39,6 +39,15 @@
-
- #include "tool-common.h"
-
-+#if defined(DBUS_WIN)
-+#if !defined(PRId64)
-+#define PRId64 "%I64d"
-+#endif
-+#if !defined(PRIu64)
-+#define PRIu64 "%I64u"
-+#endif
-+#endif
-+
- static const char*
- type_to_name (int message_type)
- {
-@@ -384,11 +393,7 @@ print_iter (DBusMessageIter *iter, dbus_bool_t literal, int depth)
- {
- dbus_int64_t val;
- dbus_message_iter_get_basic (iter, &val);
--#ifdef DBUS_INT64_PRINTF_MODIFIER
-- printf ("int64 %" DBUS_INT64_PRINTF_MODIFIER "d\n", val);
--#else
-- printf ("int64 (omitted)\n");
--#endif
-+ printf ("int64 %" PRId64 "\n", val);
- break;
- }
-
-@@ -396,11 +401,7 @@ print_iter (DBusMessageIter *iter, dbus_bool_t literal, int depth)
- {
- dbus_uint64_t val;
- dbus_message_iter_get_basic (iter, &val);
--#ifdef DBUS_INT64_PRINTF_MODIFIER
-- printf ("uint64 %" DBUS_INT64_PRINTF_MODIFIER "u\n", val);
--#else
-- printf ("uint64 (omitted)\n");
--#endif
-+ printf ("uint64 %" PRIu64 "\n", val);
- break;
- }
-
---
-2.5.3
-