aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-08 09:54:22 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-08 13:17:59 +0000
commit6a2548ebf9f70fdf4c367477f3308b3f26a99e38 (patch)
treebc8539f0098c26c7920ffa4c437d87d7a627854c
parent17a04e76bd61d4185c71f3f31227786a17caec74 (diff)
downloadaports-6a2548ebf9f70fdf4c367477f3308b3f26a99e38.tar.bz2
aports-6a2548ebf9f70fdf4c367477f3308b3f26a99e38.tar.xz
testing/zbar: upgrade to 0.22
-rw-r--r--testing/zbar/APKBUILD68
-rw-r--r--testing/zbar/imagemagick7.patch23
-rw-r--r--testing/zbar/magickwand.patch147
3 files changed, 74 insertions, 164 deletions
diff --git a/testing/zbar/APKBUILD b/testing/zbar/APKBUILD
index 4bfb2ea26f..d4e725d36c 100644
--- a/testing/zbar/APKBUILD
+++ b/testing/zbar/APKBUILD
@@ -1,37 +1,71 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Diego Queiroz <diego.queiroz@gmail.com>
# Maintainer: Diego Queiroz <diego.queiroz@gmail.com>
pkgname=zbar
-pkgver=0.10
-pkgrel=3
+pkgver=0.22
+pkgrel=0
pkgdesc="Port of ZBAR BAR CODE READER"
url="http://zbar.sourceforge.net/"
-arch="all !aarch64"
+arch="all"
license="LGPL-2.0-or-later"
depends="py-gobject"
-makedepends="imagemagick-dev gtk+-dev py-gtk-dev qt-dev libtool lcms2-dev autoconf python2-dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
-source="https://sourceforge.net/projects/zbar/files/zbar/$pkgver/zbar-$pkgver.tar.bz2
- magickwand.patch
+makedepends="imagemagick-dev gtk+-dev py-gtk-dev qt5-qtx11extras-dev
+ lcms2-dev python2-dev automake autoconf libtool xmlto docbook-xsl
+ libxv-dev"
+subpackages="
+ $pkgname-dev
+ $pkgname-doc
+ lib$pkgname:zbarlibs
+ lib${pkgname}qt:qtlibs
+ lib${pkgname}gtk:gtklibs
+ py2-${pkgname}:py"
+source="
+ $pkgname-$pkgver.tar.gz::https://github.com/mchehab/zbar/archive/$pkgver.tar.gz
+ imagemagick7.patch
"
-builddir="$srcdir"/zbar-$pkgver
prepare() {
default_prepare
- update_config_guess
- autoconf
+ autoreconf -fi
}
build() {
- cd "$builddir"
- ./configure --prefix=/usr --disable-video || return 1
- make || return 1
+ ./configure --prefix=/usr --disable-video
+ make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
+ rm -rf "$pkgdir"/usr/lib/*.a
}
-sha512sums="76cb8a469e3ac9ea7932a95c500cf933501249cdb8dce4df558bf5681bd44c62111327b494e6e887079a5fd30b32154887dcc12962e6d27b1453f55457483db4 zbar-0.10.tar.bz2
-d134c4d44364638250e31d8acf45dc87624bf84005ede95859712e97fa14f7f43347ad488357e48c27c1dd69dacbb454c8dab6a3cd28e4c4c8952f4b950e72f7 magickwand.patch"
+zbarlibs() {
+ depends=""
+ pkgdesc="$pkgdesc (library)"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libzbar.so.* "$subpkgdir"/usr/lib
+}
+
+qtlibs() {
+ depends=""
+ pkgdesc="$pkgdesc (Qt5 library)"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libzbarqt.so.* "$subpkgdir"/usr/lib
+}
+
+gtklibs() {
+ depends=""
+ pkgdesc="$pkgdesc (Gtk+2 library)"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/libzbargtk.so.* "$subpkgdir"/usr/lib
+}
+
+py() {
+ depends=""
+ pkgdesc="python2 bindings for ZBar"
+ mkdir -p "$subpkgdir"/usr/lib
+ mv "$pkgdir"/usr/lib/python2* "$subpkgdir"/usr/lib
+}
+
+sha512sums="bef1078f7fe0c943e2ca7348f45e3bb5744e807c5135051fccf2c4499d52515558e98f61620e2ef2c993f35b8104d886d0639b7f0e6f8979caa5dcc49df7c931 zbar-0.22.tar.gz
+64d97d3c7e3aa0227dea7e152ad70ebb1612b5944cfbbb18c4c77ea5498b0a995d70a9e8953eb6bf93357e38af573b64f8e5020e4f586f6bbdb3f527fc5a6bc5 imagemagick7.patch"
diff --git a/testing/zbar/imagemagick7.patch b/testing/zbar/imagemagick7.patch
new file mode 100644
index 0000000000..b3cbf1e5c4
--- /dev/null
+++ b/testing/zbar/imagemagick7.patch
@@ -0,0 +1,23 @@
+--- zbar-0.10/configure.ac~ 2016-12-20 09:17:33.000000000 +0100
++++ zbar-0.10/configure.ac 2016-12-20 09:21:38.906665127 +0100
+@@ -333,7 +333,7 @@
+ dnl double check ImageMagick install (bug #2582232)
+ CPPFLAGS_save="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $MAGICK_CFLAGS"
+- AC_CHECK_HEADER([wand/MagickWand.h],
++ AC_CHECK_HEADER([MagickWand/MagickWand.h],
+ [have_IM="yes"],
+ [have_IM="broken"])
+ CPPFLAGS="$CPPFLAGS_save"])])
+--- zbar-0.10/zbarimg/zbarimg.c.orig 2016-12-20 09:18:15.924187996 +0100
++++ zbar-0.10/zbarimg/zbarimg.c 2016-12-20 09:20:27.679129140 +0100
+@@ -44,7 +44,7 @@
+ #endif
+
+ #ifdef HAVE_IMAGEMAGICK
+-# include <wand/MagickWand.h>
++# include <MagickWand/MagickWand.h>
+
+ /* ImageMagick frequently changes API names - just use the original
+ * (more stable?) names to match GraphicsMagick
+
diff --git a/testing/zbar/magickwand.patch b/testing/zbar/magickwand.patch
deleted file mode 100644
index 26c7f8815f..0000000000
--- a/testing/zbar/magickwand.patch
+++ /dev/null
@@ -1,147 +0,0 @@
-diff --git a/configure.ac b/configure.ac
-index 56d3dd0..026dbcd 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -285,8 +285,8 @@ $saved_error
- dnl double check ImageMagick install (bug #2582232)
- CPPFLAGS_save="$CPPFLAGS"
- CPPFLAGS="$CPPFLAGS $MAGICK_CFLAGS"
-- AC_CHECK_HEADER([wand/MagickWand.h], [],
-- [AC_MSG_FAILURE([ImageMagick package found but wand/MagickWand.h not installed?!
-+ AC_CHECK_HEADER([MagickWand/MagickWand.h], [],
-+ [AC_MSG_FAILURE([ImageMagick package found but MagicWand/MagickWand.h not installed?!
- this is a problem with your ImageMagick install,
- please resolve the inconsistency and try again...])])
- CPPFLAGS="$CPPFLAGS_save"])
-diff --git a/zbarimg/zbarimg.c b/zbarimg/zbarimg.c
-index 5d2db34..a6bc2d1 100644
---- a/zbarimg/zbarimg.c
-+++ b/zbarimg/zbarimg.c
-@@ -38,7 +38,7 @@
- #include <assert.h>
-
- #include <zbar.h>
--#include <wand/MagickWand.h>
-+#include <MagickWand/MagickWand.h>
-
- /* in 6.4.5.4 MagickGetImagePixels changed to MagickExportImagePixels.
- * (still not sure this check is quite right...
---- ./configure.orig
-+++ ./configure
-@@ -21741,8 +21741,8 @@
- CPPFLAGS_save="$CPPFLAGS"
- CPPFLAGS="$CPPFLAGS $MAGICK_CFLAGS"
- if test "${ac_cv_header_wand_MagickWand_h+set}" = set; then
-- { $as_echo "$as_me:$LINENO: checking for wand/MagickWand.h" >&5
--$as_echo_n "checking for wand/MagickWand.h... " >&6; }
-+ { $as_echo "$as_me:$LINENO: checking for MagickWand/MagickWand.h" >&5
-+$as_echo_n "checking for MagickWand/MagickWand.h... " >&6; }
- if test "${ac_cv_header_wand_MagickWand_h+set}" = set; then
- $as_echo_n "(cached) " >&6
- fi
-@@ -21750,8 +21750,8 @@
- $as_echo "$ac_cv_header_wand_MagickWand_h" >&6; }
- else
- # Is the header compilable?
--{ $as_echo "$as_me:$LINENO: checking wand/MagickWand.h usability" >&5
--$as_echo_n "checking wand/MagickWand.h usability... " >&6; }
-+{ $as_echo "$as_me:$LINENO: checking MagickWand/MagickWand.h usability" >&5
-+$as_echo_n "checking MagickWand/MagickWand.h usability... " >&6; }
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
-@@ -21759,7 +21759,7 @@
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
- $ac_includes_default
--#include <wand/MagickWand.h>
-+#include <MagickWand/MagickWand.h>
- _ACEOF
- rm -f conftest.$ac_objext
- if { (ac_try="$ac_compile"
-@@ -21792,15 +21792,15 @@
- $as_echo "$ac_header_compiler" >&6; }
-
- # Is the header present?
--{ $as_echo "$as_me:$LINENO: checking wand/MagickWand.h presence" >&5
--$as_echo_n "checking wand/MagickWand.h presence... " >&6; }
-+{ $as_echo "$as_me:$LINENO: checking MagickWand/MagickWand.h presence" >&5
-+$as_echo_n "checking MagickWand/MagickWand.h presence... " >&6; }
- cat >conftest.$ac_ext <<_ACEOF
- /* confdefs.h. */
- _ACEOF
- cat confdefs.h >>conftest.$ac_ext
- cat >>conftest.$ac_ext <<_ACEOF
- /* end confdefs.h. */
--#include <wand/MagickWand.h>
-+#include <MagickWand/MagickWand.h>
- _ACEOF
- if { (ac_try="$ac_cpp conftest.$ac_ext"
- case "(($ac_try" in
-@@ -21834,25 +21834,25 @@
- # So? What about this header?
- case $ac_header_compiler:$ac_header_preproc:$ac_c_preproc_warn_flag in
- yes:no: )
-- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: accepted by the compiler, rejected by the preprocessor!" >&5
--$as_echo "$as_me: WARNING: wand/MagickWand.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
-- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: proceeding with the compiler's result" >&5
--$as_echo "$as_me: WARNING: wand/MagickWand.h: proceeding with the compiler's result" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: accepted by the compiler, rejected by the preprocessor!" >&5
-+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: accepted by the compiler, rejected by the preprocessor!" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: proceeding with the compiler's result" >&5
-+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: proceeding with the compiler's result" >&2;}
- ac_header_preproc=yes
- ;;
- no:yes:* )
-- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: present but cannot be compiled" >&5
--$as_echo "$as_me: WARNING: wand/MagickWand.h: present but cannot be compiled" >&2;}
-- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: check for missing prerequisite headers?" >&5
--$as_echo "$as_me: WARNING: wand/MagickWand.h: check for missing prerequisite headers?" >&2;}
-- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: see the Autoconf documentation" >&5
--$as_echo "$as_me: WARNING: wand/MagickWand.h: see the Autoconf documentation" >&2;}
-- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: section \"Present But Cannot Be Compiled\"" >&5
--$as_echo "$as_me: WARNING: wand/MagickWand.h: section \"Present But Cannot Be Compiled\"" >&2;}
-- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: proceeding with the preprocessor's result" >&5
--$as_echo "$as_me: WARNING: wand/MagickWand.h: proceeding with the preprocessor's result" >&2;}
-- { $as_echo "$as_me:$LINENO: WARNING: wand/MagickWand.h: in the future, the compiler will take precedence" >&5
--$as_echo "$as_me: WARNING: wand/MagickWand.h: in the future, the compiler will take precedence" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: present but cannot be compiled" >&5
-+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: present but cannot be compiled" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: check for missing prerequisite headers?" >&5
-+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: check for missing prerequisite headers?" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: see the Autoconf documentation" >&5
-+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: see the Autoconf documentation" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: section \"Present But Cannot Be Compiled\"" >&5
-+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: section \"Present But Cannot Be Compiled\"" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: proceeding with the preprocessor's result" >&5
-+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: proceeding with the preprocessor's result" >&2;}
-+ { $as_echo "$as_me:$LINENO: WARNING: MagickWand/MagickWand.h: in the future, the compiler will take precedence" >&5
-+$as_echo "$as_me: WARNING: MagickWand/MagickWand.h: in the future, the compiler will take precedence" >&2;}
- ( cat <<\_ASBOX
- ## ------------------------------------------- ##
- ## Report this to spadix@users.sourceforge.net ##
-@@ -21861,8 +21861,8 @@
- ) | sed "s/^/$as_me: WARNING: /" >&2
- ;;
- esac
--{ $as_echo "$as_me:$LINENO: checking for wand/MagickWand.h" >&5
--$as_echo_n "checking for wand/MagickWand.h... " >&6; }
-+{ $as_echo "$as_me:$LINENO: checking for MagickWand/MagickWand.h" >&5
-+$as_echo_n "checking for MagickWand/MagickWand.h... " >&6; }
- if test "${ac_cv_header_wand_MagickWand_h+set}" = set; then
- $as_echo_n "(cached) " >&6
- else
-@@ -21877,11 +21877,11 @@
- else
- { { $as_echo "$as_me:$LINENO: error: in \`$ac_pwd':" >&5
- $as_echo "$as_me: error: in \`$ac_pwd':" >&2;}
--{ { $as_echo "$as_me:$LINENO: error: ImageMagick package found but wand/MagickWand.h not installed?!
-+{ { $as_echo "$as_me:$LINENO: error: ImageMagick package found but MagickWand/MagickWand.h not installed?!
- this is a problem with your ImageMagick install,
- please resolve the inconsistency and try again...
- See \`config.log' for more details." >&5
--$as_echo "$as_me: error: ImageMagick package found but wand/MagickWand.h not installed?!
-+$as_echo "$as_me: error: ImageMagick package found but MagickWand/MagickWand.h not installed?!
- this is a problem with your ImageMagick install,
- please resolve the inconsistency and try again...
- See \`config.log' for more details." >&2;}