aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-02-19 18:09:35 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-02-19 14:15:37 -0300
commit6f64ca956ef1c3201f66fcece6b758af58db5b03 (patch)
tree8cf35d434bd26bf8cc20d61405f86889e4fe47ba
parent9aa445cb50c225a3d16b79417ee2e14224d5278f (diff)
downloadaports-6f64ca956ef1c3201f66fcece6b758af58db5b03.tar.bz2
aports-6f64ca956ef1c3201f66fcece6b758af58db5b03.tar.xz
testing/peek: upgrade to 1.5.0
Upstream switched to meson
-rw-r--r--testing/peek/APKBUILD37
-rw-r--r--testing/peek/CMakeLists.txt.patch30
2 files changed, 16 insertions, 51 deletions
diff --git a/testing/peek/APKBUILD b/testing/peek/APKBUILD
index 0cccce32ba..20da210070 100644
--- a/testing/peek/APKBUILD
+++ b/testing/peek/APKBUILD
@@ -1,41 +1,36 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=peek
-pkgver=1.4.0
+pkgver=1.5.0
pkgrel=0
pkgdesc="Simple animated GIF screen recorder with an easy to use interface"
url="https://github.com/phw/peek"
arch="all"
license="GPL-3.0-or-later"
depends="ffmpeg gst-plugins-good gst-plugins-bad"
-makedepends="cmake gtk+3.0-dev gettext-dev vala txt2man"
+makedepends="meson gtk+3.0-dev gettext-dev vala txt2man keybinder3-dev"
+checkdepends="appstream-glib desktop-file-utils"
subpackages="$pkgname-lang $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/phw/peek/archive/$pkgver.tar.gz
- CMakeLists.txt.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/phw/peek/archive/v$pkgver.tar.gz"
build() {
- if [ "$CBUILD" != "$CHOST" ]; then
- CMAKE_CROSSOPTS="-DCMAKE_SYSTEM_NAME=Linux -DCMAKE_HOST_SYSTEM_NAME=Linux"
- fi
- cmake \
- -DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBS=True \
- -DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_CXX_FLAGS="$CXXFLAGS" \
- -DCMAKE_C_FLAGS="$CFLAGS" \
- -DBUILD_TESTS=True \
- ${CMAKE_CROSSOPTS} .
- make
+ meson \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --mandir=/usr/share/man \
+ --localstatedir=/var \
+ --buildtype=release \
+ -Denable-filechoosernative=true \
+ . output
+ ninja -C output
}
check() {
- make test
+ ninja -C output test
}
package() {
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" ninja -C output install
}
-sha512sums="ef1723f72d1c575493b2e9192cee6038807d37d875a797781169e5f4640635deda947362dcf2e1a9149fcfe88de532b8ea05c665b14b1befaa9aa8c982d9aa31 peek-1.4.0.tar.gz
-b85268fad2d9c2845da3d5f5eee827ef330fc284a4569c862abe9da1d27bb36d72c26d9018728fdb4d51b7288b772392c65d5a4d6674037a6b37b854a23dcf8b CMakeLists.txt.patch"
+sha512sums="f4df743e8dd6e469d8bae53c8e4fdf225e6e430959e5cad1c9f3de03d385c4a00febd2c25e64afa18b5b522abb1d8915d42734c2db65118064e0d5afba96c36d peek-1.5.0.tar.gz"
diff --git a/testing/peek/CMakeLists.txt.patch b/testing/peek/CMakeLists.txt.patch
deleted file mode 100644
index 8dcbf3c217..0000000000
--- a/testing/peek/CMakeLists.txt.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 3c996ee9201f8b6d385966a2a1e60829734d9643 Mon Sep 17 00:00:00 2001
-From: Philipp Wolfer <phil@parolu.io>
-Date: Tue, 24 Sep 2019 18:36:03 +0200
-Subject: [PATCH] Fixed icon installation with cmake (#504)
-
----
- data/CMakeLists.txt | 10 ++--------
- 1 file changed, 2 insertions(+), 8 deletions(-)
-
-diff --git a/data/CMakeLists.txt b/data/CMakeLists.txt
-index ea628ba..63b4076 100644
---- a/data/CMakeLists.txt
-+++ b/data/CMakeLists.txt
-@@ -55,14 +55,8 @@ else()
- endif()
-
- # Install application icons
--install(FILES "icons/16x16/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/16x16/apps)
--install(FILES "icons/24x24/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/24x24/apps)
--install(FILES "icons/32x32/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/32x32/apps)
--install(FILES "icons/48x48/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/48x48/apps)
--install(FILES "icons/64x64/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/64x64/apps)
--install(FILES "icons/128x128/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/128x128/apps)
--install(FILES "icons/256x256/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/256x256/apps)
--install(FILES "icons/512x512/com.uploadedlobster.peek.png" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/hicolor/512x512/apps)
-+install(FILES "icons/com.uploadedlobster.peek.svg" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/scalable/apps)
-+install(FILES "icons/com.uploadedlobster.peek-symbolic.svg" DESTINATION ${CMAKE_INSTALL_DATAROOTDIR}/icons/symbolic/apps)
-
- # Install DBus service
- configure_file (