aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-19 11:39:50 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-19 11:39:50 -0300
commit782c04fb52b91f8ae381f57d8c22d7086ede1b96 (patch)
tree37a28d0a446bc4ed8940e6468bb69cfa58cd7a7b
parent8c09c335220dfb1120d92bd246771b0edac92588 (diff)
downloadaports-782c04fb52b91f8ae381f57d8c22d7086ede1b96.tar.bz2
aports-782c04fb52b91f8ae381f57d8c22d7086ede1b96.tar.xz
main/tk: make the -dev subpkg depend on tk=$pkgver-r$pkgrel
-rw-r--r--main/tk/APKBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/main/tk/APKBUILD b/main/tk/APKBUILD
index 963db46503..57f2411ee0 100644
--- a/main/tk/APKBUILD
+++ b/main/tk/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Isaac Dunham <ibid.ag@gmail.com>
pkgname=tk
pkgver=8.6.10
-pkgrel=0
+pkgrel=1
pkgdesc="GUI toolkit for the Tcl scripting language"
url="http://tcl.sourceforge.net/"
arch="all"
@@ -49,6 +49,10 @@ package() {
}
dev() {
+ # libtk8.6.so is the only library made and it remains in the mainpackage
+ # so depending on the main package automatically is never done
+ # https://gitlab.alpinelinux.org/alpine/aports/issues/11232#note_68789
+ depends_dev="$depends_dev tk=$pkgver-r$pkgrel"
default_dev
cd $pkgdir
for i in $(find . -name '*.c' -o -name '*Config.sh'); do