aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2019-10-09 13:53:22 +0200
committerRasmus Thomsen <oss@cogitri.dev>2019-10-09 22:20:44 +0200
commit7f258edab97d47d1f5b5448302e3b92197553433 (patch)
tree4e8e3ef98554257ce36d8f0b9c2387079d7abb41
parentd8b509e9b1de75279b1f27653d549def0e80b08c (diff)
downloadaports-7f258edab97d47d1f5b5448302e3b92197553433.tar.bz2
aports-7f258edab97d47d1f5b5448302e3b92197553433.tar.xz
testing/licenseheaders: new aport
-rw-r--r--testing/licenseheaders/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/licenseheaders/APKBUILD b/testing/licenseheaders/APKBUILD
new file mode 100644
index 0000000000..ffed61019c
--- /dev/null
+++ b/testing/licenseheaders/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Rasmus Thomsen <oss@cogitri.dev>
+# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
+pkgname=licenseheaders
+pkgver=0.7
+pkgrel=0
+pkgdesc="Add/Replace license headers in a directory tree of source files"
+url="https://github.com/johann-petrak/licenseheaders"
+arch="noarch"
+license="MIT"
+depends="python3 py3-regex"
+makedepends="py3-setuptools"
+options="!check" # no tests
+source="https://files.pythonhosted.org/packages/source/l/licenseheaders/licenseheaders-$pkgver.tar.gz"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="d78f091a384d2b0b1c5b40a378d2c321b2ed22a50f9386a639672ee787ddf234bccc2020c3b8363bf8c32939c89878aa3ac3aa4a3bb71ca5750e84d5debbc0a2 licenseheaders-0.7.tar.gz"