aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarlo Landmeter <clandmeter@alpinelinux.org>2019-04-24 05:45:13 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-04-24 05:46:15 +0000
commit889c76269f5db928e8abf9dc5159e57f4d8e3344 (patch)
tree6cf8067d190486a6f579d3ff585ed0cb61798ef5
parent17882b81871a8caf2bc836e9a176b9b2e6f8824a (diff)
downloadaports-889c76269f5db928e8abf9dc5159e57f4d8e3344.tar.bz2
aports-889c76269f5db928e8abf9dc5159e57f4d8e3344.tar.xz
community/fio: moved from testing and fix docs
-rw-r--r--community/fio/APKBUILD (renamed from testing/fio/APKBUILD)28
1 files changed, 8 insertions, 20 deletions
diff --git a/testing/fio/APKBUILD b/community/fio/APKBUILD
index 877e8ddb70..2ad8394953 100644
--- a/testing/fio/APKBUILD
+++ b/community/fio/APKBUILD
@@ -2,45 +2,33 @@
# Maintainer: wener <wenermail@gmail.com>
pkgname=fio
pkgver=3.13
-pkgrel=0
+pkgrel=1
pkgdesc="Flexible I/O Tester"
url="https://github.com/axboe/fio"
arch="all"
license="GPL-2.0"
-makedepends="linux-headers zlib-dev coreutils py-sphinx libaio-dev"
-case "$CARCH" in
- arm*)
- # no numactl-dev for arm
- ;;
- *)
- makedepends="$makedepends numactl-dev"
- ;;
-esac
+makedepends="linux-headers zlib-dev coreutils libaio-dev"
subpackages="$pkgname-doc"
source="$pkgname-$pkgver.tar.gz::https://github.com/axboe/fio/archive/fio-$pkgver.tar.gz"
builddir="$srcdir/fio-$pkgname-$pkgver"
+case "$CARCH" in
+ arm*) ;; # no numactl-dev for arm
+ *) makedepends="$makedepends numactl-dev" ;;
+esac
+
build() {
- cd "$builddir"
./configure --prefix=/usr
make
}
check() {
- cd "$builddir"
make test
}
-# needed to handle fio-fio-<version> directory name
-doc() {
- cd "$builddir"
- mkdir -p "$subpkgdir/usr"
- mv "$pkgdir/usr/man" "$subpkgdir/usr"
-}
-
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
+ mv "$pkgdir"/usr/man "$pkgdir"/usr/share
}
sha512sums="f3ed96bbcd16d326db331542147723f2f2d856241443a59bcd5c7f38b8ff496e16409051d7cf25571b7deb17c2f88bb1acf4199685d932a8883a40d95216a70c fio-3.13.tar.gz"