aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Pirogov <vbnet.ru@gmail.com>2020-01-14 19:29:32 +0300
committerLeo <thinkabit.ukim@gmail.com>2020-01-14 18:33:21 +0100
commit95e97b6f3fac73b312a7707ff5d608a2073a0432 (patch)
treec3884761fcb110549f9aeb61183cce8758a0090b
parent8b5c83e863e49e5d200e5339b9ec4fab16e3a42d (diff)
downloadaports-95e97b6f3fac73b312a7707ff5d608a2073a0432.tar.bz2
aports-95e97b6f3fac73b312a7707ff5d608a2073a0432.tar.xz
testing/lua-resty-lrucache: new aport
-rw-r--r--testing/lua-resty-lrucache/APKBUILD26
1 files changed, 26 insertions, 0 deletions
diff --git a/testing/lua-resty-lrucache/APKBUILD b/testing/lua-resty-lrucache/APKBUILD
new file mode 100644
index 0000000000..c23fb968aa
--- /dev/null
+++ b/testing/lua-resty-lrucache/APKBUILD
@@ -0,0 +1,26 @@
+# Contributor: Michael Pirogov <vbnet.ru@gmail.com>
+# Maintainer: Michael Pirogov <vbnet.ru@gmail.com>
+pkgname=lua-resty-lrucache
+pkgver=0.09
+pkgrel=0
+pkgdesc="Lua-land LRU Cache based on LuaJIT FFI"
+url="https://github.com/openresty/lua-resty-lrucache"
+arch="noarch"
+license="BSD-2-Clause"
+depends="lua"
+source="$pkgname-$pkgver.tar.gz::https://github.com/openresty/lua-resty-lrucache/archive/v$pkgver.tar.gz"
+options="!check" # FIXME: tests require OpenResty and additional dependencies
+
+for _v in 5.1 5.2 5.3; do
+ provides="$provides lua$_v-${pkgname#lua-}=$pkgver-r$pkgrel" # for backward compatibility
+done
+
+package() {
+ make install DESTDIR="$pkgdir" LUA_LIB_DIR="/usr/share/lua/common"
+
+ echo 'rock_manifest = {}' > rock_manifest
+ install -D -m 644 rock_manifest \
+ "$pkgdir"/usr/lib/luarocks/rocks-common/$pkgname/$pkgver-1
+}
+
+sha512sums="0042f5459a5d994ad3837ceeba7884efe85d2ab7194c8b08d026418c7c81c948ae1de91628d29afde45dae44f326fc5fb295988f24e95e5398a52014af50e3e2 lua-resty-lrucache-0.09.tar.gz"