aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-09-10 00:32:02 +0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-10 10:15:33 -0300
commitbffae3f271f373337929f3d30ec9b3ea1ae51ac2 (patch)
tree826972b709962bbd673ef5b9b1d6c29810bf177f
parent26e6f0d4abccea74826d47c5085d0252cfb069e6 (diff)
downloadaports-bffae3f271f373337929f3d30ec9b3ea1ae51ac2.tar.bz2
aports-bffae3f271f373337929f3d30ec9b3ea1ae51ac2.tar.xz
community/py-augeas: drop python2
Signed-off-by: prspkt <prspkt@protonmail.com>
-rw-r--r--community/py3-augeas/APKBUILD (renamed from community/py-augeas/APKBUILD)35
-rw-r--r--community/py3-augeas/dlopen-libc-explicitly.patch (renamed from community/py-augeas/dlopen-libc-explicitly.patch)0
2 files changed, 8 insertions, 27 deletions
diff --git a/community/py-augeas/APKBUILD b/community/py3-augeas/APKBUILD
index 1885d7c562..5446adcb9b 100644
--- a/community/py-augeas/APKBUILD
+++ b/community/py3-augeas/APKBUILD
@@ -1,53 +1,34 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
-pkgname=py-augeas
+pkgname=py3-augeas
_pkgname=python-augeas
pkgver=1.0.3
-pkgrel=3
+pkgrel=4
pkgdesc="Pure python bindings for augeas"
url="https://pypi.python.org/pypi/python-augeas"
arch="noarch"
license="LGPL-2.1-or-later"
-depends="augeas-libs py-cffi"
-makedepends="py2-setuptools py3-setuptools"
-subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
+depends="augeas-libs py3-cffi python3"
+makedepends="py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz
dlopen-libc-explicitly.patch
"
-
builddir="$srcdir"/$_pkgname-$pkgver
+replaces=py-augeas # Backwards compatibility
+provides=py-augeas=$pkgver-r$pkgrel # Backwards compatibility
+
build() {
- python2 setup.py build
python3 setup.py build
}
check() {
cd "$builddir"/test
- python2 test_augeas.py
python3 test_augeas.py
}
package() {
- mkdir -p "$pkgdir"
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc - $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
-}
-
-_py2() {
- depends="${depends//py-/py2-}"
- _py python2
-}
-
-_py3() {
- depends="${depends//py-/py3-}"
- _py python3
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
sha512sums="737b41e7bb438d80da75b55714c3f0b1706a4b2cacddd20fadf855bc3044e532f4079319b3775032e6f6009cf7f282af33fdf583332772b443a6c2d4925639fa python-augeas-1.0.3.tar.gz
diff --git a/community/py-augeas/dlopen-libc-explicitly.patch b/community/py3-augeas/dlopen-libc-explicitly.patch
index c7aa05a2b8..c7aa05a2b8 100644
--- a/community/py-augeas/dlopen-libc-explicitly.patch
+++ b/community/py3-augeas/dlopen-libc-explicitly.patch