aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-26 22:05:43 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-29 10:41:34 +0000
commitc3644c75f9ec04111ff15aee1b1b869c4e54b565 (patch)
treeb6db2d46bec4d6f84ed15852b7b6fc77703ee794
parent4d2b2c5f5ec4b20e9bfd90d63ff0b1c280d3bb11 (diff)
downloadaports-c3644c75f9ec04111ff15aee1b1b869c4e54b565.tar.bz2
aports-c3644c75f9ec04111ff15aee1b1b869c4e54b565.tar.xz
main/protobuf: fix build on mips{el} (-latomic)
32-bit MIPS (until R6) lacks instructions to implement 64-bit atomic operations so explicit linkage with libatomic is required.
-rw-r--r--main/protobuf/APKBUILD4
1 files changed, 3 insertions, 1 deletions
diff --git a/main/protobuf/APKBUILD b/main/protobuf/APKBUILD
index 6b4ee20ce6..62fc04e984 100644
--- a/main/protobuf/APKBUILD
+++ b/main/protobuf/APKBUILD
@@ -4,7 +4,7 @@ pkgname=protobuf
_gemname=google-protobuf
pkgver=3.6.1
_tstver=1.8.0
-pkgrel=0
+pkgrel=1
pkgdesc="Library for extensible, efficient structure packing"
url="https://github.com/google/protobuf"
arch="all"
@@ -34,6 +34,8 @@ prepare() {
build() {
cd "$builddir"
+ case "$CARCH" in mips|mipsel) export LIBS="$LIBS -latomic";; esac
+
CXXFLAGS="$CXXFLAGS -fno-delete-null-pointer-checks" \
./configure --prefix=/usr \
--sysconfdir=/etc \