aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2020-03-18 21:22:38 +0100
committerJakub Jirutka <jakub@jirutka.cz>2020-03-18 23:09:21 +0100
commitc6001e57e222862703ac23ca5864336d8fa1b355 (patch)
tree1e5697b806c43ead0915e122bfb38c29e4a260ef
parentcfd5c550cd3dcbb4a7f607842f69208b8e20d364 (diff)
downloadaports-c6001e57e222862703ac23ca5864336d8fa1b355.tar.bz2
aports-c6001e57e222862703ac23ca5864336d8fa1b355.tar.xz
testing/lua-resty-redis: fix dependencies and remove $provides
This module requires APIs provided by lua-nginx-module and thus it will work on LuaJIT only. Actually, it should depend on nginx-mod-http-lua or openresty, but I'd like to avoid creating some open-resty like provider now.
-rw-r--r--testing/lua-resty-redis/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/testing/lua-resty-redis/APKBUILD b/testing/lua-resty-redis/APKBUILD
index 425c6c3142..0a76707616 100644
--- a/testing/lua-resty-redis/APKBUILD
+++ b/testing/lua-resty-redis/APKBUILD
@@ -2,19 +2,15 @@
# Maintainer: Michael Pirogov <vbnet.ru@gmail.com>
pkgname=lua-resty-redis
pkgver=0.27
-pkgrel=0
+pkgrel=1
pkgdesc="Lua redis client driver for the ngx_lua based on the cosocket API"
url="https://github.com/openresty/lua-resty-redis"
arch="noarch"
license="BSD-2-Clause"
-depends="lua"
+depends="luajit"
source="https://github.com/openresty/lua-resty-redis/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
options="!check" # FIXME: tests require OpenResty and additional dependencies
-for _v in 5.1 5.2 5.3; do
- provides="$provides lua$_v-${pkgname#lua-}=$pkgver-r$pkgrel" # for backward compatibility
-done
-
package() {
make install DESTDIR="$pkgdir" LUA_LIB_DIR="/usr/share/lua/common"