aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTuan Hoang <tmhoang@linux.ibm.com>2019-03-14 16:24:40 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2019-03-22 12:32:19 +0000
commitcc5266b08b1e23a00faf34374d5c786eb87c1e90 (patch)
tree722eaa949e8bba665afe73b82e6342e51ae2eb6e
parent7c6369df8c7fc0e4ba73bf3571296c2dfb684ffd (diff)
downloadaports-cc5266b08b1e23a00faf34374d5c786eb87c1e90.tar.bz2
aports-cc5266b08b1e23a00faf34374d5c786eb87c1e90.tar.xz
main/s390-tools: upgrade to 1.37.1
Refactor patches Link libexecinfo by default globally
-rw-r--r--main/s390-tools/0002-musl-fixes.patch18
-rw-r--r--main/s390-tools/0003-major-minor.patch18
-rw-r--r--main/s390-tools/0004-missing-time-header.patch13
-rw-r--r--main/s390-tools/0005-dump2tar-linking-order.patch14
-rw-r--r--main/s390-tools/0007-tunedasd-no-need-error-h.patch8
-rw-r--r--main/s390-tools/0008-iucvterm-no-nls.patch2
-rw-r--r--main/s390-tools/0009-link-libexecinfo.patch13
-rw-r--r--main/s390-tools/0009-zdev-libexecinfo.patch11
-rw-r--r--main/s390-tools/0010-musl-s390x-signal-def.patch7
-rw-r--r--main/s390-tools/0200-dasdinfo-gnu-ext-hack.patch17
-rw-r--r--main/s390-tools/APKBUILD28
-rw-r--r--main/s390-tools/zconf-shell.patch13
12 files changed, 75 insertions, 87 deletions
diff --git a/main/s390-tools/0002-musl-fixes.patch b/main/s390-tools/0002-musl-fixes.patch
index 62af24ba1b..31271118d3 100644
--- a/main/s390-tools/0002-musl-fixes.patch
+++ b/main/s390-tools/0002-musl-fixes.patch
@@ -169,10 +169,10 @@ index f22444e..39ea480 100644
} fdasd_anchor_t;
enum offset {lower, upper};
-diff --git a/include/vtoc.h b/include/vtoc.h
+diff --git a/include/lib/vtoc.h b/include/lib/vtoc.h
index ea5b1c2..592200c 100644
---- a/include/vtoc.h
-+++ b/include/vtoc.h
+--- a/include/lib/vtoc.h
++++ b/include/lib/vtoc.h
@@ -21,6 +21,7 @@
#include <time.h>
#include <fcntl.h>
@@ -548,18 +548,6 @@ index ea5b1c2..592200c 100644
#endif /* VTOC_H */
-diff --git a/libutil/Makefile b/libutil/Makefile
-index e392bc3..2ffc49e 100644
---- a/libutil/Makefile
-+++ b/libutil/Makefile
-@@ -1,6 +1,7 @@
- include ../common.mak
-
- ALL_CPPFLAGS += -I../include
-+LDLIBS = $(LIBEXECINFO_LIBS)
-
- lib = libutil.a
-
diff --git a/libutil/util_opt.c b/libutil/util_opt.c
index a1a5cda..39540b6 100644
--- a/libutil/util_opt.c
diff --git a/main/s390-tools/0003-major-minor.patch b/main/s390-tools/0003-major-minor.patch
index 1137523212..f46f97377a 100644
--- a/main/s390-tools/0003-major-minor.patch
+++ b/main/s390-tools/0003-major-minor.patch
@@ -8,17 +8,17 @@ index fb28b1e..218dca3 100644
#include <stdio.h>
+#include <sys/sysmacros.h>
- #include "zt_common.h"
- #include "vtoc.h"
+ #include "lib/dasd_sys.h"
+ #include "lib/util_opt.h"
diff --git a/tape390/tape390_common.c b/tape390/tape390_common.c
-index f4f1433..71402b8 100644
+index 90954c0..ffe72bf 100644
--- a/tape390/tape390_common.c
+++ b/tape390/tape390_common.c
-@@ -9,6 +9,7 @@
- *************************************************************************/
-
+@@ -13,6 +13,7 @@
+ #include <stdlib.h>
+ #include <string.h>
#include <sys/stat.h>
+#include <sys/sysmacros.h>
- #include <stdio.h>
- #include <fcntl.h>
- #include <stdlib.h>
+
+ #include "tape390_common.h"
+
diff --git a/main/s390-tools/0004-missing-time-header.patch b/main/s390-tools/0004-missing-time-header.patch
index f8787743b9..896964d655 100644
--- a/main/s390-tools/0004-missing-time-header.patch
+++ b/main/s390-tools/0004-missing-time-header.patch
@@ -2,14 +2,15 @@ diff --git a/mon_tools/mon_procd.c b/mon_tools/mon_procd.c
index 9b52057..d7dbee3 100644
--- a/mon_tools/mon_procd.c
+++ b/mon_tools/mon_procd.c
-@@ -8,6 +8,7 @@
- */
- #include <unistd.h>
+@@ -24,7 +24,7 @@
+ #include <sys/statvfs.h>
#include <sys/vfs.h>
+ #include <syslog.h>
+-#include <time.h>
+#include <sys/time.h>
- #include <stdlib.h>
- #include <stdio.h>
- #include <string.h>
+ #include <unistd.h>
+ #include <utmp.h>
+
diff --git a/ziomon/ziomon_msg_tools.h b/ziomon/ziomon_msg_tools.h
index 383cdd4..1aa16ff 100644
--- a/ziomon/ziomon_msg_tools.h
diff --git a/main/s390-tools/0005-dump2tar-linking-order.patch b/main/s390-tools/0005-dump2tar-linking-order.patch
deleted file mode 100644
index 4276472ec3..0000000000
--- a/main/s390-tools/0005-dump2tar-linking-order.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Without this line, linker flags are placed before object files
-
-diff --git a/dump2tar/src/Makefile b/dump2tar/src/Makefile
-index a2ba26f..12f9034 100644
---- a/dump2tar/src/Makefile
-+++ b/dump2tar/src/Makefile
-@@ -22,6 +22,7 @@ check_dep_zlib:
- all: check_dep_zlib dump2tar
-
- dump2tar: $(core_objects) dump2tar.o $(libs)
-+ $(CC) $(core_objects) dump2tar.o $(libs) -o $@ $(ALL_LDFLAGS) $(LIBEXECINFO_LIBS)
-
- install: dump2tar
- $(INSTALL) -c dump2tar $(DESTDIR)$(USRBINDIR)
diff --git a/main/s390-tools/0007-tunedasd-no-need-error-h.patch b/main/s390-tools/0007-tunedasd-no-need-error-h.patch
index d33d7e3ada..c2eab1f1fc 100644
--- a/main/s390-tools/0007-tunedasd-no-need-error-h.patch
+++ b/main/s390-tools/0007-tunedasd-no-need-error-h.patch
@@ -2,11 +2,11 @@ diff --git a/tunedasd/src/tunedasd.c b/tunedasd/src/tunedasd.c
index 917000d..f779d5a 100644
--- a/tunedasd/src/tunedasd.c
+++ b/tunedasd/src/tunedasd.c
-@@ -17,7 +17,6 @@
- #include <stdarg.h>
+@@ -19,7 +19,6 @@
+ #include "lib/zt_common.h"
#include "disk.h"
-#include "error.h"
- #include "zt_common.h"
+ #include "tunedasd.h"
- /* Full tool name */
+ static const struct util_prg prg = {
diff --git a/main/s390-tools/0008-iucvterm-no-nls.patch b/main/s390-tools/0008-iucvterm-no-nls.patch
index eec9b170ff..c8f5e84ca8 100644
--- a/main/s390-tools/0008-iucvterm-no-nls.patch
+++ b/main/s390-tools/0008-iucvterm-no-nls.patch
@@ -5,7 +5,7 @@ index bc90aa7..9d298d8 100644
@@ -7,7 +7,7 @@ GETTEXT_TEXTDOMAIN = iucvterm
endif
- ALL_CPPFLAGS += -I../include -I../../include
+ ALL_CPPFLAGS += -I../include
-ALL_CPPFLAGS += -DUSE_NLS -DGETTEXT_TEXTDOMAIN=\"$(GETTEXT_TEXTDOMAIN)\"
+ALL_CPPFLAGS += -DGETTEXT_TEXTDOMAIN=\"$(GETTEXT_TEXTDOMAIN)\"
#ALL_CPPFLAGS += -D__DEBUG__
diff --git a/main/s390-tools/0009-link-libexecinfo.patch b/main/s390-tools/0009-link-libexecinfo.patch
new file mode 100644
index 0000000000..9902e8db7f
--- /dev/null
+++ b/main/s390-tools/0009-link-libexecinfo.patch
@@ -0,0 +1,13 @@
+diff --git a/common.mak b/common.mak
+index 175ec37..6d45e56 100644
+--- a/common.mak
++++ b/common.mak
+@@ -224,7 +224,7 @@ endif
+ $(CXX) $(ALL_CPPFLAGS) $(ALL_CXXFLAGS) -c $< -o $@
+
+ %: %.o
+- $(LINK) $(ALL_LDFLAGS) $^ $(LOADLIBES) $(LDLIBS) -o $@
++ $(LINK) $(ALL_LDFLAGS) $^ $(LOADLIBES) $(LDLIBS) $(LIBEXECINFO_LIBS) -o $@
+
+ %.a:
+ $(AR) rcs $@ $^
diff --git a/main/s390-tools/0009-zdev-libexecinfo.patch b/main/s390-tools/0009-zdev-libexecinfo.patch
deleted file mode 100644
index 3b8ef43ce8..0000000000
--- a/main/s390-tools/0009-zdev-libexecinfo.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff --git a/zdev/src/Makefile b/zdev/src/Makefile
-index f3adffc..434046f 100644
---- a/zdev/src/Makefile
-+++ b/zdev/src/Makefile
-@@ -1,6 +1,7 @@
- # Common definitions
- include ../../common.mak
-
-+LDLIBS=$(LIBEXECINFO_LIBS)
- ALL_CPPFLAGS += -I../../include -I ../include -std=gnu99 -Wno-unused-parameter \
- -Wno-missing-field-initializers
diff --git a/main/s390-tools/0010-musl-s390x-signal-def.patch b/main/s390-tools/0010-musl-s390x-signal-def.patch
index 3c26b84742..41af204771 100644
--- a/main/s390-tools/0010-musl-s390x-signal-def.patch
+++ b/main/s390-tools/0010-musl-s390x-signal-def.patch
@@ -4,12 +4,11 @@ diff --git a/zfcpdump/zfcpdump.c b/zfcpdump/zfcpdump.c
index 70df501..9d3c0f2 100644
--- a/zfcpdump/zfcpdump.c
+++ b/zfcpdump/zfcpdump.c
-@@ -11,6 +11,8 @@
+@@ -11,6 +11,7 @@
* Author(s): Michael Holzheu
*/
+#include <asm-generic/signal-defs.h>
-+
- #include <errno.h>
- #include <string.h>
+ #include <asm/types.h>
+ #include <ctype.h>
#include <dirent.h>
diff --git a/main/s390-tools/0200-dasdinfo-gnu-ext-hack.patch b/main/s390-tools/0200-dasdinfo-gnu-ext-hack.patch
index 289e670650..80ed757e14 100644
--- a/main/s390-tools/0200-dasdinfo-gnu-ext-hack.patch
+++ b/main/s390-tools/0200-dasdinfo-gnu-ext-hack.patch
@@ -2,13 +2,12 @@ diff --git a/dasdinfo/dasdinfo.c b/dasdinfo/dasdinfo.c
index 44a1178..7f65763 100644
--- a/dasdinfo/dasdinfo.c
+++ b/dasdinfo/dasdinfo.c
-@@ -32,6 +32,9 @@
-
- #define MAX(x,y) ((x)<(y)?(y):(x))
-
-+#define FTW_CONTINUE 0
-+#define FTW_STOP 1
-+
- static const char tool_name[] = "dasdinfo: zSeries DASD information program";
- static const char copyright_notice[] = "Copyright IBM Corp. 2007";
+@@ -33,6 +33,8 @@
+ #define BIODASDINFO _IOR(DASD_IOCTL_LETTER,1,struct dasd_information)
+ #define BIODASDINFO2 _IOR(DASD_IOCTL_LETTER,3,struct dasd_information2)
+ #define TEMP_DEV_MAX_RETRIES 1000
++#define FTW_CONTINUE 0
++#define FTW_STOP 1
+ static const struct util_prg prg = {
+ .desc = "Display DASD volume serial number and ID information",
diff --git a/main/s390-tools/APKBUILD b/main/s390-tools/APKBUILD
index ae71844dfa..c8a890da4e 100644
--- a/main/s390-tools/APKBUILD
+++ b/main/s390-tools/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Tuan M. Hoang <tmhoang@flatglobe.org>
pkgname=s390-tools
-pkgver=1.37.0
-pkgrel=4
+pkgver=1.37.1
+pkgrel=0
pkgdesc="Utilities for Linux on IBM z Systems"
url="http://www.ibm.com/developerworks/linux/linux390/s390-tools.html"
arch="s390x"
@@ -17,11 +17,10 @@ source="http://download.boulder.ibm.com/ibmdl/pub/software/dw/linux390/ht_src/$p
0002-musl-fixes.patch
0003-major-minor.patch
0004-missing-time-header.patch
- 0005-dump2tar-linking-order.patch
0006-define-path-mounted.patch
0007-tunedasd-no-need-error-h.patch
0008-iucvterm-no-nls.patch
- 0009-zdev-libexecinfo.patch
+ 0009-link-libexecinfo.patch
0010-musl-s390x-signal-def.patch
0100-zipl-no-pie.patch
@@ -29,6 +28,7 @@ source="http://download.boulder.ibm.com/ibmdl/pub/software/dw/linux390/ht_src/$p
0200-dasdinfo-gnu-ext-hack.patch
0300-disable-program-using-gnu-ext.patch
+ zconf-shell.patch
mk-s390-cdboot.c
"
@@ -49,19 +49,19 @@ package() {
install -Dm755 mk-s390-cdboot "$pkgdir"/sbin/mk-s390-cdboot
}
-sha512sums="3667ba4eb7e2b74629958f530002953adebe6e41d6429c99ae5f82d1406d6963aacdc35b63114683c365b9fa40ac32b4c22f226918ecb53423e80f944d24cb9c s390-tools-1.37.0.tar.bz2
+sha512sums="43a255171956aad3d04e666a2ab949f392bb8d8faca0a8f8a4714f9eabbc93e625ed0ec0cae69f05ef6a3ab86982de2a757184b771b60e927d86c931fb5cdf89 s390-tools-1.37.1.tar.bz2
3e1d0829e13bea69f48c556c2454b2927ffc59a7f4a04f7ebce41b9b5ed95ce963922fec9981e7ae62be801abbdc2cd27498399d0c4b8f9d10fae82dc3a9df85 0001-zipl-flags.patch
-53917ef77142eb1304f7a900eb9a624b5bad5b263110f5875ab7710b52350e1b56d42d048b5bedc9ee6780d9f014c903f047f25d347ba677dfe141eb125b1543 0002-musl-fixes.patch
-8a73e9d8e09af29cc04bc09a330ca019ec21bc49fe18468149458996c52e5c7951d9b917e2263162f1fd6e8a25f47c6ca737f7ceeec1d753d72f85e447a6ec01 0003-major-minor.patch
-701d42e799bb7398b391ef299eb9f5488638cd162826ac8827205741159b746cbd6f4841b54fe6eb5f11dd143f63fb9689f7373b7df7adf9dcb1b3ed620820c8 0004-missing-time-header.patch
-d4d707aadf095f48dd3ae79f60d17194e479d8a6ca08c6b6d64582e6d09b33d7d065a7349cc7fe61f2b20bad6d9436db5d736edd7fc673fc7982f8a22f48050a 0005-dump2tar-linking-order.patch
+658b804edfef85e63c5df7a23dccff5a53c3ab5b310b81b1e584c672070d7cec64ac78624de282e535227517e405ff33003a2ddc5f1f4ec7d4edf6e125305638 0002-musl-fixes.patch
+d8936addbf7713d14a44f9137c19769eb66f9c1d8ddc7dc58a7abbe4791045ed3c6eca88e2bbf8a6d3b18d8e437481df95d1827722bb1f7e093aa86753be85d1 0003-major-minor.patch
+5cadad403b0bce9c92e326612b2fa6d32b15b550ef9241fd77cc3b86e6e443087c29c539727a9584896624317cde9276543aeed4fa62ff1db233f8cfd8872d03 0004-missing-time-header.patch
984fd24ff1bf2d77f6aca77e4a75334ad21a9e36ce27fabb848d82a8e68446e2effeb16a725d5b93ae178ac11379f83a003c8c0d9e408cf96419873741517c3e 0006-define-path-mounted.patch
-61b58cd3763458fb2f8c58ec410398e807711734154843cc96cfcc3857757ec6374dd2c22cd5ef5dec1d30c2e8a4dd0c4064f36824e8734a8625fc58668faeb8 0007-tunedasd-no-need-error-h.patch
-1ec287c4d5c5c3336adacd658640afe5538fd91b86b87d2d0b5f96118a27527b4cf2318ce4712d6c94aceafacf2691a937ddc3ea6e1ecde9e41419c6c72a7471 0008-iucvterm-no-nls.patch
-6e17741908c34b12c24d806712e8033de742592dea0583c9d10955b8003729da8cbd4f5095b6fbd7788d7f1eedeafdcf5a2077f1908e28a4ddd7b34368aacd34 0009-zdev-libexecinfo.patch
-2d5cd3709e0233a6b97270af687b89bbc55f208744437a8409fc38c6afc152a8ebbf60a3d0b837a7c01a36b9bbf5f69d376c89fafcbb8e4153b64a09dc49a23a 0010-musl-s390x-signal-def.patch
+a0ca14c6de2415a725c44e067157c2b5a8db582f4eadbd355fadab5e050870073cf5f5e11212fd046bf24841ed60b84e1475fed115d1e307b8fc1f2da69e5fbd 0007-tunedasd-no-need-error-h.patch
+bdbeb6f3873ede82487c7e4fcac84aa2bf8a922991ec32d029a64cd7142625f5a99920db0f1b6935805d7371ae5a7640c5ea577969937dd96c4f4f996b909ac3 0008-iucvterm-no-nls.patch
+754ae56dc45326eccd9b5e7be5c1faffeeee7d8ff84ed3275269e28324b65c0437ebf6cff55dea2188a06f09a798a00c9792ccc41a805e1d24824a4d7334bec0 0009-link-libexecinfo.patch
+43edeb7f3ab3f5bbc6cd43e6d04deafcfa18211886f3801a226d46679cd70fc709732d5f41d8cc421f9fb0b441a395ebd2a57512f97662531a3050819c97ba1e 0010-musl-s390x-signal-def.patch
d879173250fc0cabef198785923248e6832158e38d6ea9ef615f14e2d6698810b54c38c8327f20b2c43d8d509a274b27a7c0ad999a0c0bed2743715f21ab859a 0100-zipl-no-pie.patch
1cbbe3fe265c7d4164143d24c532c18b354be4bc295ad24064d379660e43a475b7d678b458cdf74ffdb44d6cd38a497dbe00758d688c547c6ece63b6dee091b7 0101-zipl-dont-optimize-size.patch
-4ce15b615ff08e5c0a23d3c3b19d1e9d6362239fb731e67fa68e6cd108cfdeaaf16186c5416cc211082aa60c4d1946b930b9ea4c300458da98e9a701feed99c3 0200-dasdinfo-gnu-ext-hack.patch
+98f5a150e30752d2bec6447d8f24b89a3afda43c31ebe3e6ce940ac398ae9ebfab2c516e05686e7969461c7cf7e467e1221981a5499a9bb8a5aef2f265ec8b45 0200-dasdinfo-gnu-ext-hack.patch
6736ca9deb25838511e715e96d1f5bfc283460689e767181463d1827c80be200b1375708ff48772599083b14f74594f7053cf30fcc6c93ba7fa5dfae832434de 0300-disable-program-using-gnu-ext.patch
+4fd96891cc2dc868793003a50eae3258a82db1c840b6d2a63107586e96f6c68686e54b625f5395190af606d996c812582938e9148ce51bdb08075f4fdbe96973 zconf-shell.patch
349eb06895016d16194819c4a04f604720f1373ea61a9bc4c58467281c9a2ed3539bd4e8b6984f4e5177630dbe8b928aa95912c9a3e3b0e1fe275d59f9fe573d mk-s390-cdboot.c"
diff --git a/main/s390-tools/zconf-shell.patch b/main/s390-tools/zconf-shell.patch
new file mode 100644
index 0000000000..029b3bf8a5
--- /dev/null
+++ b/main/s390-tools/zconf-shell.patch
@@ -0,0 +1,13 @@
+diff --git a/zconf/lsdasd b/zconf/lsdasd
+index 26ac0b4..e95735e 100755
+--- a/zconf/lsdasd
++++ b/zconf/lsdasd
+@@ -106,7 +106,7 @@ function listDASDDeviceDirectories() {
+ SEARCHDIRS="$SEARCHDIRS $DRIVERFBA"
+ fi
+ if [[ -n "$SEARCHDIRS" ]]; then
+- find $SEARCHDIRS -type l -printf "%h/%l\n" 2> /dev/null
++ find $SEARCHDIRS -type l -exec readlink -f {} \; 2> /dev/null
+ else
+ # The above paths may become invalid in the future, so we keep the
+ # following query as backup: