aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-21 13:40:18 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-21 13:53:59 -0300
commitef2105713971d8552319ce46a6a63fa542189955 (patch)
tree2b4bba96afecb84299256813c0f79f6ade3af43d
parent5fff7dc02be291635956804b17140862109a58e1 (diff)
downloadaports-ef2105713971d8552319ce46a6a63fa542189955.tar.bz2
aports-ef2105713971d8552319ce46a6a63fa542189955.tar.xz
testing/tmate: upgrade to 2.3.1
-rw-r--r--testing/tmate/0001-Fix-building-with-or-without-backtrace-3.patch75
-rw-r--r--testing/tmate/APKBUILD23
2 files changed, 8 insertions, 90 deletions
diff --git a/testing/tmate/0001-Fix-building-with-or-without-backtrace-3.patch b/testing/tmate/0001-Fix-building-with-or-without-backtrace-3.patch
deleted file mode 100644
index bebb41a374..0000000000
--- a/testing/tmate/0001-Fix-building-with-or-without-backtrace-3.patch
+++ /dev/null
@@ -1,75 +0,0 @@
-From c56f00dd22611274fd6ac7626d85ceca8692abf6 Mon Sep 17 00:00:00 2001
-From: Natanael Copa <ncopa@alpinelinux.org>
-Date: Thu, 28 Sep 2017 10:28:42 +0000
-Subject: [PATCH] Fix building with or without backtrace(3)
-
-backtrace(3) and execinfo.h are GNU extensions and may or may not be
-available, and they may be provided via libexecinfo.
-
-Fix detection of libexecinfo and allow building without any support of
-backtrace, in which case we let kernel create core dump.
-
-Fixes #116
----
- configure.ac | 5 +++++
- tmate-debug.c | 10 ++++++++++
- 2 files changed, 15 insertions(+)
-
-diff --git a/configure.ac b/configure.ac
-index 02d2872b..05c1c482 100644
---- a/configure.ac
-+++ b/configure.ac
-@@ -102,6 +102,7 @@ AC_CHECK_HEADERS(
- bitstring.h \
- curses.h \
- dirent.h \
-+ execinfo.h \
- fcntl.h \
- inttypes.h \
- libutil.h \
-@@ -121,9 +122,13 @@ AC_CHECK_HEADERS(
- # Look for library needed for flock.
- AC_SEARCH_LIBS(flock, bsd)
-
-+# Look for library needed for backtrace
-+AC_SEARCH_LIBS(backtrace, execinfo)
-+
- # Check for some functions that are replaced or omitted.
- AC_CHECK_FUNCS(
- [ \
-+ backtrace \
- dirfd \
- flock \
- setproctitle \
-diff --git a/tmate-debug.c b/tmate-debug.c
-index f1fd971f..f58efe0e 100644
---- a/tmate-debug.c
-+++ b/tmate-debug.c
-@@ -1,10 +1,19 @@
-+#ifdef HAVE_EXECINFO_H
- #include <execinfo.h>
-+#endif
- #include <stdio.h>
- #include <stdlib.h>
- #include <regex.h>
- #include <signal.h>
- #include "tmate.h"
-
-+#ifndef HAVE_BACKTRACE
-+
-+void tmate_print_stack_trace(void) {}
-+void tmate_catch_sigsegv(void) {}
-+
-+#else
-+
- #if DEBUG
-
- static int print_resolved_stack_frame(const char *frame)
-@@ -88,3 +97,4 @@ void tmate_catch_sigsegv(void)
- {
- signal(SIGSEGV, handle_sigsegv);
- }
-+#endif
---
-2.14.1
-
diff --git a/testing/tmate/APKBUILD b/testing/tmate/APKBUILD
index 8ced6a7519..17ced9fb14 100644
--- a/testing/tmate/APKBUILD
+++ b/testing/tmate/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Daniel Isaksen <d@duniel.no>
pkgname=tmate
-pkgver=2.2.1
-pkgrel=2
+pkgver=2.3.1
+pkgrel=0
pkgdesc="Instant Terminal Sharing"
url="https://tmate.io/"
arch="all"
@@ -9,19 +9,15 @@ license="ISC"
depends="ncurses-terminfo"
makedepends="ncurses-dev libevent-dev autoconf automake bsd-compat-headers
libtool zlib-dev libssh-dev msgpack-c-dev"
-install=
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/$pkgname-io/$pkgname/archive/$pkgver.tar.gz
- 0001-Fix-building-with-or-without-backtrace-3.patch
- "
-
-builddir="$srcdir/"$pkgname-$pkgver
-
-build() {
- cd "$builddir"
+source="tmate-$pkgver.tar.gz::https://github.com/tmate-io/tmate/archive/$pkgver.tar.gz"
+prepare() {
+ default_prepare
./autogen.sh
+}
+build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -33,12 +29,10 @@ build() {
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
install -Dm644 example_tmux.conf \
@@ -48,5 +42,4 @@ package() {
done
}
-sha512sums="3d4ce7510cd8da39bc4fe63f2a64179846a813bb3560ca811d9e1e2a28b06d95a9033047a900d76bda069c249d7ebbe1143daa082b23212c5d32a50bf1819d2d tmate-2.2.1.tar.gz
-e530890d9771af22f99b6903bd37690a6cb58a3df8950dfc2159f383ed286541e12beeedd0d9752e3830799a43d12cf4f742ab64807aeef966c40ef556d9ed87 0001-Fix-building-with-or-without-backtrace-3.patch"
+sha512sums="98531e3a3c1cc4da11894e8298df560fd58f1ede6a81ac8cb5f8cbea86f5c21672a016977dab801ec06e14f6c718a64599a9e32740934fcd4c0a155f92710520 tmate-2.3.1.tar.gz"