aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2020-03-18 21:14:15 +0100
committerJakub Jirutka <jakub@jirutka.cz>2020-03-18 23:09:21 +0100
commitf282372b831944ec1e790d6361d0fde2c2e92942 (patch)
treefa648fc4f3c091df0e8a57fa02c40b3794d5ab97
parentec2cd0eb6eb560b95a73365a5cdc7a9a8a846776 (diff)
downloadaports-f282372b831944ec1e790d6361d0fde2c2e92942.tar.bz2
aports-f282372b831944ec1e790d6361d0fde2c2e92942.tar.xz
testing/lua-resty-core: fix dependencies and remove $provides
This module requires LuaJIT FFI, it doesn't work with PUC Lua.
-rw-r--r--testing/lua-resty-core/APKBUILD8
1 files changed, 2 insertions, 6 deletions
diff --git a/testing/lua-resty-core/APKBUILD b/testing/lua-resty-core/APKBUILD
index 3cf5559d91..22d974ce24 100644
--- a/testing/lua-resty-core/APKBUILD
+++ b/testing/lua-resty-core/APKBUILD
@@ -2,19 +2,15 @@
# Maintainer: Michael Pirogov <vbnet.ru@gmail.com>
pkgname=lua-resty-core
pkgver=0.1.17
-pkgrel=0
+pkgrel=1
pkgdesc="New FFI-based API for lua-nginx-module"
url="https://github.com/openresty/lua-resty-core"
arch="noarch"
license="BSD-2-Clause"
-depends="lua"
+depends="luajit lua-resty-lrucache"
source="https://github.com/openresty/lua-resty-core/archive/v$pkgver/$pkgname-$pkgver.tar.gz"
options="!check" # FIXME: tests require OpenResty and additional dependencies
-for _v in 5.1 5.2 5.3; do
- provides="$provides lua$_v-${pkgname#lua-}=$pkgver-r$pkgrel" # for backward compatibility
-done
-
package() {
make install DESTDIR="$pkgdir" LUA_LIB_DIR="/usr/share/lua/common"