aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2018-09-18 04:28:30 +0000
committerAndy Postnikov <apostnikov@gmail.com>2018-09-19 02:12:18 +0300
commitf7a50b675c5eca662aec9e9c5805e54499b27461 (patch)
treee2ac4628364a4cccf4feb1470075be1fd8aa1513
parentf745e49cb407c9aa6164f77d00f6a1008e79ba64 (diff)
downloadaports-f7a50b675c5eca662aec9e9c5805e54499b27461.tar.bz2
aports-f7a50b675c5eca662aec9e9c5805e54499b27461.tar.xz
testing/py-backcall: enable test suite
pytest was broken due to missing dependencies, so the test suite did not work. This has been fixed in the mean time, so the test suite can now be run.
-rw-r--r--testing/py-backcall/APKBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/testing/py-backcall/APKBUILD b/testing/py-backcall/APKBUILD
index eca5d7396d..57672f0de2 100644
--- a/testing/py-backcall/APKBUILD
+++ b/testing/py-backcall/APKBUILD
@@ -8,14 +8,22 @@ url="https://github.com/takluyver/backcall"
arch="noarch"
license="BSD-3-Clause"
makedepends="python2-dev python3-dev"
-options="!check" # pytest broken on alpine
+checkdepends="pytest"
subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
source="https://files.pythonhosted.org/packages/source/b/backcall/backcall-$pkgver.tar.gz"
builddir="$srcdir/${pkgname#py-}-$pkgver"
build() {
cd "$builddir"
- python setup.py build
+ python2 setup.py build
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+
+ py.test-2
+ py.test-3
}
package() {