aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-04-23 19:28:25 +0200
committerJakub Jirutka <jakub@jirutka.cz>2019-05-04 19:02:45 +0200
commitfba754600f083dd392d15572d860305908eb15ff (patch)
treea6760b1b54bd5204268780e43676c71df6d539b2
parent65955b8fd031ac5d1123d33065e14e280c991781 (diff)
downloadaports-fba754600f083dd392d15572d860305908eb15ff.tar.bz2
aports-fba754600f083dd392d15572d860305908eb15ff.tar.xz
main/nginx: upgrade to 1.16.0
-rw-r--r--main/nginx/APKBUILD28
-rw-r--r--main/nginx/njs~fix-test-exit-code.patch24
2 files changed, 14 insertions, 38 deletions
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index 8602f458f5..8dadad4ea1 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -14,13 +14,13 @@
pkgname=nginx
# NOTE: Upgrade only to even-numbered versions (e.g. 1.14.z, 1.16.z)!
# Odd-numbered versions are mainline (development) versions.
-pkgver=1.14.2
-pkgrel=1
+pkgver=1.16.0
+pkgrel=0
# Revision of nginx-tests to use for check().
-_tests_hgrev=d6daf03478ad
-_njs_ver=0.2.0
+_tests_hgrev=2be630357aa7
+_njs_ver=0.3.1
pkgdesc="HTTP and reverse proxy server (stable version)"
-url="http://www.nginx.org/en"
+url="https://www.nginx.org/"
arch="all"
license="BSD-2-Clause"
depends=""
@@ -38,7 +38,6 @@ replaces="$pkgname-common $pkgname-initscripts $pkgname-lua $pkgname-rtmp"
source="https://nginx.org/download/$pkgname-$pkgver.tar.gz
$pkgname-tests-$_tests_hgrev.tar.gz::https://hg.nginx.org/nginx-tests/archive/$_tests_hgrev.tar.gz
$pkgname-njs-$_njs_ver.tar.gz::https://hg.nginx.org/njs/archive/$_njs_ver.tar.gz
- njs~fix-test-exit-code.patch
nginx.conf
default.conf
$pkgname.logrotate
@@ -94,14 +93,14 @@ _add_module "http-fancyindex" "v0.4.3" "https://github.com/aperezdc/ngx-fancyind
_add_module "http-headers-more" "v0.33" "https://github.com/openresty/headers-more-nginx-module"
_http_headers_more_so="ngx_http_headers_more_filter_module.so"
-_add_module "http-lua" "v0.10.13" "https://github.com/openresty/lua-nginx-module"
+_add_module "http-lua" "v0.10.15" "https://github.com/openresty/lua-nginx-module"
_http_lua_depends="$pkgname-mod-devel-kit"
_http_lua_provides="$pkgname-lua" # for backward compatibility
_add_module "http-lua-upstream" "v0.07" "https://github.com/openresty/lua-upstream-nginx-module"
_http_lua_upstream_depends="$pkgname-mod-http-lua"
-_add_module "http-nchan" "v1.2.3" "https://github.com/slact/nchan"
+_add_module "http-nchan" "v1.2.5" "https://github.com/slact/nchan"
_http_nchan_so="ngx_nchan_module.so"
_add_module "http-shibboleth" "v2.0.1" "https://github.com/nginx-shib/nginx-http-shibboleth"
@@ -140,6 +139,8 @@ prepare() {
# This test requires superuser privileges and CAP_NET_ADMIN.
rm "$srcdir"/nginx-tests-*/proxy_bind_transparent.t
rm "$srcdir"/nginx-tests-*/proxy_bind_transparent_capability.t
+ # Travis and Drone.io does not support IPv6...
+ rm -f "$srcdir"/nginx-tests-*/upstream_ip_hash_ipv6.t
}
build() {
@@ -284,10 +285,9 @@ _module() {
echo "load_module \"modules/$soname\";" > ./etc/nginx/modules/$name.conf
}
-sha512sums="d8362dbd86435657d6b13156bd6ad1b251d2ab10bc11cdda959b142dd6120b087e4b314f0025d9bbcc88529cb4b9407fb4df1cfae5d081b7ea1db51ccfc2dbe7 nginx-1.14.2.tar.gz
-775f8fcc55e0e670f7b509974cc9e9cfb56e4bd2a88d1c7716c96b63ad87c14fd6d07f293545639972e798fb20f81414ef6483451d00ae5a4eaa262ccf2cbc98 nginx-tests-d6daf03478ad.tar.gz
-be07e635f5e0e50a28366b28180344568b5cca9d67c79bc80d0c6758d8d4097ff9428393fb6951ed239c6e9c9e3f84b46f9c92a6e2c313f1f35e677b3662512f nginx-njs-0.2.0.tar.gz
-cd6983c164383100e0239be85dfeddc7879ab9c29589aecdd9bb4b6772d1f0a5d4cd70bf728d0fb5181765cbed77b7e4c99fd85c0ec59c55826c52e923510017 njs~fix-test-exit-code.patch
+sha512sums="e99cfaa4538f209c096ea2f93c04b5019756617f3bcd3305c273e98ddc89fed5bf90d65fb9b493149bc47d55ff79e73850bfcac20505fab74930d0102075df3d nginx-1.16.0.tar.gz
+dfc558537847ab322d9e88f9b3141edc7f4391b42f672358f10ddba31b90d4e271b73c79b437cfc45d4db3932049379a1c3269953bdaafb7b4e24e436b46e4bf nginx-tests-2be630357aa7.tar.gz
+d6fddcfee8e9fdbc4bdc7c945721d5751c22075da35cadc27689069bbf5d763ed1630050daecc2fa22606a0bcd3990aea4ce16bbc85581d685888f3d009789fb nginx-njs-0.3.1.tar.gz
ac7e3153ab698b4cde077f0d5d7ac0a58897927eb36cf3b58cb01268ca0296f1d589c0a5b4f889b96b5b4a57bef05b17c59be59a9d7c4d7a3d3be58f101f7f41 nginx.conf
0907f69dc2d3dc1bad3a04fb6673f741f1a8be964e22b306ef9ae2f8e736e1f5733a8884bfe54f3553fff5132a0e5336716250f54272c3fec2177d6ba16986f3 default.conf
09b110693e3f4377349ccea3c43cb8199c8579ee351eae34283299be99fdf764b0c1bddd552e13e4d671b194501618b29c822e1ad53b34101a73a63954363dbb nginx.logrotate
@@ -297,9 +297,9 @@ eb183860cd511361346e4079c1fcf470985e1c3b2a034a57f8b2a92ba851fed99256261f9b779770
c90b81a4e85a8e9beeb5ff591dc91adb25fa4e0b6cb47086b577e5fa36db2368442dd011187675e358781956c364b949bc4d920ca2b534481b21c9987d2a9a3b echo-nginx-module-0.61.tar.gz
fe5f6afc29c99f66151c1a06e27b5749b0a16227638583d9c961adc94b2942b981184382f95e70d927f00b09b43f597b963a85a41bde5903b10e42f86bc321f1 ngx-fancyindex-0.4.3.tar.gz
13165b1b8d4be281b8bd2404fa48d456013d560bace094c81da08a35dc6a4f025a809a3ae3a42be6bbf67abbcbe41e0730aba06f905220f3baeb01e1192a7d37 headers-more-nginx-module-0.33.tar.gz
-8c316b9d12dc35779fcddc6bb90942c096f19fd8c2e090b8397e1e1ca6f0ebd7a4edddc03fddb31310147ba4e9db9fc4b3749cfd2323046d88045b3b3333f07d lua-nginx-module-0.10.13.tar.gz
+7555d3d256f169a4473f9be80e70e5bf53df5289167c9f70ecc943720bc783f92f54adcb69f15cd5fe2174436875f92f0b17d8198e3a86e27c4f0cf1e0536308 lua-nginx-module-0.10.15.tar.gz
72887c4490854b099cb26bb3f840073a36b0d812bde4486f04dc1be182ca74f0d1e3fd709e77c240c2dcf37665f74cf04e188ea9efe8e127c6789b27b487d0cd lua-upstream-nginx-module-0.07.tar.gz
-e2f23ec82669af4be77cb4d6ee24347fc8438b658a0d16d42d6a8e81b074685f5cd1d2060ccf314e610f9d3aee3720181243133af3e450d2c0d7105a1873f13f nchan-1.2.3.tar.gz
+016bbc4a33dccb4f06d43d32b132159473f26b96df2366f6eea246c695073842bcd6252a71873f42032fa47404cbbf9e34ac80f2ea819a9196491ef6c58713f7 nchan-1.2.5.tar.gz
1730845ea2e52be8c2f6cfceb2894304c5a07959a96940bb1617ee0e7cf81d22283304f411d9a219ddb71e4d9a66012bba0f6f5574d101aeb3c406f26c5d6a4e nginx-http-shibboleth-2.0.1.tar.gz
d6ca250db8de93edbd7875afca35e73cecdaf82132d1a7ee933cf94c6b8afa8e629e9e647a9321f2bc1fbb92137ec0d32dcd89b82ac5fae31e342537fb7e0431 redis2-nginx-module-0.15.tar.gz
5590526f60c99630f99a49bfa9e3455baee6d58cd2a1419eab1367a838dafb87a50f5e2607aa8ac557b90dbf633dcf61069c997b3526cddc8f2fc45820a7bc3b set-misc-nginx-module-0.32.tar.gz
diff --git a/main/nginx/njs~fix-test-exit-code.patch b/main/nginx/njs~fix-test-exit-code.patch
deleted file mode 100644
index f6edfc7698..0000000000
--- a/main/nginx/njs~fix-test-exit-code.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-# HG changeset patch
-# User Dmitry Volyntsev <xeioex@nginx.com>
-# Date 1524763304 -10800
-# Node ID 4e647f0bf155f0e858a8838c216e3ba1559ff870
-# Parent 1305b1701099541bcb47579ce1719550662e0d1c
-Fixed unit tests exit code.
-
-Previously, 0 was returned regardless of failures.
-
-Patch-Source: http://hg.nginx.org/njs/rev/4e647f0bf155
-
-diff -r 1305b1701099 -r 4e647f0bf155 njs/test/njs_unit_test.c
---- a/njs/test/njs_unit_test.c Thu Apr 26 19:58:26 2018 +0300
-+++ b/njs/test/njs_unit_test.c Thu Apr 26 20:21:44 2018 +0300
-@@ -9878,7 +9878,7 @@
- printf("njs unit tests passed\n");
- }
-
-- return NXT_OK;
-+ return rc;
- }
-
-
-