aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-04-28 15:27:43 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-04-28 15:30:28 +0200
commit20ff62966a769feb71a12a16d53831cce9fe0179 (patch)
tree1f208ee5adc30a10b67d517f3169b9fd4d46b184
parent2547117f8594952cf3ba12e9d22bec5026c1b342 (diff)
downloadaports-20ff62966a769feb71a12a16d53831cce9fe0179.tar.bz2
aports-20ff62966a769feb71a12a16d53831cce9fe0179.tar.xz
community/gnome: split gnome-apps into gnome-apps-core and gnome-apps-extra
That way users can install gnome-apps-core to get core apps like gnome-terminal without installing all GNOME apps
-rw-r--r--community/gnome/APKBUILD94
1 files changed, 54 insertions, 40 deletions
diff --git a/community/gnome/APKBUILD b/community/gnome/APKBUILD
index 65986c7df2..50a6a2d79f 100644
--- a/community/gnome/APKBUILD
+++ b/community/gnome/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gnome
pkgver=3.36.0
-pkgrel=4
+pkgrel=5
pkgdesc="GNOME (Base) meta package"
url="https://www.gnome.org"
arch="x86 x86_64 armv7 aarch64" # GNOME isn't available on all arches yet
@@ -12,6 +12,7 @@ depends="
chrome-gnome-shell
gdm
gnome-backgrounds
+ gnome-control-center
gnome-getting-started-docs
gnome-initial-setup
gnome-keyring
@@ -39,66 +40,35 @@ if [ "$CARCH" != "armv7" ]; then
depends="$depends bolt"
fi
-subpackages="$pkgname-apps:_apps $pkgname-games-collection:_games"
+subpackages="$pkgname-apps-core:_apps_core $pkgname-apps-extra:_apps_extra $pkgname-games-collection:_games"
package() {
mkdir -p "$pkgdir"
}
-_apps() {
- pkgdesc="Additional GNOME apps meta package"
+_apps_core() {
+ pkgdesc="Additional core GNOME apps meta package"
+ # From https://wiki.gnome.org/Design/Apps
depends="
- baobab
- brasero
- celluloid
- cheese
- dconf-editor
eog
epiphany
- evince
evolution
- deja-dup
- devhelp
- easytag
- file-roller
- fractal
- geary
+ evince
gedit
gedit-plugins
- ghex
- gitg
- gnome-authenticator
- gnome-books
- gnome-boxes
- gnome-builder
gnome-calculator
gnome-calendar
- gnome-characters
gnome-clocks
gnome-contacts
gnome-disk-utility
- gnome-documents
- gnome-feeds
- gnome-games
- gnome-latex
gnome-maps
- gnome-music
- gnome-obfuscate
- gnome-passwordsafe
- gnome-photos
- gnome-podcasts
- gnome-power-manager
gnome-screenshot
- gnome-shortwave
gnome-software
- gnome-sound-recorder
+ gnome-software-plugin-apk
gnome-system-monitor
gnome-terminal
gnome-tweaks
gnome-weather
- gnote
- gparted
- gpaste
grilo
grilo-plugins
gst-plugins-bad
@@ -116,18 +86,62 @@ _apps() {
gvfs-fuse
gvfs-gphoto2
gvfs-avahi
+ nautilus
+ totem
+ "
+
+ mkdir -p "$subpkgdir"
+}
+
+_apps_extra() {
+ pkgdesc="Additional GNOME apps meta package"
+ replaces="gnome-apps" # splitted into gnome-apps-core and gnome-apps-extra
+ provides="gnome-apps=$pkgver-r$pkgrel"
+ depends="
+ baobab
+ brasero
+ celluloid
+ cheese
+ dconf-editor
+ deja-dup
+ devhelp
+ easytag
+ file-roller
+ fractal
+ geary
+ ghex
+ gitg
+ gnome-apps-core
+ gnome-authenticator
+ gnome-books
+ gnome-boxes
+ gnome-builder
+ gnome-characters
+ gnome-documents
+ gnome-feeds
+ gnome-games
+ gnome-latex
+ gnome-music
+ gnome-obfuscate
+ gnome-passwordsafe
+ gnome-photos
+ gnome-podcasts
+ gnome-power-manager
+ gnome-shortwave
+ gnome-sound-recorder
+ gnote
+ gparted
+ gpaste
meld
orca
peek
polari
rhythmbox
- nautilus
seahorse
simple-scan
shotwell
sound-juicer
sushi
- totem
transmission
vinagre
vino