aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2020-01-16 14:19:45 -0500
committerTimo Teräs <timo.teras@iki.fi>2020-01-26 09:01:26 +0200
commit83936387bae927d58451862b200fb3f99f969cdb (patch)
treed249829fd11c1e9c6ef39790228af1c4513fcc59
parent49d7db15e34ced8a7a2deec9efed47b27d9b8a86 (diff)
downloadaports-83936387bae927d58451862b200fb3f99f969cdb.tar.bz2
aports-83936387bae927d58451862b200fb3f99f969cdb.tar.xz
add apk-version(8)
-rw-r--r--doc/Makefile1
-rw-r--r--doc/apk-version.8.scd53
2 files changed, 54 insertions, 0 deletions
diff --git a/doc/Makefile b/doc/Makefile
index 7cdf3994d0..77f1766273 100644
--- a/doc/Makefile
+++ b/doc/Makefile
@@ -21,6 +21,7 @@ docs: $(obj)/apk.8 \
$(obj)/apk-update.8 \
$(obj)/apk-upgrade.8 \
$(obj)/apk-verify.8 \
+ $(obj)/apk-version.8 \
$(obj)/apk-repositories.5 \
$(obj)/apk-world.5
targets += docs
diff --git a/doc/apk-version.8.scd b/doc/apk-version.8.scd
new file mode 100644
index 0000000000..654a033ae5
--- /dev/null
+++ b/doc/apk-version.8.scd
@@ -0,0 +1,53 @@
+apk-version(8)
+
+# NAME
+
+apk version - compare package versions
+
+# SYNOPSIS
+
+*apk version* [<_options_>...] [_packages_...]
+
+*apk version* -c _versions_...
+
+*apk version* -t _left_ _right_
+
+*apk version* -I
+
+# DESCRIPTION
+
+*apk version* compares the versions of installed packages against package
+versions available from repositories (see *apk-repositories*(5)). If no
+packages are specified, all installed packages are considered. Otherwise,
+the comparison is limited to the explicitly listed packages. A summary is
+printed on stdout, with the difference between package versions being
+represented as *>*, *=*, or *<*.
+
+*apk version -c* tests the specified version string(s) for validity and prints
+a list of _invalid_ version strings. If all version strings are valid, nothing
+is printed and *apk version* exits with status code zero. If one or more
+version strings are invalid, the exit code is nonzero.
+
+*apk version -t* accepts two arbitrary version strings and compares them
+without consulting the database, then prints the result as *>*, *=*, or *<*.
+
+*apk version -I* prints the versions and descriptions of each repository's
+index. See *apk-repositories*(5) for more information.
+
+# OPTIONS
+
+These options only apply when checking installed package versions against
+packages available from the repositories (when neither *-c*, *-t*, nor *-I* are
+specified).
+
+*-a*
+ Consider packages from all repository tags.
+
+*-l* _operand_
+ Limit output to packages whose comparison is among the given operands,
+ specified as any combination of *>*, *=*, and *<*.
+
+# AUTHORS
+
+Natanael Copa <ncopa@alpinelinux.org>++
+Timo Teräs <_timo.teras@iki.fi_>