aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2014-05-22 11:14:00 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2014-05-22 11:15:34 +0000
commit401042d6aecd267fc73b9dcf3f7f3d924ac71558 (patch)
tree0ddc202d605525be7c742e1846101ddbb56cf46f
parent329b2489abf5f0bfec150195b8488269674c89a7 (diff)
downloadaports-401042d6aecd267fc73b9dcf3f7f3d924ac71558.tar.bz2
aports-401042d6aecd267fc73b9dcf3f7f3d924ac71558.tar.xz
main/lxc: backport support for all iX86 strings for lxc.arch
ref #2843
-rw-r--r--main/lxc/0001-allow-all-iX86-strings-for-lxc.arch.patch40
-rw-r--r--main/lxc/0001-alpinelinux-set-correct-lxc_arch-for-x86.patch24
-rw-r--r--main/lxc/APKBUILD16
3 files changed, 48 insertions, 32 deletions
diff --git a/main/lxc/0001-allow-all-iX86-strings-for-lxc.arch.patch b/main/lxc/0001-allow-all-iX86-strings-for-lxc.arch.patch
new file mode 100644
index 0000000000..4c6f3b3400
--- /dev/null
+++ b/main/lxc/0001-allow-all-iX86-strings-for-lxc.arch.patch
@@ -0,0 +1,40 @@
+From bb8d8207c36402ba1282081963b3dcd3356452ec Mon Sep 17 00:00:00 2001
+From: Dwight Engen <dwight.engen@oracle.com>
+Date: Mon, 28 Apr 2014 16:50:51 -0400
+Subject: [PATCH] allow all iX86 strings for lxc.arch
+
+This change accepts all the same strings for lxc.arch that setarch(8) does.
+
+Note that we continue to parse plain x86 as PER_LINUX32 so as not to break
+existing lxc configuration files.
+
+Signed-off-by: Dwight Engen <dwight.engen@oracle.com>
+Signed-off-by: Serge Hallyn <serge.hallyn@ubuntu.com>
+---
+ src/lxc/confile.c | 8 +++++++-
+ 1 file changed, 7 insertions(+), 1 deletion(-)
+
+diff --git a/src/lxc/confile.c b/src/lxc/confile.c
+index 90fb344..4e7dead 100644
+--- a/src/lxc/confile.c
++++ b/src/lxc/confile.c
+@@ -1723,9 +1723,15 @@ signed long lxc_config_parse_arch(const char *arch)
+ struct per_name {
+ char *name;
+ unsigned long per;
+- } pername[4] = {
++ } pername[] = {
+ { "x86", PER_LINUX32 },
++ { "linux32", PER_LINUX32 },
++ { "i386", PER_LINUX32 },
++ { "i486", PER_LINUX32 },
++ { "i586", PER_LINUX32 },
+ { "i686", PER_LINUX32 },
++ { "athlon", PER_LINUX32 },
++ { "linux64", PER_LINUX },
+ { "x86_64", PER_LINUX },
+ { "amd64", PER_LINUX },
+ };
+--
+1.9.3
+
diff --git a/main/lxc/0001-alpinelinux-set-correct-lxc_arch-for-x86.patch b/main/lxc/0001-alpinelinux-set-correct-lxc_arch-for-x86.patch
deleted file mode 100644
index f6d80684a6..0000000000
--- a/main/lxc/0001-alpinelinux-set-correct-lxc_arch-for-x86.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-From 1e2eb721ed696412c7aafc9538b3e45ac5c96ef9 Mon Sep 17 00:00:00 2001
-From: Carlo Landmeter <clandmeter@gmail.com>
-Date: Tue, 15 Apr 2014 09:51:53 +0000
-Subject: [PATCH] alpinelinux: set correct lxc_arch for x86
-
----
- templates/lxc-alpine.in | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/templates/lxc-alpine.in b/templates/lxc-alpine.in
-index d8c6674..7a22d5e 100644
---- a/templates/lxc-alpine.in
-+++ b/templates/lxc-alpine.in
-@@ -362,6 +362,7 @@ apk_arch=$arch
- case "$arch" in
- i[3-6]86)
- apk_arch=x86
-+ lxc_arch=x86
- ;;
- x86)
- lxc_arch=i686
---
-1.9.2
-
diff --git a/main/lxc/APKBUILD b/main/lxc/APKBUILD
index 154d1569f5..36b2696b37 100644
--- a/main/lxc/APKBUILD
+++ b/main/lxc/APKBUILD
@@ -3,7 +3,7 @@
pkgname=lxc
pkgver=1.0.3
_mypkgver=${pkgver/_rc/.rc}
-pkgrel=0
+pkgrel=1
pkgdesc="linux containers - tools"
url="http://lxc.sourceforge.net/"
arch="all"
@@ -16,8 +16,8 @@ subpackages="$pkgname-dev $pkgname-doc $pkgname-lvm lua5.2-lxc:_lua52
$pkgname-templates $pkgname-libs"
source="https://github.com/lxc/lxc/archive/lxc-$_mypkgver.tar.gz
version.patch
+ 0001-allow-all-iX86-strings-for-lxc.arch.patch
lxc.initd
- 0001-alpinelinux-set-correct-lxc_arch-for-x86.patch
"
_builddir="${srcdir}/lxc-lxc-${_mypkgver}"
@@ -87,13 +87,13 @@ dev() {
md5sums="4ebce63536f157125ed953e5836767d6 lxc-1.0.3.tar.gz
79e90616b5049a472ccdcb5b1dcdd8b1 version.patch
-1268d4b3e6ed004a47216b8714d09bfd lxc.initd
-b93cda6f092211535cf87fa841d611aa 0001-alpinelinux-set-correct-lxc_arch-for-x86.patch"
+81aff50820a3f06e3a6abdb7136f8216 0001-allow-all-iX86-strings-for-lxc.arch.patch
+1268d4b3e6ed004a47216b8714d09bfd lxc.initd"
sha256sums="9fc4ac60a842058e4ad0fe6a281dc0079ee9830afa1852a10fa044219f2c6412 lxc-1.0.3.tar.gz
b6d85fb23940d2511b3951de56b2532843c0e03ec1613548366361cc0c1a46b9 version.patch
-bc108a722dc359a24c48837ef7012c776b1d20a533ae0e2231f75081dad4e2f5 lxc.initd
-64bf7588bb0b7c4cd214eb1b89bd8426173dedec16e90b791d795a5d1234ad2b 0001-alpinelinux-set-correct-lxc_arch-for-x86.patch"
+e8da394a0610e1c2d6400c34fe7b015faba02ff1b94a995faceeb534c089542b 0001-allow-all-iX86-strings-for-lxc.arch.patch
+bc108a722dc359a24c48837ef7012c776b1d20a533ae0e2231f75081dad4e2f5 lxc.initd"
sha512sums="95d7080cdb34776b601959bbc95572b1d6defeaec6820a38d9b09eb05bb43eaa4a2c4d9fae26f4d1a7ee13ad6cd104c36dd5cbe6ee5e44f274135e42370cc983 lxc-1.0.3.tar.gz
e2ffcbf55447291a8434a4f37255c3a6a119bc4116c75d205006aa2b070bf6be28535cf6107bead14bbf64bf9fa415346ab544bd1c15e1add7d1c6380e6b2def version.patch
-6618ceb59f1927bb82ad1a0fe0a7d4c452ced7855d8f0953556fce9154f30a4c5afbd7a2ab07fb26e6e793b07d4c8f906f8dc27c1defe0580dcf1545c80d1d60 lxc.initd
-65f688f98b0b6879c6616006f8a39cce7e406c19976487f8ed41fba27beeda4a13f0182960f677d919d4441d436f0cc79a2d34fa0fff86183553e4c266cc5e70 0001-alpinelinux-set-correct-lxc_arch-for-x86.patch"
+5c4758bec433a1da5c65bc7aa53452f3b9452ad7f3dece76321af38824a177a2b334dc638596987633143074ba785ed2bae98551b31c5259eae436f981394eee 0001-allow-all-iX86-strings-for-lxc.arch.patch
+6618ceb59f1927bb82ad1a0fe0a7d4c452ced7855d8f0953556fce9154f30a4c5afbd7a2ab07fb26e6e793b07d4c8f906f8dc27c1defe0580dcf1545c80d1d60 lxc.initd"