aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2012-07-09 07:21:36 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2012-07-09 07:22:57 +0000
commit30e0f07fd60e62ff22d0543d258c36953ab9df85 (patch)
tree9d778c1e405c521e7e474ad0b4c61f4c59019790
parentc14ece59762857954e66f828404f812f4248c160 (diff)
parent5ccdc422ed45059a3afc57f00e52f6c863500310 (diff)
downloadaports-30e0f07fd60e62ff22d0543d258c36953ab9df85.tar.bz2
aports-30e0f07fd60e62ff22d0543d258c36953ab9df85.tar.xz
Merge git://github.com/Barthalion/aports
-rw-r--r--main/libtorrent/APKBUILD (renamed from testing/libtorrent/APKBUILD)0
-rw-r--r--main/nginx/APKBUILD16
-rw-r--r--main/pcre/APKBUILD5
-rw-r--r--main/python/APKBUILD3
-rw-r--r--main/rtorrent/APKBUILD (renamed from testing/rtorrent/APKBUILD)0
-rw-r--r--testing/gitolite/APKBUILD4
-rw-r--r--testing/ncmpcpp/APKBUILD15
-rw-r--r--testing/ufw/APKBUILD11
-rw-r--r--testing/vnstat/APKBUILD16
-rw-r--r--testing/vnstat/vnstat.pre-install5
-rw-r--r--testing/vnstat/vnstatd.confd7
-rw-r--r--testing/vnstat/vnstatd.initd3
12 files changed, 52 insertions, 33 deletions
diff --git a/testing/libtorrent/APKBUILD b/main/libtorrent/APKBUILD
index ec51d9046b..ec51d9046b 100644
--- a/testing/libtorrent/APKBUILD
+++ b/main/libtorrent/APKBUILD
diff --git a/main/nginx/APKBUILD b/main/nginx/APKBUILD
index bf229fa1b3..a8b0cc3159 100644
--- a/main/nginx/APKBUILD
+++ b/main/nginx/APKBUILD
@@ -1,8 +1,9 @@
# Maintainer: Cameron Banta <cbanta@gmail.com>
# Contributor: Jeff Bilyk <jbilyk@gmail.com>
# Contributor: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
+
pkgname=nginx
-pkgver=1.0.15
+pkgver=1.2.2
pkgrel=0
pkgdesc="lightweight HTTP and reverse proxy server"
url="http://www.nginx.org"
@@ -22,6 +23,7 @@ prepare() {
patch -Np1 -i "$srcdir"/ipv6.patch
}
+
build() {
cd "$_builddir"
./configure --prefix=/usr \
@@ -30,14 +32,14 @@ build() {
--lock-path=/var/run/$pkgname.lock \
--error-log-path=/var/log/$pkgname/error.log \
--http-log-path=/var/log/$pkgname/access.log \
- --with-http_ssl_module \
- --with-http_gzip_static_module \
--http-client-body-temp-path=/tmp/$pkgname/client-body \
--http-proxy-temp-path=/tmp/$pkgname/proxy \
--http-fastcgi-temp-path=/tmp/$pkgname/fastcgi \
- --with-mail \
- --with-mail_ssl_module \
- --with-ipv6 \
+ --user=http --group=http \
+ --with-ipv6 --with-pcre-jit \
+ --with-http_ssl_module \
+ --with-http_gzip_static_module \
+ --with-mail --with-mail_ssl_module \
|| return 1
make || return 1
}
@@ -52,7 +54,7 @@ package() {
install -m644 -D LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
}
-md5sums="17da4802209b83d9bebb0f0edd975dfc nginx-1.0.15.tar.gz
+md5sums="53105bbe3ac9319db54d9eb46119695b nginx-1.2.2.tar.gz
4faf8dff6ff1490edae1688baf1b2abb nginx.initd
8823274a834332d3db4f62bf7dd1fb7d nginx.logrotate
801a87f7f9d27f8ad85b41a78b4c4461 ipv6.patch"
diff --git a/main/pcre/APKBUILD b/main/pcre/APKBUILD
index a5985ad552..73d61479da 100644
--- a/main/pcre/APKBUILD
+++ b/main/pcre/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pcre
-pkgver=8.30
+pkgver=8.31
pkgrel=0
pkgdesc="Perl-compatible regular expression library"
url="http://pcre.sourceforge.net"
@@ -25,6 +25,7 @@ prepare() {
build() {
cd "$_builddir"
./configure --prefix=/usr \
+ --enable-jit \
--enable-utf8 \
--enable-unicode-properties \
--with-match-limit-recursion=8192 \
@@ -46,4 +47,4 @@ libpcrecpp() {
mv "$pkgdir"/usr/lib/libpcrecpp.so* "$subpkgdir"/usr/lib/
}
-md5sums="98e8928cccc945d04279581e778fbdff pcre-8.30.tar.bz2"
+md5sums="1c9a276af932b5599157f96e945391f0 pcre-8.31.tar.bz2"
diff --git a/main/python/APKBUILD b/main/python/APKBUILD
index 50b34674b8..fb6ab7017d 100644
--- a/main/python/APKBUILD
+++ b/main/python/APKBUILD
@@ -2,7 +2,7 @@
pkgname=python
pkgver=2.7.3
_verbase=${pkgver%.*}
-pkgrel=4
+pkgrel=5
pkgdesc="A high-level scripting language"
url="http://www.python.org"
arch="all"
@@ -31,6 +31,7 @@ build() {
./configure --prefix=/usr \
--enable-shared \
--with-threads \
+ --enable-ipv6 \
--with-system-ffi \
--with-system-expat \
--enable-unicode=ucs4 \
diff --git a/testing/rtorrent/APKBUILD b/main/rtorrent/APKBUILD
index bc3dfad102..bc3dfad102 100644
--- a/testing/rtorrent/APKBUILD
+++ b/main/rtorrent/APKBUILD
diff --git a/testing/gitolite/APKBUILD b/testing/gitolite/APKBUILD
index 3a4eab3f99..11c26e7989 100644
--- a/testing/gitolite/APKBUILD
+++ b/testing/gitolite/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Carlo Landmeter <clandmeter@gmail.com>
pkgname=gitolite
-pkgver=3.03
+pkgver=3.04
pkgrel=0
pkgdesc='A centralized git server, with very fine-grained access control and many powerful features.'
url='http://github.com/sitaramc/gitolite'
@@ -21,4 +21,4 @@ package() {
ln -s /usr/lib/gitolite/gitolite ${pkgdir}/usr/bin/ || return 1
}
-md5sums="5b66437e362e610595ad1d1b099e0812 gitolite-3.03.tar.gz"
+md5sums="a607da096dc49737adb24c1360b3f3c4 gitolite-3.04.tar.gz"
diff --git a/testing/ncmpcpp/APKBUILD b/testing/ncmpcpp/APKBUILD
index 88e1c4938c..c4678b6d77 100644
--- a/testing/ncmpcpp/APKBUILD
+++ b/testing/ncmpcpp/APKBUILD
@@ -1,26 +1,25 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=ncmpcpp
-pkgver=0.5.8
+pkgver=0.5.10
pkgrel=0
pkgdesc="An almost exact clone of ncmpc with some new features."
url="http://unkart.ovh.org/ncmpcpp/"
arch="all"
license="GPL"
-depends=""
makedepends="curl-dev libmpdclient-dev taglib-dev ncurses-dev openssl-dev"
-install=
subpackages="$pkgname-doc"
source="http://unkart.ovh.org/ncmpcpp/ncmpcpp-$pkgver.tar.bz2"
_builddir="$srcdir"/$pkgname-$pkgver
-build ()
-{
+build () {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr \
--enable-unicode \
--enable-clock \
- --with-taglib --with-curl
- make
+ --with-taglib \
+ --with-curl \
+ || return 1
+ make || return 1
}
package() {
@@ -28,4 +27,4 @@ package() {
make DESTDIR="$pkgdir" install || return 1
}
-md5sums="288952c6b4cf4fa3683f3f83a58da37c ncmpcpp-0.5.8.tar.bz2"
+md5sums="298ed66325bcfe358e37e186c7ea4861 ncmpcpp-0.5.10.tar.bz2"
diff --git a/testing/ufw/APKBUILD b/testing/ufw/APKBUILD
index 02cd77ec93..733361b56f 100644
--- a/testing/ufw/APKBUILD
+++ b/testing/ufw/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Bartłomiej Piotrowski <nospam@bpiotrowski.pl>
pkgname=ufw
-pkgver=0.31.1
+pkgver=0.32
pkgrel=0
pkgdesc='Uncomplicated CLI tool managing a netfilter firewall'
url='https://launchpad.net/ufw'
@@ -15,14 +15,13 @@ source="http://launchpad.net/$pkgname/$(echo $pkgver|cut -c1-4)/$pkgver/+downloa
package() {
cd "$srcdir"/$pkgname-$pkgver
-
- sed -e 's|/lib|/usr/lib|' -i setup.py || return 1
- python setup.py install --root="$pkgdir" || return 1 # move /lib to /usr/lib
+
+ sed -e 's|/lib|/usr/lib|' -i setup.py || return 1
+ python setup.py install --root="$pkgdir"
install -Dm755 "$srcdir"/$pkgname.initd "$pkgdir"/etc/init.d/$pkgname || return 1
chmod 644 "$pkgdir"/etc/ufw/*.rules "$pkgdir"/usr/lib/ufw/*.rules || return 1
- sed -i '7s/YES/NO/' "$pkgdir"/etc/default/ufw || return 1 #TODO: ipv6 support
}
-md5sums="74b49d4d06e26359a55bf4ff576833a7 ufw-0.31.1.tar.gz
+md5sums="e9d314a6213c94ec6bddf107f7bbdb9f ufw-0.32.tar.gz
7bf1a3dee43b294bda8f2025e04164ce ufw.initd"
diff --git a/testing/vnstat/APKBUILD b/testing/vnstat/APKBUILD
index 1c13ff8102..be2e25310e 100644
--- a/testing/vnstat/APKBUILD
+++ b/testing/vnstat/APKBUILD
@@ -2,15 +2,17 @@
pkgname=vnstat
pkgver=1.11
-pkgrel=0
+pkgrel=1
pkgdesc='A console-based network traffic monitor'
url='http://humdi.net/vnstat/'
arch='all'
license='GPL'
+install="$pkgname.pre-install"
makedepends='gd-dev'
subpackages="$pkgname-doc"
source="http://humdi.net/vnstat/$pkgname-$pkgver.tar.gz
- vnstatd.initd"
+ vnstatd.initd
+ vnstatd.confd"
build() {
cd "$srcdir"/$pkgname-$pkgver
@@ -21,8 +23,11 @@ package() {
cd "$srcdir"/$pkgname-$pkgver
make DESTDIR="$pkgdir" install || return 1
- install -D -m0755 "$srcdir"/vnstatd.initd "$pkgdir"/etc/init.d/vnstat \
- || return 1
+ install -D -m0755 "$srcdir"/vnstatd.initd \
+ "$pkgdir"/etc/init.d/vnstatd || return 1
+ install -D -m0644 "$srcdir"/vnstatd.confd \
+ "$pkgdir"/etc/conf.d/vnstatd || return 1
+
install -D -m0644 examples/vnstat.cron \
"$pkgdir"/usr/share/doc/vnstat/examples/vnstat.cron || return 1
install -D -m0755 examples/vnstat.cgi \
@@ -30,4 +35,5 @@ package() {
}
md5sums="a5a113f9176cd61fb954f2ba297f5fdb vnstat-1.11.tar.gz
-6c8a07d3388155c6cb23715ac8467700 vnstatd.initd"
+b439075575d307cd9373740fe59538f1 vnstatd.initd
+810205e9cd5328b4279bd9ab1b804c36 vnstatd.confd"
diff --git a/testing/vnstat/vnstat.pre-install b/testing/vnstat/vnstat.pre-install
new file mode 100644
index 0000000000..4cb61f2443
--- /dev/null
+++ b/testing/vnstat/vnstat.pre-install
@@ -0,0 +1,5 @@
+#!/bin/sh
+
+addgroup -S vnstat 2>/dev/null
+adduser -S -h /var/lib/ -H -s /bin/false -D -G vnstat vnstat 2>/dev/null
+exit 0
diff --git a/testing/vnstat/vnstatd.confd b/testing/vnstat/vnstatd.confd
new file mode 100644
index 0000000000..17901419aa
--- /dev/null
+++ b/testing/vnstat/vnstatd.confd
@@ -0,0 +1,7 @@
+# /etc/conf.d/vnstatd: config file for /etc/init.d/vnstatd
+
+# Adjust scheduling priority on vnstatd (default: 0)
+#VNSTATD_NICELEVEL="0"
+
+# Pass extra options to vnstatd
+#VNSTATD_EXTRAOPTS="--config /etc/vnstat.conf"
diff --git a/testing/vnstat/vnstatd.initd b/testing/vnstat/vnstatd.initd
index b3f136cef3..167e2cc307 100644
--- a/testing/vnstat/vnstatd.initd
+++ b/testing/vnstat/vnstatd.initd
@@ -1,7 +1,6 @@
#!/sbin/runscript
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-analyzer/vnstat/files/vnstatd.initd,v 1.6 2012/01/01 01:19:16 idl0r Exp $
extra_started_commands="reload"
@@ -18,7 +17,7 @@ start() {
--pidfile "${VNSTATD_PIDFILE}" \
--user vnstat --group vnstat \
--nicelevel ${VNSTATD_NICELEVEL:-0} \
- --exec /usr/bin/vnstatd -- \
+ --exec /usr/sbin/vnstatd -- \
-d ${VNSTATD_EXTRAOPTS} -p ${VNSTATD_PIDFILE}
eend $?
}