aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2013-06-25 14:23:50 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2013-06-25 14:23:50 +0200
commit6d0c7375dbf5d1d74d7287a9170bbc86a893b6e4 (patch)
tree566a52b16000f1f33fe9aced0c3014522c949375
parent3eac3b21e7ded9c0d1d3c89ec77fe0857c72d450 (diff)
downloadaports-6d0c7375dbf5d1d74d7287a9170bbc86a893b6e4.tar.bz2
aports-6d0c7375dbf5d1d74d7287a9170bbc86a893b6e4.tar.xz
testing/lua5.2-cjson: build fix
we need set cflags
-rw-r--r--testing/lua5.2-cjson/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/lua5.2-cjson/APKBUILD b/testing/lua5.2-cjson/APKBUILD
index 82a7ae2d17..5e98e96eec 100644
--- a/testing/lua5.2-cjson/APKBUILD
+++ b/testing/lua5.2-cjson/APKBUILD
@@ -2,7 +2,7 @@
_luaver=5.2
pkgname=lua${_luaver}-cjson
pkgver=2.1.0
-pkgrel=0
+pkgrel=1
pkgdesc="fast JSON parsing and encoding support for Lua $_luaver"
url="http://www.kyne.com.au/~mark/software/lua-cjson.php"
arch="all"
@@ -27,7 +27,8 @@ prepare() {
build() {
cd "$_builddir"
- make CFLAGS_EXTRA= PREFIX=/usr|| return 1
+ make CFLAGS_EXTRA="$( pkg-config lua$_luaver --cflags )" \
+ PREFIX=/usr|| return 1
}
package() {