aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-26 18:43:13 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-31 09:01:39 +0000
commit09bae1c6f56c909a69a2c1dcabfe204f7c14b4c9 (patch)
treefa709cab75c5810e82cacaacab4f2af1599dba7e
parent487c1b6db543ae34c8e258729237bf2f4878d208 (diff)
downloadaports-09bae1c6f56c909a69a2c1dcabfe204f7c14b4c9.tar.bz2
aports-09bae1c6f56c909a69a2c1dcabfe204f7c14b4c9.tar.xz
community/xfburn: switch to gstreamer-1.0
0.10 is no longer maintained. Upstream recommends usage of 1.0 https://gstreamer.freedesktop.org/documentation/frequently-asked-questions/getting.html?gi-language=c
-rw-r--r--community/xfburn/APKBUILD13
1 files changed, 5 insertions, 8 deletions
diff --git a/community/xfburn/APKBUILD b/community/xfburn/APKBUILD
index 568881c18f..545a9f77af 100644
--- a/community/xfburn/APKBUILD
+++ b/community/xfburn/APKBUILD
@@ -1,29 +1,27 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=xfburn
pkgver=0.5.5
-pkgrel=0
+pkgrel=1
pkgdesc="a simple CD/DVD burning tool based on libburnia libraries"
+options="!check" # No testsuite
url="http://goodies.xfce.org/projects/applications/xfburn"
arch="all"
-license="GPL-2.0"
+license="GPL-2.0-or-later"
depends="desktop-file-utils hicolor-icon-theme"
makedepends="libburn-dev libisofs-dev libxfce4ui-dev thunar-dev librsvg-dev
- gst-plugins-base0.10-dev exo-dev"
+ gst-plugins-base-dev exo-dev"
subpackages="$pkgname-doc $pkgname-lang"
source="https://archive.xfce.org/src/apps/xfburn/${pkgver%.*}/xfburn-$pkgver.tar.bz2"
-builddir="$srcdir"/$pkgname-$pkgver
prepare() {
default_prepare
- cd "$_builddir"
# fix build issue
sed -i '1 i\
#include <glib-object.h>' \
xfburn/xfburn-settings.h
}
-build () {
- cd "$builddir"
+build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,7 +33,6 @@ build () {
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}