aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-26 18:56:43 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-31 09:01:39 +0000
commit4627c1aecb43b304dd8f9e931719ec50103db75a (patch)
tree8913942c2f0884870911ed1c812fa4d5689f3036
parent09bae1c6f56c909a69a2c1dcabfe204f7c14b4c9 (diff)
downloadaports-4627c1aecb43b304dd8f9e931719ec50103db75a.tar.bz2
aports-4627c1aecb43b304dd8f9e931719ec50103db75a.tar.xz
testing/handbrake: switch to gstreamer-1.0
0.10 is no longer maintained. Upstream recommends usage of 1.0 https://gstreamer.freedesktop.org/documentation/frequently-asked-questions/getting.html?gi-language=c
-rw-r--r--testing/handbrake/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/testing/handbrake/APKBUILD b/testing/handbrake/APKBUILD
index 3932c501eb..ed2fcf9b71 100644
--- a/testing/handbrake/APKBUILD
+++ b/testing/handbrake/APKBUILD
@@ -2,7 +2,7 @@
pkgname=handbrake
_pkgname=HandBrake
pkgver=1.2.2
-pkgrel=0
+pkgrel=1
pkgdesc="Handbrake video transcoder"
url="https://handbrake.fr"
arch="x86_64 x86 armhf armv7 ppc64le"
@@ -11,10 +11,10 @@ makedepends="yasm autoconf libtool zlib-dev libbz2 libogg-dev libtheora-dev
libvorbis-dev libsamplerate-dev fribidi-dev freetype-dev
tinyxml-dev fontconfig-dev libass-dev intltool glib-dev dbus-glib-dev
gtk+3.0-dev libgudev-dev libnotify-dev libdvdread-dev
- gstreamer0.10-dev x264-dev lame-dev linux-headers cmake
- autoconf automake ffmpeg-dev coreutils libdvdnav-dev
- libbluray-dev x265-dev libvpx-dev fdk-aac-dev jansson-dev
- opus-dev python2 speex-dev xz-dev"
+ gst-plugins-base-dev x264-dev lame-dev linux-headers cmake
+ automake ffmpeg-dev coreutils libdvdnav-dev libbluray-dev
+ x265-dev libvpx-dev fdk-aac-dev jansson-dev opus-dev python2
+ speex-dev xz-dev"
subpackages="$pkgname-lang $pkgname-gtk"
source="https://download.handbrake.fr/releases/$pkgver/HandBrake-$pkgver-source.tar.bz2
handbrake-9999-fix-missing-x265-link-flag.patch
@@ -26,7 +26,6 @@ options="!check"
builddir="$srcdir"/${_pkgname}-${pkgver}
prepare() {
- cd "$builddir"
default_prepare
# build against external libs
sed -i 's:.*contrib/.*::g' \
@@ -34,7 +33,6 @@ prepare() {
}
build() {
- cd "$builddir"
./configure \
--prefix=/usr \
--force \