aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-05-30 01:01:53 +0300
committerprspkt <prspkt@protonmail.com>2019-05-30 01:16:34 +0300
commit4d4ab6548eb0ec3faa924deab15cb21f9e77834d (patch)
tree6a966b067afd0b58939aea808f2fa7dbd3c11d59
parenta6c0b1f90ec0f9a797f1fc0a1edd08bb63166442 (diff)
downloadaports-4d4ab6548eb0ec3faa924deab15cb21f9e77834d.tar.bz2
aports-4d4ab6548eb0ec3faa924deab15cb21f9e77834d.tar.xz
testing/py3-typed-ast: new aport
-rw-r--r--testing/py3-typed_ast/APKBUILD28
1 files changed, 28 insertions, 0 deletions
diff --git a/testing/py3-typed_ast/APKBUILD b/testing/py3-typed_ast/APKBUILD
new file mode 100644
index 0000000000..d05d3ef35b
--- /dev/null
+++ b/testing/py3-typed_ast/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: prspkt <prspkt@protonmail.com>
+# Maintainer: prspkt <prspkt@protonmail.com>
+pkgname=py3-typed-ast
+_pkgname=typed-ast
+pkgver=1.3.5
+pkgrel=0
+pkgdesc="Fork of the Python ast module with type comment support"
+url="https://github.com/python/typed_ast"
+arch="all"
+license="Apache-2.0"
+depends="python3"
+makedepends="py3-setuptools python3-dev"
+source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir/"$_pkgname-$pkgver
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e02a13d28b793229f5535a9e794f740d089b63fc632053a44f44b53d64d1742b5aca9d0ae4e0a292488524822a056181a21fa809d0b7e8eaadffb0f8e2c02f20 typed-ast-1.3.5.tar.gz"