aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-26 18:37:09 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-31 09:01:39 +0000
commit5e89308cc32ca144e62e16e13144e5258f3ff512 (patch)
treea79828370dc49c37855be04abdf2f7d178a9c659
parentf442fe9e705ac44143242a302259acc8ed5bfea7 (diff)
downloadaports-5e89308cc32ca144e62e16e13144e5258f3ff512.tar.bz2
aports-5e89308cc32ca144e62e16e13144e5258f3ff512.tar.xz
main/farstream0.1: remove
- Depends on unmaintained gst0.10
-rw-r--r--main/farstream0.1/APKBUILD56
-rw-r--r--main/farstream0.1/gtk-doc.patch127
2 files changed, 0 insertions, 183 deletions
diff --git a/main/farstream0.1/APKBUILD b/main/farstream0.1/APKBUILD
deleted file mode 100644
index c7b45b73dc..0000000000
--- a/main/farstream0.1/APKBUILD
+++ /dev/null
@@ -1,56 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=farstream0.1
-pkgver=0.1.2
-pkgrel=2
-pkgdesc="Libraries for videoconferencing"
-url="http://www.freedesktop.org/wiki/Software/Farstream"
-arch="all"
-license="LGPL-2.0-or-later"
-depends=""
-depends_dev="libnice-dev gstreamer0.10-dev gst-plugins-base0.10-dev"
-makedepends="$depends_dev gobject-introspection-dev py-gobject-dev python2-dev
- py-gst0.10"
-install=""
-replaces="farstream"
-subpackages="$pkgname-dev $pkgname-doc py-$pkgname:py"
-source="https://freedesktop.org/software/farstream/releases/farstream/farstream-$pkgver.tar.gz
- gtk-doc.patch"
-
-_builddir="$srcdir"/farstream-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- update_config_sub || return 1
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
-
-build() {
- cd "$_builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --enable-python \
- || return 1
- make -C farstream -j1 || return 1
- make || return 1
-}
-
-package() {
- cd "$_builddir"
- make DESTDIR="$pkgdir" install || return 1
-}
-
-py() {
- pkgdesc="Python binding for farstream"
- mkdir -p "$subpkgdir"/usr/lib/
- mv "$pkgdir"/usr/lib/python* "$subpkgdir"/usr/lib/
-}
-
-sha512sums="7d9ddde5d17205752a17298fb90cf855a828b2ae58746fbdc7e47749cee5e5eac4fd56f97f58251a5d253901cdd555e9cfade6016b6d92df99daefbe850e2910 farstream-0.1.2.tar.gz
-197f8fb222a3588bb5831c723adaa09f56149ced995fe17d7527ec17504613ed6d8c3df6349e9f9e516cc1be955add4c3c851e93d5dc4a95b6424279cafcbbe4 gtk-doc.patch"
diff --git a/main/farstream0.1/gtk-doc.patch b/main/farstream0.1/gtk-doc.patch
deleted file mode 100644
index 7414b1a929..0000000000
--- a/main/farstream0.1/gtk-doc.patch
+++ /dev/null
@@ -1,127 +0,0 @@
-From 39450457190675716c8e66700e35b05334a6a1a0 Mon Sep 17 00:00:00 2001
-From: Olivier CrĂȘte <olivier.crete@collabora.com>
-Date: Fri, 25 May 2012 21:06:59 +0000
-Subject: Gtk-doc tags belong after the description
-
----
-diff --git a/farstream/fs-session.c b/farstream/fs-session.c
-index 80794d1..abb1bc3 100644
---- a/farstream/fs-session.c
-+++ b/farstream/fs-session.c
-@@ -270,9 +270,6 @@ fs_session_class_init (FsSessionClass *klass)
- /**
- * FsSession:codec-preferences:
- *
-- * Type: GLib.List(FsCodec)
-- * Transfer: full
-- *
- * This is the current preferences list for the local codecs. It is
- * set by the user to specify the codec options and priorities. The user may
- * change its value with fs_session_set_codec_preferences() at any time
-@@ -283,6 +280,9 @@ fs_session_class_init (FsSessionClass *klass)
- * or %FS_CODEC_ID_ANY. If the encoding name is "reserve-pt", then the
- * payload type of the codec will be "reserved" and not be used by any
- * dynamically assigned payload type.
-+ *
-+ * Type: GLib.List(FsCodec)
-+ * Transfer: full
- */
- g_object_class_install_property (gobject_class,
- PROP_CODEC_PREFERENCES,
-@@ -296,9 +296,6 @@ fs_session_class_init (FsSessionClass *klass)
- /**
- * FsSession:codecs:
- *
-- * Type: GLib.List(FsCodec)
-- * Transfer: full
-- *
- * This is the list of codecs used for this session. It will include the
- * codecs and payload type used to receive media on this session. It will
- * also include any configuration parameter that must be transmitted reliably
-@@ -317,6 +314,8 @@ fs_session_class_init (FsSessionClass *klass)
- * It is a #GList of #FsCodec. User must free this codec list using
- * fs_codec_list_destroy() when done.
- *
-+ * Type: GLib.List(FsCodec)
-+ * Transfer: full
- */
- g_object_class_install_property (gobject_class,
- PROP_CODECS,
-@@ -329,9 +328,6 @@ fs_session_class_init (FsSessionClass *klass)
- /**
- * FsSession:codecs-without-config:
- *
-- * Type: GLib.List(FsCodec)
-- * Transfer: full
-- *
- * This is the same list of codecs as #FsSession:codecs without
- * the configuration information that describes the data sent. It is suitable
- * for configurations where a list of codecs is shared by many senders.
-@@ -349,6 +345,8 @@ fs_session_class_init (FsSessionClass *klass)
- * It is a #GList of #FsCodec. User must free this codec list using
- * fs_codec_list_destroy() when done.
- *
-+ * Type: GLib.List(FsCodec)
-+ * Transfer: full
- */
- g_object_class_install_property (gobject_class,
- PROP_CODECS_WITHOUT_CONFIG,
-diff --git a/farstream/fs-stream.c b/farstream/fs-stream.c
-index b9e1320..110641d 100644
---- a/farstream/fs-stream.c
-+++ b/farstream/fs-stream.c
-@@ -176,13 +176,12 @@ fs_stream_class_init (FsStreamClass *klass)
- /**
- * FsStream:remote-codecs:
- *
-- * Type: GLib.List(FsCodec)
-- * Transfer: full
-- *
- * This is the list of remote codecs for this stream. They must be set by the
- * user as soon as they are known using fs_stream_set_remote_codecs()
- * (generally through external signaling). It is a #GList of #FsCodec.
- *
-+ * Type: GLib.List(FsCodec)
-+ * Transfer: full
- */
- g_object_class_install_property (gobject_class,
- PROP_REMOTE_CODECS,
-@@ -195,15 +194,14 @@ fs_stream_class_init (FsStreamClass *klass)
- /**
- * FsStream:negotiated-codecs:
- *
-- * Type: GLib.List(FsCodec)
-- * Transfer: full
-- *
- * This is the list of negotiatied codecs, it is the same list as the list
- * of #FsCodec from the parent #FsSession, except that the codec config data
- * has been replaced with the data from the remote codecs for this stream.
- * This is the list of #FsCodec used to receive data from this stream.
- * It is a #GList of #FsCodec.
- *
-+ * Type: GLib.List(FsCodec)
-+ * Transfer: full
- */
- g_object_class_install_property (gobject_class,
- PROP_NEGOTIATED_CODECS,
-@@ -216,9 +214,6 @@ fs_stream_class_init (FsStreamClass *klass)
- /**
- * FsStream:current-recv-codecs:
- *
-- * Type: GLib.List(FsCodec)
-- * Transfer: full
-- *
- * This is the list of codecs that have been received by this stream.
- * The user must free the list if fs_codec_list_destroy().
- * The "farstream-recv-codecs-changed" message is send on the #GstBus
-@@ -228,6 +223,8 @@ fs_stream_class_init (FsStreamClass *klass)
- * also be emitted if the pad already exists, but the source material that
- * will come to it is different.
- *
-+ * Type: GLib.List(FsCodec)
-+ * Transfer: full
- */
- g_object_class_install_property (gobject_class,
- PROP_CURRENT_RECV_CODECS,
---
-cgit v0.9.0.3