aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2016-11-26 00:39:09 +0100
committerJakub Jirutka <jakub@jirutka.cz>2016-11-26 01:27:08 +0100
commita6543d44831453a1fa8628ad570abb88c0971a96 (patch)
tree47e4f5e17f8666923ec126005f9ccba1228c80c1
parent6dffd98982df63a60bb820d80bd04574e1df4fec (diff)
downloadaports-a6543d44831453a1fa8628ad570abb88c0971a96.tar.bz2
aports-a6543d44831453a1fa8628ad570abb88c0971a96.tar.xz
main/nodejs-lts: improve abuild
-rw-r--r--main/nodejs-lts/APKBUILD35
1 files changed, 14 insertions, 21 deletions
diff --git a/main/nodejs-lts/APKBUILD b/main/nodejs-lts/APKBUILD
index a784a1d939..55d1f53f07 100644
--- a/main/nodejs-lts/APKBUILD
+++ b/main/nodejs-lts/APKBUILD
@@ -4,35 +4,27 @@
pkgname=nodejs-lts
pkgver=4.5.0
pkgrel=0
-pkgdesc='Evented I/O for V8 javascript'
-url='http://nodejs.org/'
-arch='all'
-license='MIT'
+pkgdesc="JavaScript runtime built on V8 engine - LTS version"
+url="http://nodejs.org/"
+arch="all"
+license="MIT"
# gold is needed for mksnapshot
-makedepends="$depends_dev python2 openssl-dev zlib-dev libuv-dev
- linux-headers paxmark binutils-gold"
+makedepends="python2 openssl-dev zlib-dev libuv-dev linux-headers paxmark
+ binutils-gold"
subpackages="$pkgname-dev $pkgname-doc"
replaces="nodejs"
source="https://nodejs.org/dist/v$pkgver/node-v$pkgver.tar.gz"
-_builddir="$srcdir"/node-v$pkgver
-
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/node-v$pkgver"
build() {
- cd "$_builddir"
+ cd "$builddir"
+
./configure --prefix=/usr \
--shared-zlib \
--shared-libuv \
--shared-openssl \
|| return 1
+
# we need run mksnapshot at build time so paxmark it early
make -C out mksnapshot BUILDTYPE=Release \
&& paxmark -m out/Release/mksnapshot \
@@ -40,17 +32,18 @@ build() {
}
package() {
- local d
- cd "$_builddir"
+ cd "$builddir"
+
make DESTDIR="$pkgdir" install || return 1
# paxmark so JIT works
paxmark -m "$pkgdir"/usr/bin/node || return 1
cp -pr "$pkgdir"/usr/lib/node_modules/npm/man "$pkgdir"/usr/share || return 1
- for d in doc html man; do
+ local d; for d in doc html man; do
rm -r "$pkgdir"/usr/lib/node_modules/npm/$d || return 1
done
}
+
md5sums="1885586b4b8a2263f77dce27855661e9 node-v4.5.0.tar.gz"
sha256sums="74ced83b8d890d90e2a8b0d54b0d0e9b5e01d6fd6148cec6e9911ff6eaf0cf21 node-v4.5.0.tar.gz"
sha512sums="c4ad7382a387365febc664b11253b01d8e638501419daca0f26eecad9fa285dc9745d81c406aa015ad48d8f2e41371c216494b1318ce5e3c12a945d6e837e790 node-v4.5.0.tar.gz"