aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2018-07-07 13:33:31 +0200
committerJakub Jirutka <jakub@jirutka.cz>2018-07-07 18:41:28 +0200
commitc1a4655c1c5ba63241798b9b574c2439cb244320 (patch)
tree61a55d65e3455580770e6da5739029eaba2ecaff
parent4989c8474b3a62277cb3d96e6cce2435aac32358 (diff)
downloadaports-c1a4655c1c5ba63241798b9b574c2439cb244320.tar.bz2
aports-c1a4655c1c5ba63241798b9b574c2439cb244320.tar.xz
testing/ocaml-lwt: rename subpkg ocaml-lwt-react to ocaml-lwt_react
To be consistent in naming.
-rw-r--r--testing/ocaml-lambda-term/APKBUILD5
-rw-r--r--testing/ocaml-lwt/APKBUILD8
-rw-r--r--testing/utop/APKBUILD4
3 files changed, 8 insertions, 9 deletions
diff --git a/testing/ocaml-lambda-term/APKBUILD b/testing/ocaml-lambda-term/APKBUILD
index 87c01ff739..b8ce16fb54 100644
--- a/testing/ocaml-lambda-term/APKBUILD
+++ b/testing/ocaml-lambda-term/APKBUILD
@@ -3,19 +3,18 @@
pkgname=ocaml-lambda-term
_pkgname=lambda-term
pkgver=1.12.0
-pkgrel=4
+pkgrel=5
pkgdesc="Terminal manipulation library for OCaml"
url="https://github.com/diml/lambda-term"
# x86, armhf, s390x: limited by ocaml aport
arch="all !x86 !armhf !s390x"
license="BSD-3-Clause"
-depends="ocaml-camomile ocaml-lwt ocaml-lwt-react ocaml-zed"
+depends="ocaml-camomile ocaml-lwt ocaml-lwt_react ocaml-zed"
makedepends="
dune
ocaml
ocaml-camomile-dev
ocaml-lwt-dev
- ocaml-lwt-react
ocaml-findlib
ocaml-react-dev
ocaml-result-dev
diff --git a/testing/ocaml-lwt/APKBUILD b/testing/ocaml-lwt/APKBUILD
index 040a791a16..c23100bc7d 100644
--- a/testing/ocaml-lwt/APKBUILD
+++ b/testing/ocaml-lwt/APKBUILD
@@ -3,7 +3,7 @@
pkgname=ocaml-lwt
_pkgname=lwt
pkgver=3.3.0
-pkgrel=0
+pkgrel=1
pkgdesc="OCaml promises and concurrent I/O"
url="https://github.com/ocsigen/lwt"
arch="all !x86 !armhf !s390x" # limited by ocaml aport
@@ -26,7 +26,7 @@ makedepends="$depends_dev
ocaml-result-dev
opam
"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-react"
+subpackages="$pkgname-dev $pkgname-doc ${pkgname}_react:_react"
source="$pkgname-$pkgver.tar.gz::https://github.com/ocsigen/$_pkgname/archive/$pkgver.tar.gz
result_lseek_noinline.patch"
builddir="$srcdir/$_pkgname-$pkgver"
@@ -68,7 +68,7 @@ package() {
rm -Rf "$pkgdir"/usr/lib/ocaml/$_pkgname*/*.ml
}
-react() {
+_react() {
pkgdesc="$pkgdesc (for FRP)"
depends="$pkgname=$pkgver-r$pkgrel ocaml-react"
@@ -78,7 +78,7 @@ react() {
dev() {
default_dev
- depends="$depends $pkgname=$pkgver-r$pkgrel $pkgname-react=$pkgver-r$pkgrel"
+ depends="$depends $pkgname=$pkgver-r$pkgrel ${pkgname}_react=$pkgver-r$pkgrel"
local sitelib="usr/lib/ocaml/$_pkgname"
cd "$pkgdir"/$sitelib
diff --git a/testing/utop/APKBUILD b/testing/utop/APKBUILD
index bfd2f04b7b..82f20cf8c3 100644
--- a/testing/utop/APKBUILD
+++ b/testing/utop/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=utop
pkgver=2.1.0
-pkgrel=1
+pkgrel=2
pkgdesc="Universal toplevel for OCaml"
url="https://github.com/diml/utop"
# x86, armhf, s390x: limited by ocaml aport
@@ -18,7 +18,7 @@ _depends_ocaml="
ocaml-findlib>=1.7.2
ocaml-lambda-term
ocaml-lwt
- ocaml-lwt-react
+ ocaml-lwt_react
ocaml-react
"
makedepends="