aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2018-11-23 07:42:29 +0100
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-23 14:41:42 +0000
commit00fc18aa0c07998215c7fc55185c63ae496592eb (patch)
treeb73bbc99fe86cd7f8e66cb5fb9a3b9c56b70213b
parent6413d57449d77bb2f9af64f3da33b28630b501d8 (diff)
downloadaports-00fc18aa0c07998215c7fc55185c63ae496592eb.tar.bz2
aports-00fc18aa0c07998215c7fc55185c63ae496592eb.tar.xz
main/open-vm-tools: fix reboot and halt
-rw-r--r--main/open-vm-tools/APKBUILD4
-rw-r--r--main/open-vm-tools/systemLinux.c-fixup-for-Alpine.patch36
2 files changed, 39 insertions, 1 deletions
diff --git a/main/open-vm-tools/APKBUILD b/main/open-vm-tools/APKBUILD
index 63da7dfad8..eb85534b4d 100644
--- a/main/open-vm-tools/APKBUILD
+++ b/main/open-vm-tools/APKBUILD
@@ -3,7 +3,7 @@ pkgname=open-vm-tools
pkgver=10.3.5
_pkgsubver=${pkgver#*_p}
_ver=${pkgver/_p/-}
-pkgrel=0
+pkgrel=1
pkgdesc="The Open Virtual Machine Tools are the open source implementation of VMware Tools."
url="https://github.com/vmware/open-vm-tools/"
arch="x86 x86_64"
@@ -31,6 +31,7 @@ source="$pkgname-$pkgver.tar.gz::https://github.com/vmware/$pkgname/archive/stab
0011-use-off64_t-instead-of-loff_t.patch
0012-remove-references-to-missing-common-agent-etc-config.patch
strerror_r.patch
+ systemLinux.c-fixup-for-Alpine.patch
$pkgname.initd
$pkgname.confd
@@ -138,6 +139,7 @@ ff807233d0d1b15897d012080851007d23ad6e19c76eb85c9f63673491a4ff622a7d69d99c4a23ff
a38bb2ac16657be9f7e9b2a5e32d23e66db1f283284c1cb8e7ffe853e047373397e60f01e735a28ecfaa60010f285b0b5a4066465a2afbe643a9b4b9b74ac1f4 0011-use-off64_t-instead-of-loff_t.patch
ae00f77279a76f0d5205e7c6e8e2a9abd8fd1590244a907792c9be003c38c057eee015aba3e79bd956b4197dc03b7a6eb3935620f3d3cbc4d4e7c62187ae76ce 0012-remove-references-to-missing-common-agent-etc-config.patch
5507a58198179805e4c924b6bd6ac8b026bd602c9e5e4c52213dadf6c8880a23a16ee49a4dfe2db27515c2a36009e609dd81b7ee0d560bbea1ddf6a5324eb7ac strerror_r.patch
+c18280eb3fdfe1e3ecc5aa116369908c71917bd4dd49743a9abf78e0096e8d6c7d4323057cf506ef31886b893b2e4c4839656172edd5097a347efa96aea1c86c systemLinux.c-fixup-for-Alpine.patch
d4d0c0c3042eef4d241c933de6f7c398a88275744b3576efc2f909acd681752f548e4ae4a17eca7db731ee0b9254b46169a48463d12a72ec6354065d788159f4 open-vm-tools.initd
ffc9c945a41e48791bab61ba72fed96c1a6ae3722caa715424e3077d167421b4e2f53bb4d415ab227d1f6e40d6ca3779df41e6b0a38db34b520979fa2b19298d open-vm-tools.confd
5626c68b8ee01ece804f314b829476280e892581a448c27092e32a60b04d40ecfa8e8eca464c4376c3cfc497eb60406798b7383d1a747a173d3cd8b78d23100b open-vm-tools.logrotate"
diff --git a/main/open-vm-tools/systemLinux.c-fixup-for-Alpine.patch b/main/open-vm-tools/systemLinux.c-fixup-for-Alpine.patch
new file mode 100644
index 0000000000..1b7799ec62
--- /dev/null
+++ b/main/open-vm-tools/systemLinux.c-fixup-for-Alpine.patch
@@ -0,0 +1,36 @@
+From db3546f6234506d51caf91e3763bfdf000828156 Mon Sep 17 00:00:00 2001
+From: Henrik Riomar <henrik.riomar@gmail.com>
+Date: Fri, 23 Nov 2018 07:40:22 +0100
+Subject: [PATCH] systemLinux.c: fixup for Alpine
+
+/sbin/shutdown -r now -> /sbin/reboot
+/sbin/shutdown -h now -> /sbin/halt
+---
+ open-vm-tools/lib/system/systemLinux.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/open-vm-tools/lib/system/systemLinux.c b/open-vm-tools/lib/system/systemLinux.c
+index c74d4890..c98ce962 100644
+--- a/open-vm-tools/lib/system/systemLinux.c
++++ b/open-vm-tools/lib/system/systemLinux.c
+@@ -312,7 +312,7 @@ System_Shutdown(Bool reboot) // IN: "reboot or shutdown" flag
+ #elif defined(USERWORLD)
+ cmd = "/bin/reboot";
+ #else
+- cmd = "/sbin/shutdown -r now";
++ cmd = "/sbin/reboot";
+ #endif
+ } else {
+ #if __FreeBSD__
+@@ -322,7 +322,7 @@ System_Shutdown(Bool reboot) // IN: "reboot or shutdown" flag
+ #elif defined(USERWORLD)
+ cmd = "/bin/halt";
+ #else
+- cmd = "/sbin/shutdown -h now";
++ cmd = "/sbin/halt";
+ #endif
+ }
+ if (system(cmd) == -1) {
+--
+2.19.1
+