aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-11-12 14:05:02 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-11-12 10:48:38 -0300
commit15a08e31dde3fc03fbbba239e3214b0e454be521 (patch)
tree80a0a60c93f27443b5eee1c722c7feffa3b59224
parentfd50f98d4fade9978e6d7815485a93b5231a2c69 (diff)
downloadaports-15a08e31dde3fc03fbbba239e3214b0e454be521.tar.bz2
aports-15a08e31dde3fc03fbbba239e3214b0e454be521.tar.xz
community/libksane: move from testing
-rw-r--r--community/libksane/APKBUILD (renamed from testing/libksane/APKBUILD)13
1 files changed, 11 insertions, 2 deletions
diff --git a/testing/libksane/APKBUILD b/community/libksane/APKBUILD
index 1c8d8a303b..2ae8e7244f 100644
--- a/testing/libksane/APKBUILD
+++ b/community/libksane/APKBUILD
@@ -8,11 +8,18 @@ url="https://www.kde.org/applications/graphics/"
pkgdesc="An image scanning library"
license="LGPL-2.1-only OR LGPL-3.0-only"
makedepends="extra-cmake-modules qt5-qtbase-dev ki18n-dev kwidgetsaddons-dev ktextwidgets-dev kwallet-dev sane-dev"
-source="https://download.kde.org/stable/applications/$pkgver/src/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/applications/$pkgver/src/libksane-$pkgver.tar.xz"
subpackages="$pkgname-dev $pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -20,10 +27,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}