aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDrew DeVault <sir@cmpwn.com>2019-03-06 14:01:24 -0700
committerCarlo Landmeter <clandmeter@alpinelinux.org>2019-03-18 21:06:54 +0000
commit32552889cc50bfc3baf09c06a6cf334b3b1ca228 (patch)
treea4947d211012550489dfa0f70e3a08d5b916f81e
parentd0f037160bf35f8524f430ee2d82ffcf36135719 (diff)
downloadaports-32552889cc50bfc3baf09c06a6cf334b3b1ca228.tar.bz2
aports-32552889cc50bfc3baf09c06a6cf334b3b1ca228.tar.xz
main/py-ukcodeparser: new APKBUILD
-rw-r--r--main/py-ukpostcodeparser/APKBUILD57
1 files changed, 57 insertions, 0 deletions
diff --git a/main/py-ukpostcodeparser/APKBUILD b/main/py-ukpostcodeparser/APKBUILD
new file mode 100644
index 0000000000..6cd72d4adb
--- /dev/null
+++ b/main/py-ukpostcodeparser/APKBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Drew DeVault <sir@cmpwn.com>
+pkgname=py-ukpostcodeparser
+_pkgname=ukpostcodeparser
+pkgver=1.1.2
+pkgrel=0
+pkgdesc="UK Postcode parser"
+url=https://github.com/hamstah/ukpostcodeparser
+arch=noarch
+license=MIT
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+makedepends="py-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/hamstah/$_pkgname/archive/v$pkgver.tar.gz"
+builddir=$srcdir/$_pkgname-$pkgver
+# tests broken upstream: https://github.com/hamstah/ukpostcodeparser/issues/8
+options="!check"
+
+prepare() {
+ cp -r "$builddir" "$builddir"-py3
+}
+
+build() {
+ cd "$builddir"
+ python2 setup.py build
+ cd "$builddir"-py3
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python2 setup.py test
+ cd "$builddir"-py3
+ python3 setup.py test
+}
+
+package() {
+ mkdir -p "$pkgdir"
+}
+
+_py2() {
+ cd "$builddir"
+ _py python2
+}
+
+_py3() {
+ cd "$builddir"-py3
+ _py python3
+}
+
+_py() {
+ python="$1"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+ $python setup.py install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="8113522b728c095f937a9f53f21c369130e3e63c4fc3546dbea4ad1c53648742fb0e766b1254c76ee65d69dec585f1a90caa7d39ca540de1765ff5f989a702de py-ukpostcodeparser-1.1.2.tar.gz"