aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-11 09:55:07 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-23 02:37:42 -0300
commit4b8e26b25b1e002dae024d30745d631733984ecd (patch)
treea9c259a0bf1e25117b5dd7e94cdf425d324ddfa9
parent0702746af30db435a63335edc75fe05ea2f8be92 (diff)
downloadaports-4b8e26b25b1e002dae024d30745d631733984ecd.tar.bz2
aports-4b8e26b25b1e002dae024d30745d631733984ecd.tar.xz
testing/yaru-themes: new aport
https://discourse.ubuntu.com/c/desktop/theme-refresh Ubuntu community theme
-rw-r--r--testing/yaru-themes/APKBUILD83
1 files changed, 83 insertions, 0 deletions
diff --git a/testing/yaru-themes/APKBUILD b/testing/yaru-themes/APKBUILD
new file mode 100644
index 0000000000..9380ebe024
--- /dev/null
+++ b/testing/yaru-themes/APKBUILD
@@ -0,0 +1,83 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=yaru-themes
+pkgver=19.10.1
+pkgrel=0
+pkgdesc="Ubuntu community theme"
+options="!check" # No testsuite
+url="https://discourse.ubuntu.com/c/desktop/theme-refresh"
+arch="noarch"
+license="GPL-3.0-or-later AND CC-BY-SA-4.0"
+makedepends="sassc meson glib-dev"
+subpackages="
+ yaru-common
+ yaru-icons
+ yaru
+ yaru-dark
+ yaru-gnome-shell
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/ubuntu/yaru/archive/$pkgver.tar.gz"
+builddir="$srcdir/yaru-$pkgver"
+
+build() {
+ meson \
+ --prefix=/usr \
+ -Dcommunitheme_compat=false \
+ . output
+ ninja -C output
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C output install
+}
+
+common() {
+ depends=""
+ pkgdesc="Common resources for yaru"
+
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/sounds "$subpkgdir"/usr/share
+}
+
+icons() {
+ depends=""
+ pkgdesc="Yaru theme icons"
+
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/icons "$subpkgdir"/usr/share
+}
+
+yaru() {
+ depends="yaru-common"
+ pkgdesc="Yaru, the Ubuntu community theme"
+
+ mkdir -p "$subpkgdir"/usr/share/themes
+ mv "$pkgdir"/usr/share/wayland-sessions \
+ "$pkgdir"/usr/share/xsessions \
+ "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/themes/Yaru \
+ "$subpkgdir"/usr/share/themes
+}
+
+dark() {
+ depends="yaru-common"
+ pkgdesc="Yaru dark, the dark variant of the Ubuntu community theme"
+
+ mkdir -p "$subpkgdir"/usr/share/themes
+ mv "$pkgdir"/usr/share/themes/Yaru-dark \
+ "$subpkgdir"/usr/share/themes
+}
+
+shell() {
+ depends="yaru-common yaru"
+ pkgdesc="Yaru theme for the GNOME Desktop Environment"
+
+ # Automatically install if we have yaru-common (user has installed
+ # yaru or yaru-dark)
+ install_if="yaru-common=$pkgver-r$pkgrel gnome-shell"
+
+ mkdir -p "$subpkgdir"/usr/share
+ mv "$pkgdir"/usr/share/gnome-shell "$subpkgdir"/usr/share
+}
+
+sha512sums="c76a4950f3bb6097e126f0767075b6b618e6c2102822941662086241b6b6631816466971f88f010fd9f0d0d8e19c53b35432fe21f6811236478d46be9e31654c yaru-themes-19.10.1.tar.gz"