aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-16 02:43:34 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-16 02:44:41 +0200
commit93c6fcfcd06e7f0c5e7c9452019e05a1d6db7cff (patch)
tree8404a4895fec06de0f153b037cad73f40a959df2
parent6fa07041d845d0c398c70179576f50782765027a (diff)
downloadaports-93c6fcfcd06e7f0c5e7c9452019e05a1d6db7cff.tar.bz2
aports-93c6fcfcd06e7f0c5e7c9452019e05a1d6db7cff.tar.xz
testing/libmpack: avoid flooding logs by tests
-rw-r--r--testing/libmpack/APKBUILD9
1 files changed, 8 insertions, 1 deletions
diff --git a/testing/libmpack/APKBUILD b/testing/libmpack/APKBUILD
index d850a7d41c..1f62a9392a 100644
--- a/testing/libmpack/APKBUILD
+++ b/testing/libmpack/APKBUILD
@@ -18,8 +18,15 @@ build() {
}
check() {
+ local out
cd "$builddir"
- make test
+
+ # Tests prints thousands lines, so print only last few when fails.
+ out=$(make test) || {
+ echo "Tests failed, printing last 50 lines of the output..."
+ printf '%s\n' "$out" | tail -n 50
+ return 1
+ }
}
package() {