aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorxming <xmingske@gmail.com>2014-10-22 11:16:18 +0000
committerCarlo Landmeter <clandmeter@gmail.com>2014-10-23 10:19:13 +0200
commitd8a77d5ec7a0763a5d239e691b959f629c886b79 (patch)
tree37df687dee26f69a3579bcea76f2431fc4c739e0
parent8bedd034a2560e3090de51dc2b25031cd5d5e52d (diff)
downloadaports-d8a77d5ec7a0763a5d239e691b959f629c886b79.tar.bz2
aports-d8a77d5ec7a0763a5d239e691b959f629c886b79.tar.xz
testing/py-django-registration: new aport
simple user-registration application for Django https://bitbucket.org/ubernostrum/django-registration/wiki/Home
-rw-r--r--testing/py-django-registation/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/py-django-registation/APKBUILD b/testing/py-django-registation/APKBUILD
new file mode 100644
index 0000000000..99d3ae86fa
--- /dev/null
+++ b/testing/py-django-registation/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: <xmingske@gmail.com>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+_pkgname=django-registration
+pkgname=py-${_pkgname}
+pkgver=1.0
+pkgrel=0
+pkgdesc="simple user-registration application for Django"
+url="https://bitbucket.org/ubernostrum/django-registration/wiki/Home"
+arch="noarch"
+license="BSD"
+makedepends="python-dev py-setuptools"
+depends="python"
+source="https://bitbucket.org/ubernostrum/django-registration/downloads/${_pkgname}-${pkgver}.tar.gz"
+
+_builddir="${srcdir}/${_pkgname}-${pkgver}"
+
+prepare() {
+ local pf
+ cd "${_builddir}"
+ for pf in $source; do
+ case $pf in
+ *.patch) msg $pf; patch -p1 -i "$srcdir"/${pf} || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "${_builddir}"
+ python setup.py build || return 1
+}
+
+package() {
+ cd "${_builddir}"
+ python setup.py install --prefix=/usr --root="$pkgdir" || return 1
+}
+
+md5sums="56a7e705dcef054ee44d51f1ef7b1db0 django-registration-1.0.tar.gz"
+sha256sums="f19112fa1c1f34eb46427afa280398d9f044a604d68d6d0d15047243e0a71d93 django-registration-1.0.tar.gz"
+sha512sums="53b191e4c75629d3ce93e4817a843bc1b056a14558be892aa95dc060b8b0542ddcae79f7cb0b37c4e758e8d9da093e59a57591294539acfed39b998b7087e0e6 django-registration-1.0.tar.gz"