aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-26 00:02:38 -0300
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-26 06:41:24 +0000
commit15a83dd81fc4b8dbdab67e9ecb1e2ae1ac3bc502 (patch)
tree51484355728fce6f36a4cec6a2c5f435e3e3e131
parent1e0473b4ef507ec1294b70a0dd0267ce07b7219d (diff)
downloadaports-15a83dd81fc4b8dbdab67e9ecb1e2ae1ac3bc502.tar.bz2
aports-15a83dd81fc4b8dbdab67e9ecb1e2ae1ac3bc502.tar.xz
testing/py3-maxminddb: modernize
-rw-r--r--testing/py3-maxminddb/APKBUILD10
1 files changed, 2 insertions, 8 deletions
diff --git a/testing/py3-maxminddb/APKBUILD b/testing/py3-maxminddb/APKBUILD
index 69ebbb241e..29ddaaa6da 100644
--- a/testing/py3-maxminddb/APKBUILD
+++ b/testing/py3-maxminddb/APKBUILD
@@ -8,7 +8,7 @@ url="http://maxminddb.readthedocs.org/"
arch="all"
license="Apache-2.0"
depends="python3"
-makedepends="libmaxminddb-dev python3 python3-dev py3-setuptools"
+makedepends="libmaxminddb-dev python3-dev py3-setuptools"
checkdepends="py3-nose py3-mock"
_test_data_commit=90c7fb95d67ee03ca7fc487fb69f525bcc19a671
source="$pkgname-$pkgver.tar.gz::https://github.com/maxmind/MaxMind-DB-Reader-python/archive/v$pkgver.tar.gz
@@ -22,24 +22,18 @@ prepare() {
# Submodule required for tests
cp -r "MaxMind-DB-$_test_data_commit/"* "$builddir/tests/data"
- default_prepare
+ default_prepare
}
build() {
- cd "$builddir"
-
python3 setup.py build
}
check() {
- cd "$builddir"
-
python3 setup.py test
}
package() {
- cd "$builddir"
-
python3 setup.py install --prefix=/usr --root="$pkgdir"
}