aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-08 04:28:44 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-06-14 11:28:32 +0000
commit4ba27c27fdc9343eea9f969f83e2ab91d4e7a8c7 (patch)
tree304970591facac949bbcd2e188b7093957ba56cc
parentece355c794df3630dde557a77765ee81dd95e3eb (diff)
downloadaports-4ba27c27fdc9343eea9f969f83e2ab91d4e7a8c7.tar.bz2
aports-4ba27c27fdc9343eea9f969f83e2ab91d4e7a8c7.tar.xz
community/libetpan: upgrade to 1.9.3
-rw-r--r--community/libetpan/APKBUILD16
-rw-r--r--community/libetpan/fix-build.patch14
2 files changed, 21 insertions, 9 deletions
diff --git a/community/libetpan/APKBUILD b/community/libetpan/APKBUILD
index 7c243b4e66..6b645de795 100644
--- a/community/libetpan/APKBUILD
+++ b/community/libetpan/APKBUILD
@@ -1,6 +1,6 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libetpan
-pkgver=1.9.2
+pkgver=1.9.3
pkgrel=0
pkgdesc="a portable middleware for email access"
url="http://www.etpan.org/"
@@ -11,18 +11,16 @@ makedepends="db-dev cyrus-sasl-dev curl-dev expat-dev gnutls-dev libgcrypt-dev
libgpg-error-dev autoconf automake libtool zlib-dev"
depends_dev="cyrus-sasl-dev db-dev"
source="libetpan-$pkgver.tar.gz::https://github.com/dinhviethoa/libetpan/archive/$pkgver.tar.gz
+ fix-build.patch
"
-builddir="$srcdir/$pkgname-$pkgver"
-
prepare() {
default_prepare
- cd "$builddir"
- ./autogen.sh
+ touch README
+ autoreconf -fi
}
-build () {
- cd "$builddir"
+build() {
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -35,7 +33,6 @@ build () {
}
check() {
- cd "$builddir"
make check
}
@@ -45,4 +42,5 @@ package() {
install -Dm644 COPYRIGHT "$pkgdir"/usr/share/licenses/$pkgname/license.txt
}
-sha512sums="3e2e1de77fae2212374e909d15ed8564eee90883c38fee0ca69f58785733b1ac2df848da1bda6f55577d647e0ad27bc3057199e70b6ef01f2a7e2823b24113ba libetpan-1.9.2.tar.gz"
+sha512sums="66e504fbf82445819845a3f1dcb8dc48ad2440993134d43752c754463cee2434a30080718687cd05c579f0da8df6b0f6dfc7572f2882d0dd9dfd327b4ae11fd6 libetpan-1.9.3.tar.gz
+85d0be0b1a57cb5865a6802c01c9f4fe3e4e32b06929a9c7f688be6f2115a2f6ea8229fd637f83d1376925939b7112bcb6704a9bd79206bf821c32f06747e6c9 fix-build.patch"
diff --git a/community/libetpan/fix-build.patch b/community/libetpan/fix-build.patch
new file mode 100644
index 0000000000..20fd34c13d
--- /dev/null
+++ b/community/libetpan/fix-build.patch
@@ -0,0 +1,14 @@
+diff --git a/src/low-level/imap/clientid.c b/src/low-level/imap/clientid.c
+index 1c34637..f28b616 100644
+--- a/src/low-level/imap/clientid.c
++++ b/src/low-level/imap/clientid.c
+@@ -33,6 +33,8 @@
+ # include <config.h>
+ #endif
+
++#include <stddef.h>
++
+ #include "mailimap_sender.h"
+ #include "clientid_sender.h"
+ #include "clientid.h"
+