aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBreno Leitao <brenohl@br.ibm.com>2017-01-18 08:59:32 -0500
committerJakub Jirutka <jakub@jirutka.cz>2017-01-18 16:37:21 +0100
commit5d05878ab2390a86859e5c60c34e5190fbbf0ba3 (patch)
treeb7d4648c7a4b3913ab98e85c0069466866ac7d0f
parent7aa1cbc53fba73b072e4c1f651bba5efdb713430 (diff)
downloadaports-5d05878ab2390a86859e5c60c34e5190fbbf0ba3.tar.bz2
aports-5d05878ab2390a86859e5c60c34e5190fbbf0ba3.tar.xz
main/linux-headers: add entry for powerpc platforms
This patch simply adds an entry to build linux-header for powerpc platforms. The main target is ppc64le architecture, which uses Linux ARCH=powerpc on the Makefiles.
-rw-r--r--main/linux-headers/APKBUILD3
1 files changed, 2 insertions, 1 deletions
diff --git a/main/linux-headers/APKBUILD b/main/linux-headers/APKBUILD
index 890a6483f3..f3c0bf87a4 100644
--- a/main/linux-headers/APKBUILD
+++ b/main/linux-headers/APKBUILD
@@ -2,7 +2,7 @@
pkgname=linux-headers
pkgver=4.4.6
_kernver=${pkgver%.*}
-pkgrel=1
+pkgrel=2
pkgdesc="Linux system headers"
url="http://kernel.org"
arch="all"
@@ -39,6 +39,7 @@ package() {
aarch64*) _carch="arm64" ;;
arm*) _carch="arm" ;;
s390*) _carch="s390" ;;
+ ppc64*) _carch="powerpc" ;;
esac
cd "$srcdir"/linux-$_kernver