aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Isaksen <d@duniel.no>2018-11-17 18:03:33 +0000
committerCarlo Landmeter <clandmeter@alpinelinux.org>2018-11-18 08:46:41 +0000
commit6058daedf9414ad93c1cccdc1c517f327722764d (patch)
treed18164426d1267353dbc876c93e8fce4a7eddb95
parent21e0088fa65ab3a54943ad9cdbf9cd2c53da3bd7 (diff)
downloadaports-6058daedf9414ad93c1cccdc1c517f327722764d.tar.bz2
aports-6058daedf9414ad93c1cccdc1c517f327722764d.tar.xz
commit/libfreehand: remove superfluous parentheses
-rw-r--r--community/libfreehand/APKBUILD6
-rw-r--r--community/libfreehand/parentheses-gcc8-fix.patch13
2 files changed, 17 insertions, 2 deletions
diff --git a/community/libfreehand/APKBUILD b/community/libfreehand/APKBUILD
index a37bcebe58..88a9cd6fb5 100644
--- a/community/libfreehand/APKBUILD
+++ b/community/libfreehand/APKBUILD
@@ -12,7 +12,8 @@ depends_dev="libxml2-dev lcms2-dev icu-dev"
makedepends="$depends_dev gperf perl doxygen librevenge-dev zlib-dev"
install=""
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
-source="https://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz"
+source="https://dev-www.libreoffice.org/src/$pkgname/$pkgname-$pkgver.tar.xz
+ parentheses-gcc8-fix.patch"
builddir="$srcdir/$pkgname-$pkgver"
@@ -49,4 +50,5 @@ tools() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr
}
-sha512sums="4112a76ac99999801d97d1b282596d631d8496a5bf65778ab26aa06da86637b1e2b630648a67ea01bf3316ecec9f2715546baff27af090b900267c87a011b963 libfreehand-0.1.2.tar.xz"
+sha512sums="4112a76ac99999801d97d1b282596d631d8496a5bf65778ab26aa06da86637b1e2b630648a67ea01bf3316ecec9f2715546baff27af090b900267c87a011b963 libfreehand-0.1.2.tar.xz
+af4e1fd4fa75a5d45bd9072abc934a0f1d86e0a6d1deaca955bb18bd8ba0f78cd20e0f442e61c52587264ec828ec46a711e0f463fa152e5a1968ac0c5af822f3 parentheses-gcc8-fix.patch"
diff --git a/community/libfreehand/parentheses-gcc8-fix.patch b/community/libfreehand/parentheses-gcc8-fix.patch
new file mode 100644
index 0000000000..7af1b05345
--- /dev/null
+++ b/community/libfreehand/parentheses-gcc8-fix.patch
@@ -0,0 +1,13 @@
+diff --git a/src/lib/FHCollector.cpp b/src/lib/FHCollector.cpp
+index 874ab46edf..a5ab52ed9a 100644
+--- a/src/lib/FHCollector.cpp
++++ b/src/lib/FHCollector.cpp
+@@ -1907,7 +1907,7 @@ void libfreehand::FHCollector::_outputDisplayText(const libfreehand::FHDisplayTe
+ textObjectProps.insert("svg:width", width);
+ for (int i=0; i<4; ++i) // osnola: let assume that there is no padding
+ {
+- char const *(padding[])= {"fo:padding-left","fo:padding-right","fo:padding-top","fo:padding-bottom"};
++ char const *padding[]= {"fo:padding-left","fo:padding-right","fo:padding-top","fo:padding-bottom"};
+ textObjectProps.insert(padding[i],0,librevenge::RVNG_POINT);
+ }
+ if (!FH_ALMOST_ZERO(rotation))