aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-03-28 18:27:45 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-03-28 18:36:39 +0200
commit6c35ac03b9497af1491c8c9fd386faf5e78905f0 (patch)
tree55eab09e97faf643fc03aa314e3a2dfc023b712b
parentf6bcf1effdea11c3834fbe77de2998c7a2e799f0 (diff)
downloadaports-6c35ac03b9497af1491c8c9fd386faf5e78905f0.tar.bz2
aports-6c35ac03b9497af1491c8c9fd386faf5e78905f0.tar.xz
main/php5: fix seding of nonexistent file /etc/php/php.ini
-rw-r--r--main/php5/APKBUILD9
1 files changed, 6 insertions, 3 deletions
diff --git a/main/php5/APKBUILD b/main/php5/APKBUILD
index 10e01917a6..c8a9289fe8 100644
--- a/main/php5/APKBUILD
+++ b/main/php5/APKBUILD
@@ -335,11 +335,14 @@ doc() {
common() {
pkgdesc="PHP Common Files"
depends=""
+
cd "$srcdir"/php-$pkgver
+
install -D -m644 php.ini-production "$subpkgdir"$_confdir/php.ini
- sed -i -e "s:^; extension_dir = \"./\":extension_dir = \"$_extdir\":" "$subpkgdir"/etc/php/php.ini
- sed -ri 's/;(date.timezone =)/\1 UTC/' "$subpkgdir"$_confdir/php.ini
- sed -ri "s~^([;]*cgi\.rfc2616_headers.*)$~\1\n\n\; If this is enabled, the PHP CGI binary can safely be placed outside of the\n; web tree and people will not be able to circumvent .htaccess security.\ncgi\.discard_path = 1~" "$subpkgdir"$_confdir/php.ini
+ sed -ri -e "s:^; extension_dir = \"./\":extension_dir = \"$_extdir\":" \
+ -e 's/;(date.timezone =)/\1 UTC/' \
+ -e "s~^([;]*cgi\.rfc2616_headers.*)$~\1\n\n\; If this is enabled, the PHP CGI binary can safely be placed outside of the\n; web tree and people will not be able to circumvent .htaccess security.\ncgi\.discard_path = 1~" \
+ "$subpkgdir"$_confdir/php.ini
}
cgi() {