aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndré Klitzing <aklitzing@gmail.com>2018-11-02 15:35:51 +0100
committerAndy Postnikov <apostnikov@gmail.com>2018-11-02 18:45:45 +0200
commitb0c4913719de7739dac8d0b968711d5a2434b06d (patch)
tree036cd71a08182e1cd6a69e4d1857aa222476d2a0
parentb399cc803aabd34f1bfd9b8c6a462ff3a56db325 (diff)
downloadaports-b0c4913719de7739dac8d0b968711d5a2434b06d.tar.bz2
aports-b0c4913719de7739dac8d0b968711d5a2434b06d.tar.xz
community/zstd: upgrade to 1.3.7
-rw-r--r--community/zstd/APKBUILD11
-rw-r--r--community/zstd/allow-invoking-list-when-stdin-not-tty.patch67
-rw-r--r--community/zstd/fix-list-tests-with-stdin.patch30
3 files changed, 4 insertions, 104 deletions
diff --git a/community/zstd/APKBUILD b/community/zstd/APKBUILD
index be2f1a1194..0c1b7ea2fd 100644
--- a/community/zstd/APKBUILD
+++ b/community/zstd/APKBUILD
@@ -1,17 +1,16 @@
# Contributor: stef <l0ls0fo2i@ctrlc.hu>
# Maintainer: André Klitzing <aklitzing@gmail.com>
pkgname=zstd
-pkgver=1.3.5
+pkgver=1.3.7
pkgrel=0
pkgdesc="Zstandard - Fast real-time compression algorithm"
url="http://www.zstd.net"
arch="all !armhf !armv7"
license="BSD-3-Clause GPL-2.0-or-later"
checkdepends="file"
+makedepends="grep"
subpackages="$pkgname-static $pkgname-libs $pkgname-dev $pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/facebook/$pkgname/archive/v$pkgver.tar.gz
- allow-invoking-list-when-stdin-not-tty.patch
- fix-list-tests-with-stdin.patch"
+source="$pkgname-$pkgver.tar.gz::https://github.com/facebook/zstd/archive/v$pkgver.tar.gz"
builddir="$srcdir/$pkgname-$pkgver"
build() {
@@ -36,6 +35,4 @@ static() {
mv "$pkgdir"/usr/lib/*.a "$subpkgdir"/usr/lib/
}
-sha512sums="a5347b132d6b79e6a7f39a4546cafc5cf85e8d01b765477011008908035789e914b1093e2b2405c75086f05a7bc87e29b69e10252260d747c5c056ce16f91661 zstd-1.3.5.tar.gz
-7d8bcf26b09270a41cd15d0d9f7b8d177e3fed152d7755558195d4dd0803bcb3d1568fb988bc0d4eff74b9053e42323ae1db2a114582af1731546faff214d5da allow-invoking-list-when-stdin-not-tty.patch
-5966b58b35aa43557d0dc36c00c11e07d23fb91249c5e4ce32bcbc9e9de259e691ab2537fa09886c1a1635f1042a4e09f91a7907069a79302c9ee76c95c3809c fix-list-tests-with-stdin.patch"
+sha512sums="b7a432b13e237ac1490cd82b87727f6a4385d5ea7b89f566dea61a3993e17909c03288f727326ada326e36eb47ea5f9eab67c097808ee42f52cc800a7f7e1738 zstd-1.3.7.tar.gz"
diff --git a/community/zstd/allow-invoking-list-when-stdin-not-tty.patch b/community/zstd/allow-invoking-list-when-stdin-not-tty.patch
deleted file mode 100644
index 47fa3e59a7..0000000000
--- a/community/zstd/allow-invoking-list-when-stdin-not-tty.patch
+++ /dev/null
@@ -1,67 +0,0 @@
-From 712a9fd9721c314f4b0238577d803b012845f6d2 Mon Sep 17 00:00:00 2001
-From: "W. Felix Handte" <w@felixhandte.com>
-Date: Fri, 29 Jun 2018 15:33:44 -0400
-Subject: [PATCH] Allow Invoking `zstd --list` When `stdin` is not a `tty`
-
-Also now returns an error when no inputs are given.
-
-New proposed behavior:
-
-```
-felix@odin:~/prog/zstd (list-stdin-check)$ ./zstd -l; echo $?
-No files given
-1
-felix@odin:~/prog/zstd (list-stdin-check)$ ./zstd -l Makefile.zst; echo $?
-Frames Skips Compressed Uncompressed Ratio Check Filename
- 1 0 3.08 KB 10.92 KB 3.544 XXH64 Makefile.zst
-0
-felix@odin:~/prog/zstd (list-stdin-check)$ ./zstd -l <Makefile.zst; echo $?
-zstd: --list does not support reading from standard input
-No files given
-1
-felix@odin:~/prog/zstd (list-stdin-check)$ ./zstd -l Makefile.zst <Makefile.zst; echo $?
-Frames Skips Compressed Uncompressed Ratio Check Filename
- 1 0 3.08 KB 10.92 KB 3.544 XXH64 Makefile.zst
-0
-felix@odin:~/prog/zstd (list-stdin-check)$
-```
----
- programs/fileio.c | 16 ++++++++++------
- 1 file changed, 10 insertions(+), 6 deletions(-)
-
-diff --git a/programs/fileio.c b/programs/fileio.c
-index 0175b3163..b4eed28d1 100644
---- a/programs/fileio.c
-+++ b/programs/fileio.c
-@@ -2017,21 +2017,25 @@ static int FIO_listFile(fileInfo_t* total, const char* inFileName, int displayLe
- }
-
- int FIO_listMultipleFiles(unsigned numFiles, const char** filenameTable, int displayLevel){
--
-- if (!IS_CONSOLE(stdin)) {
-- DISPLAYOUT("zstd: --list does not support reading from standard input\n");
-- return 1;
-+ unsigned u;
-+ for (u=0; u<numFiles;u++) {
-+ if (!strcmp (filenameTable[u], stdinmark)) {
-+ DISPLAYOUT("zstd: --list does not support reading from standard input\n");
-+ return 1;
-+ }
- }
-
- if (numFiles == 0) {
-+ if (!IS_CONSOLE(stdin)) {
-+ DISPLAYOUT("zstd: --list does not support reading from standard input\n");
-+ }
- DISPLAYOUT("No files given\n");
-- return 0;
-+ return 1;
- }
- if (displayLevel <= 2) {
- DISPLAYOUT("Frames Skips Compressed Uncompressed Ratio Check Filename\n");
- }
- { int error = 0;
-- unsigned u;
- fileInfo_t total;
- memset(&total, 0, sizeof(total));
- total.usesCheck = 1;
diff --git a/community/zstd/fix-list-tests-with-stdin.patch b/community/zstd/fix-list-tests-with-stdin.patch
deleted file mode 100644
index a10355448c..0000000000
--- a/community/zstd/fix-list-tests-with-stdin.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-From 8e7bdc18d62632adcee029b2f8f5013d11549dd7 Mon Sep 17 00:00:00 2001
-From: "W. Felix Handte" <w@felixhandte.com>
-Date: Fri, 29 Jun 2018 16:31:22 -0400
-Subject: [PATCH] Fix Tests of `--list` Behavior with `stdin`
-
----
- tests/playTests.sh | 10 ++++++++--
- 1 file changed, 8 insertions(+), 2 deletions(-)
-
-diff --git a/tests/playTests.sh b/tests/playTests.sh
-index 09a7377f2..aa5535d59 100755
---- a/tests/playTests.sh
-+++ b/tests/playTests.sh
-@@ -731,8 +731,14 @@ $ECHO "\n===> zstd --list/-l error detection tests "
- ! $ZSTD -lv tmp1*
- ! $ZSTD --list -v tmp2 tmp12.zst
-
--$ECHO "\n===> zstd --list/-l exits 1 when stdin is piped in"
--! echo "piped STDIN" | $ZSTD --list
-+$ECHO "\n===> zstd --list/-l errors when presented with stdin / no files"
-+! $ZSTD -l
-+! $ZSTD -l -
-+! $ZSTD -l < tmp1.zst
-+! $ZSTD -l - < tmp1.zst
-+! $ZSTD -l - tmp1.zst
-+! $ZSTD -l - tmp1.zst < tmp1.zst
-+$ZSTD -l tmp1.zst < tmp1.zst # but doesn't error just because stdin is not a tty
-
- $ECHO "\n===> zstd --list/-l test with null files "
- ./datagen -g0 > tmp5