aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Daudt <kdaudt@alpinelinux.org>2019-05-17 18:45:36 +0000
committerKevin Daudt <kdaudt@alpinelinux.org>2019-05-17 18:45:36 +0000
commitc1bba6bed3f43ff4146c001ad37563e5c13b68a8 (patch)
tree3a6c3bcfc83455a071cb805f9e8cfca753aa6795
parent13eed54fc68018e8a2fbb64386d09596cb53a9b9 (diff)
downloadaports-c1bba6bed3f43ff4146c001ad37563e5c13b68a8.tar.bz2
aports-c1bba6bed3f43ff4146c001ad37563e5c13b68a8.tar.xz
community/lua-copas: skip broken test
The test verified that a http -> http redirect works. The service they used (goo.gl), started to redirect to https first, so the result is (http -> https -> http), which the library does not allow. Skip this test for now.
-rw-r--r--community/lua-copas/APKBUILD6
-rw-r--r--community/lua-copas/skip-broken-test.patch20
2 files changed, 24 insertions, 2 deletions
diff --git a/community/lua-copas/APKBUILD b/community/lua-copas/APKBUILD
index 301782c2ea..1555011e0f 100644
--- a/community/lua-copas/APKBUILD
+++ b/community/lua-copas/APKBUILD
@@ -15,7 +15,8 @@ subpackages=""
source="$pkgname-$pkgver.tar.gz::https://github.com/keplerproject/$_pkgname/archive/v$_pkgver.tar.gz
default-tls1.2.patch
test-certs.patch
- ipv4-only.patch"
+ ipv4-only.patch
+ skip-broken-test.patch"
builddir="$srcdir/$_pkgname-$_pkgver"
# luajit is not available on s390x
@@ -66,4 +67,5 @@ _subpackage() {
sha512sums="dd83a513fbddb2f0164c3573b417623f5cc556413c4937be7e362f4c1667bad83391143e1bf609480726730ce488c4080e810f2ce12a98a7abb5293993c10182 lua-copas-2.0.2.tar.gz
d65a2d26ff025ec4b7c652bdf179a9f18078f736ec8f9166df077a47ec34cc4731cdeaa984d25c9556f332b36bfd9b4a7e2069284f8b63a4344e8a81b5ad72bc default-tls1.2.patch
f775cda7762f7924be8794ea2c77eb49740741a3cf9f67ca7b7e7563868d51f386ed473833e40b673af3aee5660a5e4767f43522bda1e0c38b2bf07c9df183df test-certs.patch
-4fb2b65f41869b9729cc4672eebbfb2745a2d01af1cd54341b8306f57510f98e118eac77c77a980f4c8e8b181b6fda150061dc39819269e9ee64bf07656dfd54 ipv4-only.patch"
+4fb2b65f41869b9729cc4672eebbfb2745a2d01af1cd54341b8306f57510f98e118eac77c77a980f4c8e8b181b6fda150061dc39819269e9ee64bf07656dfd54 ipv4-only.patch
+f661d6b5651496174d04bb26357ab37180b949d5c3a50d67fb090152ee3c63e37eda72754d8d6f2a84351569f74a2088ef4588e9f313583baec5057d11cc7170 skip-broken-test.patch"
diff --git a/community/lua-copas/skip-broken-test.patch b/community/lua-copas/skip-broken-test.patch
new file mode 100644
index 0000000000..ea48eeaf47
--- /dev/null
+++ b/community/lua-copas/skip-broken-test.patch
@@ -0,0 +1,20 @@
+diff --git a/tests/httpredirect.lua b/tests/httpredirect.lua
+index a47b42ba0f..1f23fd9e48 100644
+--- a/tests/httpredirect.lua
++++ b/tests/httpredirect.lua
+@@ -43,10 +43,11 @@ copas.addthread(function()
+ assert(headers.location == "https://github.com/brunoos/luasec")
+ print("http -> https redirect OK!")
+ copas.addthread(function()
+- local result, code, headers, status = doreq("http://goo.gl/tBfqNu") -- http --> http redirect
+- assert(tonumber(code)==200)
+- assert(headers.location == "http://www.thijsschreijer.nl/blog/")
+- print("http -> http redirect OK!")
++ -- Broken test:
++ -- local result, code, headers, status = doreq("http://goo.gl/tBfqNu") -- http --> http redirect
++ -- assert(tonumber(code)==200)
++ -- assert(headers.location == "http://www.thijsschreijer.nl/blog/")
++ -- print("http -> http redirect OK!")
+ copas.addthread(function()
+ local result, code, headers, status = doreq("https://goo.gl/tBfqNu") -- https --> http security test case
+ assert(result==nil and code == "Unallowed insecure redirect https to http")