aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-07-24 13:54:41 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-07-24 15:23:25 +0000
commitdeb2c1013b501182939180077b2ad948b3a383fb (patch)
tree8db6a92ccc6c27f24b3540776201ed7e64452261
parent6c2c90e42a986142c37f2ff970542a3d7082c158 (diff)
downloadaports-deb2c1013b501182939180077b2ad948b3a383fb.tar.bz2
aports-deb2c1013b501182939180077b2ad948b3a383fb.tar.xz
testing/py3-cached-property: new aport
Decorator for caching properties in classes https://github.com/pydanny/cached-property
-rw-r--r--testing/py3-cached-property/APKBUILD29
1 files changed, 29 insertions, 0 deletions
diff --git a/testing/py3-cached-property/APKBUILD b/testing/py3-cached-property/APKBUILD
new file mode 100644
index 0000000000..0433523516
--- /dev/null
+++ b/testing/py3-cached-property/APKBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=py3-cached-property
+pkgver=1.4.3
+pkgrel=0
+pkgdesc="Decorator for caching properties in classes"
+url="https://github.com/pydanny/cached-property"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="python3-dev"
+source="https://pypi.io/packages/source/c/cached-property/cached-property-$pkgver.tar.gz"
+builddir="$srcdir/cached-property-$pkgver"
+
+build() {
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 setup.py check
+}
+
+package() {
+ cd "$builddir"
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="e36e61af8f68a253573efbac666abd4e897142b3cec2499c50ba932924f8dad786979e1a297df7f0898310ae1aec1116615dff6e39c0b203e262628b450ad91f cached-property-1.4.3.tar.gz"