aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-12 14:58:25 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-12 19:42:37 -0300
commitf1ae7b0f2dd4784aa7a67138e7a5e1a69868bfb6 (patch)
treefe3004fcb3a0cea4fb9318f4fdfa99220fad6af5
parentbeb47e97b7817884b78b9fa5a9f6a8bca89989cf (diff)
downloadaports-f1ae7b0f2dd4784aa7a67138e7a5e1a69868bfb6.tar.bz2
aports-f1ae7b0f2dd4784aa7a67138e7a5e1a69868bfb6.tar.xz
testing/ocaml-cppo: upgrade to 1.6.6
-rw-r--r--testing/ocaml-cppo/APKBUILD23
-rw-r--r--testing/ocaml-cppo/ppc64le-asr.patch11
2 files changed, 9 insertions, 25 deletions
diff --git a/testing/ocaml-cppo/APKBUILD b/testing/ocaml-cppo/APKBUILD
index 2e55d7d563..8f34189e0e 100644
--- a/testing/ocaml-cppo/APKBUILD
+++ b/testing/ocaml-cppo/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
pkgname=ocaml-cppo
_pkgname=cppo
-pkgver=1.6.4
-pkgrel=5
+pkgver=1.6.6
+pkgrel=0
pkgdesc="C-style preprocessor for OCaml"
url="https://github.com/mjambon/cppo"
arch="all !x86 !armhf !armv7 !s390x" # limited by ocaml
@@ -12,27 +12,23 @@ makedepends="dune ocaml ocaml-ocamlbuild-dev ocaml-findlib opam"
options="textrels" # needed for ppc64le
subpackages="$pkgname-dev $pkgname-ocamlbuild"
source="$pkgname-$pkgver.tar.gz::https://github.com/mjambon/$_pkgname/archive/v$pkgver.tar.gz
- ppc64le-asr.patch
"
builddir="$srcdir/$_pkgname-$pkgver"
build() {
- cd "$builddir"
- jbuilder build --root . @install @DEFAULT
+ dune build --root . @install @DEFAULT
}
check() {
- cd "$builddir"
- jbuilder runtest
+ dune runtest
}
package() {
- cd "$builddir"
-
mkdir -p "$pkgdir"/usr/lib/ocaml
- jbuilder install \
- --destdir="$pkgdir/usr" \
- --libdir="$pkgdir/usr/lib/ocaml"
+ dune install \
+ --destdir="$pkgdir" \
+ --prefix=/usr \
+ --libdir=/usr/lib/ocaml
cd "$pkgdir"
@@ -64,5 +60,4 @@ dev() {
mv *.cmx *.cmxa *.mli "$subpkgdir"/$sitelib/
}
-sha512sums="89c6df66d597d929be7532ad82f0206b028bdbd79a0b4b39451bce3fa5bd63a80dce931d575f69bd7066de829347498c736657dfe9610b20700a652b9b542a4d ocaml-cppo-1.6.4.tar.gz
-718b0bfb4c0106e153bde9cf9a52f79858f113b3a8ffd6c9f887c2b2fec16dd330e952786e322a3532200e34ae533828d9d98c3fa784910cd3f92fec56250533 ppc64le-asr.patch"
+sha512sums="80b0d7a5f0f5b7d9d62ddfb204ebf5e3216c2926ba7f667b9ef10981de6a51cd6d670b7062769bf6fbdd163c1c8fb5426a74c31234ddc03ec94a75645bf469da ocaml-cppo-1.6.6.tar.gz"
diff --git a/testing/ocaml-cppo/ppc64le-asr.patch b/testing/ocaml-cppo/ppc64le-asr.patch
deleted file mode 100644
index 480a865dd5..0000000000
--- a/testing/ocaml-cppo/ppc64le-asr.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/src/cppo_parser.mly
-+++ b/src/cppo_parser.mly
-@@ -252,7 +252,7 @@
- | aexpr MOD aexpr { `Mod ($2, $1, $3) }
- | aexpr LSL aexpr { `Lsl ($1, $3) }
- | aexpr LSR aexpr { `Lsr ($1, $3) }
-- | aexpr ASR aexpr { `Lsr ($1, $3) }
-+ | aexpr ASR aexpr { `Asr ($1, $3) }
- | aexpr LAND aexpr { `Land ($1, $3) }
- | aexpr LOR aexpr { `Lor ($1, $3) }
- | aexpr LXOR aexpr { `Lxor ($1, $3) }