aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenrik Riomar <henrik.riomar@gmail.com>2018-11-12 21:21:07 +0100
committerHenrik Riomar <henrik.riomar@gmail.com>2018-11-12 21:41:48 +0100
commitf4a67e14a227861357140965c8a882f86def827a (patch)
treeab4d0c3111f9da1609f00bdefc8f5b71cd22b5cf
parent2d73723bae42b8175c01599216bf9d089ba0b04e (diff)
downloadaports-f4a67e14a227861357140965c8a882f86def827a.tar.bz2
aports-f4a67e14a227861357140965c8a882f86def827a.tar.xz
zfs-prune-snapshots: new aport
-rw-r--r--testing/zfs-prune-snapshots/0001-allow-passing-DESTDIR.patch36
-rw-r--r--testing/zfs-prune-snapshots/APKBUILD23
2 files changed, 59 insertions, 0 deletions
diff --git a/testing/zfs-prune-snapshots/0001-allow-passing-DESTDIR.patch b/testing/zfs-prune-snapshots/0001-allow-passing-DESTDIR.patch
new file mode 100644
index 0000000000..8ff30b26a1
--- /dev/null
+++ b/testing/zfs-prune-snapshots/0001-allow-passing-DESTDIR.patch
@@ -0,0 +1,36 @@
+From 6de152a1687ba5c2a5c522280942cd1f7647fc5c Mon Sep 17 00:00:00 2001
+From: Henrik Riomar <henrik.riomar@gmail.com>
+Date: Mon, 12 Nov 2018 21:29:10 +0100
+Subject: [PATCH] allow passing $(DESTDIR)
+
+---
+ Makefile | 10 ++++++----
+ 1 file changed, 6 insertions(+), 4 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index 271fd1d..af17196 100644
+--- a/Makefile
++++ b/Makefile
+@@ -20,13 +20,15 @@ clean:
+
+ .PHONY: install
+ install:
+- cp $(NAME) $(PREFIX)/bin/$(NAME)
+- cp man/$(MANPAGE) $(PREFIX)/share/man/man$(MAN_SECTION)/$(MANPAGE)
++ install -d $(DESTDIR)/$(PREFIX)/bin
++ install -d $(DESTDIR)/$(PREFIX)/share/man/man$(MAN_SECTION)
++ install -m 0755 $(NAME) $(DESTDIR)/$(PREFIX)/bin/$(NAME)
++ install -m 0644 man/$(MANPAGE) $(DESTDIR)/$(PREFIX)/share/man/man$(MAN_SECTION)/$(MANPAGE)
+
+ .PHONY: uninstall
+ uninstall:
+- rm -f $(PREFIX)/bin/$(NAME)
+- rm -f $(PREFIX)/share/man/man$(MAN_SECTION)/$(MANPAGE)
++ rm -f $(DESTDIR)/$(PREFIX)/bin/$(NAME)
++ rm -f $(DESTDIR)/$(PREFIX)/share/man/man$(MAN_SECTION)/$(MANPAGE)
+
+ .PHONY: check
+ check:
+--
+2.19.1
+
diff --git a/testing/zfs-prune-snapshots/APKBUILD b/testing/zfs-prune-snapshots/APKBUILD
new file mode 100644
index 0000000000..c0ec9096bc
--- /dev/null
+++ b/testing/zfs-prune-snapshots/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Henrik Riomar <henrik.riomar@gmail.com>
+# Maintainer: Henrik Riomar <henrik.riomar@gmail.com>
+pkgname=zfs-prune-snapshots
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Remove snapshots from one or more zpools that match given criteria"
+url="https://github.com/bahamas10/zfs-prune-snapshots"
+arch="noarch"
+license="MIT"
+subpackages="$pkgname-doc"
+options="!check" # check() requires shellcheck
+source="$pkgname-$pkgver.tar.gz::https://github.com/bahamas10/${pkgname}/archive/v${pkgver}.tar.gz
+ 0001-allow-passing-DESTDIR.patch
+ "
+builddir="$srcdir/$pkgname-$pkgver"
+
+package() {
+ cd "$builddir"
+ make install PREFIX="/usr" DESTDIR="$pkgdir"
+}
+
+sha512sums="4f4b157c93fdfeb2d517ce19622694ca2911bdb6c5735ec126a85b8fa2132752cdd91e8b5a2c79350d0e601c7f91a7d22b60d7e74abbe844b93bc6950d6218ab zfs-prune-snapshots-1.0.0.tar.gz
+9d671c39437bf5d83ef734ac0ef1650c1794634903cf8fc25c920b137cc466896bfbfa3b406110c431151534bd393c3b1235f957e58224d0009f7a3076f9160d 0001-allow-passing-DESTDIR.patch"