aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2020-03-10 10:29:05 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2020-03-20 18:39:57 +0100
commit23c86ac2c72d08bd396ebb8e074887060a8dff72 (patch)
tree772af2349d2ff6330ad65e889f3d5e3b9aed66ff
parent28b681820cbc07cde857ed721a21600a6040806b (diff)
downloadaports-23c86ac2c72d08bd396ebb8e074887060a8dff72.tar.bz2
aports-23c86ac2c72d08bd396ebb8e074887060a8dff72.tar.xz
main/linux-rpi: add check to verify kernel version
Verfify that the patch does not contain wrong kernel version ref #11219 (cherry picked from commit bf10e38a44b00626894d1240fa094675668060fa)
-rw-r--r--main/linux-rpi/APKBUILD5
1 files changed, 5 insertions, 0 deletions
diff --git a/main/linux-rpi/APKBUILD b/main/linux-rpi/APKBUILD
index 5709a43b9d..667ab6648c 100644
--- a/main/linux-rpi/APKBUILD
+++ b/main/linux-rpi/APKBUILD
@@ -165,6 +165,11 @@ build() {
unset LDFLAGS
for i in $_flavors; do
cd "$srcdir"/build-$i
+ local _kver=$(make kernelversion)
+ if [ "$_kver" != "$pkgver" ]; then
+ error "Version in Makefile ($_kver) does not correspond with pkgver ($pkgver)"
+ return 1
+ fi
make ARCH="$_carch" CC="${CC:-gcc}" \
KBUILD_BUILD_VERSION="$((pkgrel + 1 ))-Alpine"
done