aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-05-26 19:53:54 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-27 19:16:51 +0000
commit6e94b171737e9c3d83424319563e4892039fd8be (patch)
tree3c68b50092e1d61375eadbd090641e44cddc3b65
parent68fbf24e487669f987533c0df9fd384a7bb2a1c3 (diff)
downloadaports-6e94b171737e9c3d83424319563e4892039fd8be.tar.bz2
aports-6e94b171737e9c3d83424319563e4892039fd8be.tar.xz
main/truecrypt: remove
- Unmaintained since May 2014 - VeraCrypt is recommended alternative See: http://truecrypt.sourceforge.net/
-rw-r--r--main/truecrypt/APKBUILD52
-rw-r--r--main/truecrypt/execstack-fix.patch60
-rw-r--r--main/truecrypt/fix-invalid-characters.patch54
-rw-r--r--main/truecrypt/flush-stdout.patch11
-rw-r--r--main/truecrypt/libdl.patch11
-rw-r--r--main/truecrypt/truecrypt-arch-detection.patch15
-rw-r--r--main/truecrypt/truecrypt.desktop9
7 files changed, 0 insertions, 212 deletions
diff --git a/main/truecrypt/APKBUILD b/main/truecrypt/APKBUILD
deleted file mode 100644
index 669c72b60d..0000000000
--- a/main/truecrypt/APKBUILD
+++ /dev/null
@@ -1,52 +0,0 @@
-# Contributor: Natanael Copa <ncopa@alpinelinux.org>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=truecrypt
-pkgver=7.1a
-pkgrel=3
-pkgdesc="crypto"
-url="http://www.truecrypt.org/"
-arch="all"
-license="AS-IS"
-depends="device-mapper"
-depends_dev=""
-makedepends="nasm fuse-dev wxgtk2.8-dev"
-install=""
-subpackages=""
-source="https://sources.archlinux.org/other/tc/truecrypt-${pkgver}.tar.gz
- https://sources.archlinux.org/other/tc/pkcs-2.20.tar.gz
- fix-invalid-characters.patch
- flush-stdout.patch
- truecrypt-arch-detection.patch
- execstack-fix.patch
- libdl.patch
- truecrypt.desktop
- "
-
-builddir="$srcdir"/truecrypt-$pkgver-source
-
-build() {
- cd "$builddir"
- export CXXFLAGS="$CXXFLAGS -std=gnu++98"
- make PKCS11_INC="${srcdir}/pkcs-2.20" VERBOSE=1 \
- TC_EXTRA_CFLAGS="${CFLAGS}" \
- TC_EXTRA_CXXFLAGS="${CXXFLAGS}" \
- TC_EXTRA_LFLAGS="${LDFLAGS} -no-pie" \
- NOSTRIP=1 \
- || return 1
-}
-
-package() {
- cd "$builddir"
- install -Dm755 Main/truecrypt "$pkgdir"/usr/bin/truecrypt || return 1
- install -Dm644 "$srcdir"/truecrypt.desktop \
- "$pkgdir"/usr/share/applications/truecrypt.desktop
-}
-
-sha512sums="b5e766023168015cb91bfd85c9e2621055dd98408215e02704775861b5070c5a0234a00c64c1bf7faa34e6d0b51ac71cd36169dd7a6f84d7a34ad0cfa304796a truecrypt-7.1a.tar.gz
-d69d90040da5bc93f91041ed9404f1614a3b1bdc8eddc2bbbd19367f12d2416a6f3af8b0071d77e1273d627148c63ebe7ebe332878fbe9adb8ae33dcc723f473 pkcs-2.20.tar.gz
-da6a97ba4caa7b3e6455fa7f126282a5aa9bffb04d5cfd0f7e1358bf7177c68a4102632ae32121a670abe5bb63ab522e9c1bf8f0e7ad336954760089252f39d8 fix-invalid-characters.patch
-837c147bc934f7ac431792ea49eae208fc2dbf792ba8e84a8d9ed72e8fdb39caeffe02f1664f6354b1d8d473a3f74f2d15e012379cc9d6db149f48af99205f0b flush-stdout.patch
-fac6963c65720f0b13486ff22bdcc2e31e78c39ede2b9561b2c4037ef2c0375f04c4d51dc6067c37aaeb664c3ed70e5747488389737c41807680750c26a8f084 truecrypt-arch-detection.patch
-a5d843a0eac7f14668e8c722a85ab8d871f64cf0488a9d9acd33235f077e74af3d191a3a6c18ddd25e8b487ef56b3afdbb6f3d7877113687a8101a1b855c366e execstack-fix.patch
-83a8daefe3137581daab0aed599a9b47ec19a7403bdca424eb86fce482ddefb0a513ad18522a7d9b03d18fb771502ef378c76626521d8184c2e200e23d499737 libdl.patch
-1ac13f1888319d6d2f10e03a61e22d68e5fe4a61bbdf8ad364a0fe6f6712cc53dbc1a98fff3fda2ecd57dbe67fcc24fb358c0805ab47eaa12cf14d48f1067e51 truecrypt.desktop"
diff --git a/main/truecrypt/execstack-fix.patch b/main/truecrypt/execstack-fix.patch
deleted file mode 100644
index d72fe0e14a..0000000000
--- a/main/truecrypt/execstack-fix.patch
+++ /dev/null
@@ -1,60 +0,0 @@
---- ./Crypto/Aes_hw_cpu.asm.old 2011-06-01 17:12:53.078000001 -0400
-+++ ./Crypto/Aes_hw_cpu.asm 2011-06-01 17:12:53.080000002 -0400
-@@ -328,3 +328,12 @@
-
-
- %endif ; __BITS__ != 16
-+ %ifidn __OUTPUT_FORMAT__,elf
-+ section .note.GNU-stack noalloc noexec nowrite progbits
-+ %endif
-+ %ifidn __OUTPUT_FORMAT__,elf32
-+ section .note.GNU-stack noalloc noexec nowrite progbits
-+ %endif
-+ %ifidn __OUTPUT_FORMAT__,elf64
-+ section .note.GNU-stack noalloc noexec nowrite progbits
-+ %endif
---- ./Crypto/AesSmall_x86.asm.old 2011-06-01 17:12:53.084000002 -0400
-+++ ./Crypto/AesSmall_x86.asm 2011-06-01 17:12:53.086000002 -0400
-@@ -1442,3 +1442,12 @@
- db v8(0xe1),v8(0x69),v8(0x14),v8(0x63),v8(0x55),v8(0x21),v8(0x0c),v8(0x7d)
-
- %endif
-+ %ifidn __OUTPUT_FORMAT__,elf
-+ section .note.GNU-stack noalloc noexec nowrite progbits
-+ %endif
-+ %ifidn __OUTPUT_FORMAT__,elf32
-+ section .note.GNU-stack noalloc noexec nowrite progbits
-+ %endif
-+ %ifidn __OUTPUT_FORMAT__,elf64
-+ section .note.GNU-stack noalloc noexec nowrite progbits
-+ %endif
---- ./Crypto/Aes_x64.asm.old 2011-06-01 17:12:53.090000002 -0400
-+++ ./Crypto/Aes_x64.asm 2011-06-01 17:12:53.092000002 -0400
-@@ -905,3 +905,12 @@
- %endif
-
- %endif
-+ %ifidn __OUTPUT_FORMAT__,elf
-+ section .note.GNU-stack noalloc noexec nowrite progbits
-+ %endif
-+ %ifidn __OUTPUT_FORMAT__,elf32
-+ section .note.GNU-stack noalloc noexec nowrite progbits
-+ %endif
-+ %ifidn __OUTPUT_FORMAT__,elf64
-+ section .note.GNU-stack noalloc noexec nowrite progbits
-+ %endif
---- ./Crypto/Aes_x86.asm.old 2011-06-01 17:12:53.096000002 -0400
-+++ ./Crypto/Aes_x86.asm 2011-06-01 17:12:53.097000002 -0400
-@@ -644,3 +644,12 @@
- do_exit
-
- %endif
-+ %ifidn __OUTPUT_FORMAT__,elf
-+ section .note.GNU-stack noalloc noexec nowrite progbits
-+ %endif
-+ %ifidn __OUTPUT_FORMAT__,elf32
-+ section .note.GNU-stack noalloc noexec nowrite progbits
-+ %endif
-+ %ifidn __OUTPUT_FORMAT__,elf64
-+ section .note.GNU-stack noalloc noexec nowrite progbits
-+ %endif
diff --git a/main/truecrypt/fix-invalid-characters.patch b/main/truecrypt/fix-invalid-characters.patch
deleted file mode 100644
index f8e54f31dc..0000000000
--- a/main/truecrypt/fix-invalid-characters.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 646679da4d79bf7f8af22c44c7ae8498086a88a6 Mon Sep 17 00:00:00 2001
-From: Mounir IDRASSI <mounir.idrassi@idrix.fr>
-Date: Fri, 18 Mar 2016 16:25:48 +0100
-Subject: [PATCH] Linux: Completely fix gcc-5 "Invalid characters encountered"
- issue on mount. It was caused by an issue of gcc-5 STL implementation that is
- causing char* pointers retrieved from std::string using c_str method to
- become invalid in the child of a child process (after two fork calls). The
- workaround is to first copy the std:string values in the child before calling
- the second fork.
-
----
- Platform/Unix/Process.cpp | 24 ++++++++++++++++++++++--
- 1 file changed, 22 insertions(+), 2 deletions(-)
-
-diff --git a/Platform/Unix/Process.cpp b/Platform/Unix/Process.cpp
-index 388bda6..0770364 100644
---- a/Platform/Unix/Process.cpp
-+++ b/Platform/Unix/Process.cpp
-@@ -53,13 +53,33 @@ namespace VeraCrypt
- try
- {
- int argIndex = 0;
-+ /* Workaround for gcc 5.X issue related to the use of STL (string and list) with muliple fork calls.
-+ *
-+ * The char* pointers retrieved from the elements of parameter "arguments" are no longer valid after
-+ * a second fork is called. "arguments" was created in the parent of the current child process.
-+ *
-+ * The only solution is to copy the elements of "arguments" parameter in a local string array on this
-+ * child process and then use char* pointers retrieved from this local copies before calling fork.
-+ *
-+ * gcc 4.x doesn't suffer from this issue.
-+ *
-+ */
-+ string argsCopy[array_capacity (args)];
- if (!execFunctor)
-- args[argIndex++] = const_cast <char*> (processName.c_str());
-+ {
-+ argsCopy[argIndex++] = processName;
-+ }
-
- foreach (const string &arg, arguments)
- {
-- args[argIndex++] = const_cast <char*> (arg.c_str());
-+ argsCopy[argIndex++] = arg;
- }
-+
-+ for (int i = 0; i < argIndex; i++)
-+ {
-+ args[i] = const_cast <char*> (argsCopy[i].c_str());
-+ }
-+
- args[argIndex] = nullptr;
-
- if (inputData)
diff --git a/main/truecrypt/flush-stdout.patch b/main/truecrypt/flush-stdout.patch
deleted file mode 100644
index 24809bae10..0000000000
--- a/main/truecrypt/flush-stdout.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- truecrypt-7.1a-source/Main/TextUserInterface.cpp.orig 2017-03-10 14:07:32.880449234 +0200
-+++ truecrypt-7.1a-source/Main/TextUserInterface.cpp 2017-03-10 14:11:28.843128874 +0200
-@@ -1247,6 +1247,8 @@
- if (!TextInputStream.get() || feof (stdin) || ferror (stdin))
- throw UserAbort (SRC_POS);
-
-+ wcout.flush();
-+
- line = TextInputStream->ReadLine();
-
- if (ferror (stdin) || (line.empty() && feof (stdin)))
diff --git a/main/truecrypt/libdl.patch b/main/truecrypt/libdl.patch
deleted file mode 100644
index f9aa888629..0000000000
--- a/main/truecrypt/libdl.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- ./Makefile.orig
-+++ ./Makefile
-@@ -39,7 +39,7 @@
- export CXXFLAGS := -Wall -Wno-unused-parameter
- C_CXX_FLAGS := -MMD -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_LARGE_FILES -I$(BASE_DIR) -I$(BASE_DIR)/Crypto
- export ASFLAGS := -Ox -D __GNUC__
--export LFLAGS :=
-+export LFLAGS := -ldl
-
- export PKG_CONFIG_PATH ?= /usr/local/lib/pkgconfig
-
diff --git a/main/truecrypt/truecrypt-arch-detection.patch b/main/truecrypt/truecrypt-arch-detection.patch
deleted file mode 100644
index bc16a2a36e..0000000000
--- a/main/truecrypt/truecrypt-arch-detection.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-diff -urN truecrypt-7.0a-source/Makefile truecrypt-7.0a-source.fixed/Makefile
---- truecrypt-7.0a-source/Makefile 2010-09-05 10:32:10.000000000 -0400
-+++ truecrypt-7.0a-source.fixed/Makefile 2011-07-05 21:41:50.296437879 -0400
-@@ -120,10 +120,7 @@
-
- export CPU_ARCH ?= unknown
-
--ARCH = $(shell uname -p)
--ifeq "$(ARCH)" "unknown"
-- ARCH = $(shell uname -m)
--endif
-+ARCH = $(shell uname -m)
-
- ifneq (,$(filter i386 i486 i586 i686 x86,$(ARCH)))
- CPU_ARCH = x86
diff --git a/main/truecrypt/truecrypt.desktop b/main/truecrypt/truecrypt.desktop
deleted file mode 100644
index 53626f29ff..0000000000
--- a/main/truecrypt/truecrypt.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Type=Application
-Exec=truecrypt
-Icon=truecrypt
-Comment=On-the-fly encryption
-Terminal=false
-Name=TrueCrypt
-StartupNotify=true
-Categories=System;