aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoropal hart <opal@wowana.me>2019-04-06 10:46:46 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-04-22 07:01:31 +0000
commit7ef569012025ef959f3367daff6638ea3cfa4fbc (patch)
tree2ce5fa6895a199f34a30e3d0d548a5626e9b127a
parent3e4eb66a51b846ef22bd392eb4cfbf5bc7bbfa65 (diff)
downloadaports-7ef569012025ef959f3367daff6638ea3cfa4fbc.tar.bz2
aports-7ef569012025ef959f3367daff6638ea3cfa4fbc.tar.xz
bump testing/keepassxc to 2.4.0
also use the release tarball rather than the archive, which gets rid of the unsightly developer's warning in the keepass UI. have to compile WITH_XC_KEESHARE=ON per issue documented on <https://github.com/keepassxreboot/keepassxc/pull/2810>; should be fixed in keepass 2.4.1
-rw-r--r--testing/keepassxc/APKBUILD9
1 files changed, 5 insertions, 4 deletions
diff --git a/testing/keepassxc/APKBUILD b/testing/keepassxc/APKBUILD
index 7b3e6e51f9..81407907a8 100644
--- a/testing/keepassxc/APKBUILD
+++ b/testing/keepassxc/APKBUILD
@@ -5,7 +5,7 @@
# Maintainer: Orson Teodoro <orsonteodoro@hotmail.com>
pkgname=keepassxc
-pkgver=2.3.4
+pkgver=2.4.0
pkgrel=0
pkgdesc="Community-driven port of the Windows application Keepass Password Safe"
url="https://keepassxc.org/"
@@ -13,9 +13,9 @@ arch="all"
license="GPL-3.0 BSD-3-Clause CC0-1.0 LGPL-2.0-only LGPL-2.1-only \
LGPL-3.0-or-later Nokia-Qt-exception-1.1 MIT BSL-1.0"
depends="icu-libs"
-makedepends="cmake qt5-qtbase-dev qt5-qttools-dev libxtst-dev \
+makedepends="cmake qt5-qtbase-dev qt5-qttools-dev libxtst-dev qt5-qtsvg-dev libqrencode-dev \
qt5-qtx11extras-dev libgcrypt-dev libgpg-error-dev argon2-dev zlib-dev"
-source="$pkgname-$pkgver.tar.gz::https://github.com/keepassxreboot/$pkgname/archive/$pkgver.tar.gz"
+source="https://github.com/keepassxreboot/$pkgname/releases/download/$pkgver/$pkgname-$pkgver-src.tar.xz"
builddir="$srcdir"/$pkgname-$pkgver
subpackages="$pkgname-doc"
@@ -24,6 +24,7 @@ build() {
cmake -DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=/usr/lib \
-DCMAKE_BUILD_TYPE=Release \
+ -DWITH_XC_KEESHARE=ON \
-DKEEPASSXC_BUILD_TYPE=Release .
make
}
@@ -44,4 +45,4 @@ check() {
make test
}
-sha512sums="630d4d1f77c44c27f3d27a1908c80a94265af9aae8774d80726f86f635eee6a10d8a426b0157ad03efe9f5111d7d67f5c785962ec3715c8374b9f38788fab863 keepassxc-2.3.4.tar.gz"
+sha512sums="b7295f5983237606efd236955dc73d477992d944e547eeb2c3a267d846e70ce6f83e489f58e3bd9b5bb21decabd9052a4ea7b98bd98e8283abbb678ae19e5559 keepassxc-2.4.0-src.tar.xz"