aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-08 18:28:06 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-08 19:12:07 -0300
commit95a36ea9a90486e332e689ba8013860784cae745 (patch)
tree0a8287c158ff9fb5f78618b649cf0ebf577dd8e7
parent1eebd9dc7f4eb49921286a7984f87aa150f6d16d (diff)
downloadaports-95a36ea9a90486e332e689ba8013860784cae745.tar.bz2
aports-95a36ea9a90486e332e689ba8013860784cae745.tar.xz
testing/py3-sphinxcontrib-textstyle: upgrade to 0.2.3
-rw-r--r--testing/py3-sphinxcontrib-textstyle/APKBUILD35
1 files changed, 10 insertions, 25 deletions
diff --git a/testing/py3-sphinxcontrib-textstyle/APKBUILD b/testing/py3-sphinxcontrib-textstyle/APKBUILD
index 9071f9a148..af1d7ee4f3 100644
--- a/testing/py3-sphinxcontrib-textstyle/APKBUILD
+++ b/testing/py3-sphinxcontrib-textstyle/APKBUILD
@@ -1,41 +1,26 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
-pkgname=py-sphinxcontrib-textstyle
+pkgname=py3-sphinxcontrib-textstyle
_pkgname=sphinxcontrib-textstyle
-pkgver=0.2.0
+pkgver=0.2.3
pkgrel=0
pkgdesc="Sphinx textstyle extension"
url="https://pypi.python.org/pypi/sphinxcontrib-textstyle"
arch="noarch"
-license="BSD"
-depends="python2 py-sphinx"
-depends_dev=""
-makedepends="python2-dev py-setuptools"
-install=""
-subpackages=""
+license="BSD-2-Clause"
+depends="python3 py3-sphinx py3-setuptools"
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+replaces="py-sphinxcontrib-textstyle" # Backwards compatibility
+provides="py-sphinxcontrib-textstyle=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="e24cdc85bc1353a04aa9e3cf25046b21 sphinxcontrib-textstyle-0.2.0.tar.gz"
-sha256sums="9369879ba5cfffadf1f0ee163247b7aff1e8e22d4cf56270c168e6ce4f0eab45 sphinxcontrib-textstyle-0.2.0.tar.gz"
-sha512sums="fe49ead9abfca36e15b3ed4e42ebacb734af6cfaf935a4f55781f53badf58275d4ae694c3d759961714a15cb3a7eb6cfe93cd41eca2b5556531610dad1edc4e0 sphinxcontrib-textstyle-0.2.0.tar.gz"
+sha512sums="0b6ba8d50a97439e2ab57de336157f942876ee9c8203e8ff5be415fdc340bacab15fb461579457209e616c7fa1eec2c42720d5b0e3726c83a123e700b096fb4d sphinxcontrib-textstyle-0.2.3.tar.gz"