aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Postnikov <apostnikov@gmail.com>2018-10-21 00:12:07 +0300
committerAndy Postnikov <apostnikov@gmail.com>2018-10-21 00:19:37 +0300
commitbac9f295a45641e1489eaff392852884b055e7cb (patch)
tree1229175745821c801b87697f0fc7f78f5ea76858
parent32ff6fdffe40025b287cef87adcb1e2be78b4955 (diff)
downloadaports-bac9f295a45641e1489eaff392852884b055e7cb.tar.bz2
aports-bac9f295a45641e1489eaff392852884b055e7cb.tar.xz
community/php7-pecl-mcrypt: renamed from php7-mcrypt, modernize
-rw-r--r--community/php7-pecl-mcrypt/APKBUILD (renamed from community/php7-mcrypt/APKBUILD)12
1 files changed, 7 insertions, 5 deletions
diff --git a/community/php7-mcrypt/APKBUILD b/community/php7-pecl-mcrypt/APKBUILD
index f611e4e05e..e814689744 100644
--- a/community/php7-mcrypt/APKBUILD
+++ b/community/php7-pecl-mcrypt/APKBUILD
@@ -1,16 +1,18 @@
# Maintainer: TBK <alpine@jjtc.eu>
-pkgname=php7-mcrypt
+pkgname=php7-pecl-mcrypt
_pkgreal=mcrypt
pkgver=1.0.1
-pkgrel=0
+pkgrel=1
pkgdesc="Provides bindings for the unmaintained libmcrypt."
url="https://pecl.php.net/package/mcrypt"
arch="all"
license="PHP"
-depends=""
+depends="php7-common"
makedepends="pcre-dev php7-dev autoconf libmcrypt-dev"
source="https://pecl.php.net/get/$_pkgreal-$pkgver.tgz"
builddir="$srcdir/$_pkgreal-$pkgver"
+provides="php7-mcrypt=$pkgver-r$pkgrel" # for backward compatibility
+replaces="php7-mcrypt" # for backward compatibility
build() {
cd "$builddir"
@@ -23,8 +25,8 @@ build() {
check() {
cd "$builddir"
- # One test fails with PHP 7.2.3
- rm tests/bug8040.phpt
+ # One test fails with PHP 7.2.11
+ rm tests/bug8040.phpt
make NO_INTERACTION=1 REPORT_EXIT_STATUS=1 test
}