aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2018-12-14 07:32:31 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-12-14 07:32:41 +0000
commitbc082c541be451337303de3ce5b649c395a1d54d (patch)
treebfb9ba45ba9a2b5ecd8531983c952a6c9088e653
parent18d079012147a2ab04c392be4da712eae76b5bf4 (diff)
downloadaports-bc082c541be451337303de3ce5b649c395a1d54d.tar.bz2
aports-bc082c541be451337303de3ce5b649c395a1d54d.tar.xz
main/perl-dbd-mysql: upgrade to 4.049
-rw-r--r--main/perl-dbd-mysql/APKBUILD11
-rw-r--r--main/perl-dbd-mysql/DBD-mysql-4.043-Fix-build-failures-for-MariaDB-10.2.patch71
2 files changed, 4 insertions, 78 deletions
diff --git a/main/perl-dbd-mysql/APKBUILD b/main/perl-dbd-mysql/APKBUILD
index 06b3bd1d4e..e280fe1005 100644
--- a/main/perl-dbd-mysql/APKBUILD
+++ b/main/perl-dbd-mysql/APKBUILD
@@ -3,17 +3,15 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=perl-dbd-mysql
_pkgname=DBD-mysql
-pkgver=4.046
-pkgrel=2
+pkgver=4.049
+pkgrel=0
pkgdesc="Perl CPAN DBD::Mysql module"
url="http://search.cpan.org/~capttofu/DBD-mysql/"
arch="all"
license="GPL PerlArtistic"
depends="perl perl-dbi"
makedepends="perl perl-dev mariadb-connector-c-dev zlib-dev perl-devel-checklib"
-source="https://cpan.metacpan.org/authors/id/C/CA/CAPTTOFU/DBD-mysql-$pkgver.tar.gz
- DBD-mysql-4.043-Fix-build-failures-for-MariaDB-10.2.patch
- "
+source="https://cpan.metacpan.org/authors/id/D/DV/DVEEDEN/DBD-mysql-$pkgver.tar.gz"
subpackages="$pkgname-doc"
options="!check" # requires a running dbms
builddir="$srcdir"/${_pkgname}-$pkgver
@@ -41,5 +39,4 @@ check() {
make test
}
-sha512sums="57b3243a724ac21a11b6eea10aa1cfc821f295cb5bf44f9eaabeb979d3f8e1f7f5e00d40b144a16688d0a358c82c2bb00f630e925e176f29a9ca84b8ee7fb9cc DBD-mysql-4.046.tar.gz
-66916fbe21d16f2064c95d4081d183eec554804d018dd43a0a02ba8e702f86820d4ee4997536c774f4f61e53929f83abcd4642db488bdc632d25eea94c8eac0f DBD-mysql-4.043-Fix-build-failures-for-MariaDB-10.2.patch"
+sha512sums="e0e1376927be3afd366e3fff4e221e8ecc57339644c8e420e34b9e45a802e2a2a2c294fdd7ca0c59a84d6236f7d0e8fd2000b5da8f6839444d3318e3b7d9b422 DBD-mysql-4.049.tar.gz"
diff --git a/main/perl-dbd-mysql/DBD-mysql-4.043-Fix-build-failures-for-MariaDB-10.2.patch b/main/perl-dbd-mysql/DBD-mysql-4.043-Fix-build-failures-for-MariaDB-10.2.patch
deleted file mode 100644
index e61e305d5b..0000000000
--- a/main/perl-dbd-mysql/DBD-mysql-4.043-Fix-build-failures-for-MariaDB-10.2.patch
+++ /dev/null
@@ -1,71 +0,0 @@
-From 051748825e77172677d9e3b319b870c3c0a70a38 Mon Sep 17 00:00:00 2001
-From: Jitka Plesnikova <jplesnik@redhat.com>
-Date: Fri, 14 Jul 2017 14:13:50 +0200
-Subject: [PATCH] Fix build failures for MariaDB 10.2
-MIME-Version: 1.0
-Content-Type: text/plain; charset=UTF-8
-Content-Transfer-Encoding: 8bit
-
-<mariadb_version.h> does not exist in mariadb-5.5.26. Do not include
-it explicitly. Instead rely on including <mysql.h> that transitively
-includes <mariadb_version.h> or <mysql_version.h>. This makes this
-patch more portable.
-
-Signed-off-by: Petr Písař <ppisar@redhat.com>
----
- dbdimp.c | 7 +++++++
- mysql.xs | 4 ++--
- 2 files changed, 9 insertions(+), 2 deletions(-)
-
-# Fixed in 4.045
-#diff --git a/dbdimp.c b/dbdimp.c
-#index 71251da..97fa9c4 100644
-#--- a/dbdimp.c
-#+++ b/dbdimp.c
-#@@ -2104,6 +2104,9 @@ MYSQL *mysql_dr_connect(
-#
-# if (result)
-# {
-#+#if MYSQL_VERSION_ID >= 50013
-#+ my_bool reconnect= 1;
-#+#endif
-# #if MYSQL_VERSION_ID >=SERVER_PREPARE_VERSION
-# /* connection succeeded. */
-# /* imp_dbh == NULL when mysql_dr_connect() is called from mysql.xs
-#@@ -2122,7 +2125,11 @@ MYSQL *mysql_dr_connect(
-# we turn off Mysql's auto reconnect and handle re-connecting ourselves
-# so that we can keep track of when this happens.
-# */
-#+#if MYSQL_VERSION_ID >= 50013
-#+ mysql_options(result, MYSQL_OPT_RECONNECT, &reconnect);
-#+#else
-# result->reconnect=0;
-#+#endif
-# }
-# else {
-# /*
-diff --git a/mysql.xs b/mysql.xs
-index 60cf9c6..750c763 100644
---- a/mysql.xs
-+++ b/mysql.xs
-@@ -787,7 +787,7 @@ dbd_mysql_get_info(dbh, sql_info_type)
- D_imp_dbh(dbh);
- IV type = 0;
- SV* retsv=NULL;
--#if !defined(MARIADB_BASE_VERSION) && MYSQL_VERSION_ID >= 50709
-+#if MYSQL_VERSION_ID >= 50709
- /* MariaDB 10 is not MySQL source level compatible so this only applies to MySQL*/
- IV buffer_len;
- #endif
-@@ -819,7 +819,7 @@ dbd_mysql_get_info(dbh, sql_info_type)
- retsv = newSVpvn("`", 1);
- break;
- case SQL_MAXIMUM_STATEMENT_LENGTH:
--#if !defined(MARIADB_BASE_VERSION) && MYSQL_VERSION_ID >= 50709
-+#if MYSQL_VERSION_ID >= 50709
- /* MariaDB 10 is not MySQL source level compatible so this
- only applies to MySQL*/
- /* mysql_get_option() was added in mysql 5.7.3 */
---
-2.13.6
-