aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-30 01:41:59 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-09-03 15:44:45 +0000
commitda2f6605523dd62703274e61b56d3db6883ba716 (patch)
tree7ddbdbfab11fbe014bfda36ee7293f9eacfcb0e2
parentef07d937feab8f57a0ce7bbb76dc54ec4b624d21 (diff)
downloadaports-da2f6605523dd62703274e61b56d3db6883ba716.tar.bz2
aports-da2f6605523dd62703274e61b56d3db6883ba716.tar.xz
main/py3-django-widget-tweaks: drop py2
-rw-r--r--main/py3-django-widget-tweaks/APKBUILD43
1 files changed, 21 insertions, 22 deletions
diff --git a/main/py3-django-widget-tweaks/APKBUILD b/main/py3-django-widget-tweaks/APKBUILD
index 8b74d2d228..8154d392b4 100644
--- a/main/py3-django-widget-tweaks/APKBUILD
+++ b/main/py3-django-widget-tweaks/APKBUILD
@@ -1,35 +1,34 @@
# Contributor: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
# Maintainer: Kaarle Ritvanen <kaarle.ritvanen@datakunkku.fi>
-pkgname=py-django-widget-tweaks
+pkgname=py3-django-widget-tweaks
pkgver=1.4.5
pkgrel=0
pkgdesc="Tweak the form field rendering in templates, not in python-level form definitions"
-url=https://github.com/kmike/django-widget-tweaks
-arch=noarch
-license=MIT
-depends=py-django
-makedepends=py-setuptools
-source="https://files.pythonhosted.org/packages/source/d/django-widget-tweaks/django-widget-tweaks-$pkgver.tar.gz"
+url="https://github.com/jazzband/django-widget-tweaks"
+arch="noarch"
+license="MIT"
+depends="py3-django"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/jazzband/django-widget-tweaks/archive/$pkgver.tar.gz"
-_builddir=$srcdir/django-widget-tweaks-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir/django-widget-tweaks-$pkgver"
+
+replaces="py-django-widget-tweaks" # Backwards compatibility
+provides="py-django-widget-tweaks=$pkgver-r$pkgrel" # Backwards compatibility
build() {
- cd "$_builddir"
- ./setup.py build
+ cd "$builddir"
+ python3 setup.py build
+}
+
+check() {
+ cd "$builddir"
+ python3 runtests.py
}
package() {
- cd "$_builddir"
- ./setup.py install --root "$pkgdir"
+ cd "$builddir"
+ python3 setup.py install --root "$pkgdir"
}
-sha512sums="5621f611a794a59319ce0a290c53334ee51df11ed1e1c2e9db4ddf5ce44f3c52e299eea0afc5577e7ed43eb0bfe4bab2ef5b5cf0d45fc0608b1573936148aa72 django-widget-tweaks-1.4.5.tar.gz"
+sha512sums="e35c5360bfe016c470cd50b8d500d9e3f8648e1a909508c5a516ecf82d98d2808432bb2a5738ec2dd6d1e77e63e9beb454237ba44e5a4060cf812ddd43ace18e py3-django-widget-tweaks-1.4.5.tar.gz"